Aeotec Smart Switch 6 and 7 unresponsive last 2 days? (12 April 2023)

Has anyone else noticed all their Aeotec Smart Switch 6 and 7 models go unresponsive the past several days? At first I thought it was something with automations but after muttering things under my breath for about the 27th time since this weekend, it clicked (in my brain, that is)… Only those models of switches are not responding to on/off commands from the app.

No amount of rebooting the hub or zwave repairs have helped. I noticed there was a note in the firmware release notes about switches and wondered if that might be a correlation, so I have opened a support ticket.

If you are seeing the same, would you let me know and also open a ticket to report the problem? Thanks!

Also, I noticed something really interesting. The current power load is still being dynamically reported in the app correctly. It only seems to be the on/off function that is affected.

Edit: updated title to match behavior change. Forgot which day of the week it was. Behavior started Monday or Tuesday.

Edit: SmartThings Support just answered my first support ticket 4/14 5pm. They require a picture of my hub to be able to troubleshoot the problem further: :man_facepalming:

  1. Photo of your Hub’s serial number and LED status

Which edge driver are you using?

A couple of people reported recent problems with Fibaro Switches over the same time., And @orangebucket noted that it appeared the stock Driver had been modified to remove a button capability that it had previously had. That could definitely make a device work differently.

So I’m just wondering if there might be a similar change to the aeotec. But it may just be a coincidence of timing. :thinking:

1 Like

I think you’re on to something. I was using the driver names “Aeotec Smart Switch 6 (Advanced Options)”(and the driver named 7 for the model 7) by Mike McMahon (CommanderQ).

Switching back to stock Edge drivers got the model 6 switches working again, but the on/off for the model 7 switches is still unresponsive.


Aeotec have developed their own Edge drivers for some products, perhaps they might help?

1 Like

I later realised that the Fibaro double switch, which seemed to be the sub-driver affected by the change, was one of the new fingerprints being added to the production default driver. Presumably this means the code has only been available in the production beta channel until now.


Unfortunately, they do not publish their own for their late model switches. Instead, they provide a link to the contributor who had already created drivers and skipped making their own I’ve contacted the developer of the drivers to let him know of the issue and provided the details I have about it.


I am also experiencing this problem starting at some point on 4/11. Interestingly, the LEDs turn on/off like they should, but this does not affect (or reflect) the power state. For one device, I reset it, changed drivers from the standard Z-Wave Switch driver to CommanderQ’s advanced Edge driver but it still does not turn on or off. All other Z-Wave devices are working without problems.

I also will be opening a support ticket.


Yesterday all of my Aeotec Smart Switch 7 plug-in devices stopped working for my SmartThings hub. I believe that the SmartThings hub update is the culprit. I tried a total power-off of the house as well as several z-wave network repairs. All to no avail. I tried to add a new Aeotec Smart Switch 7. Same thing - it did not work. Although the SmartThings application reports the device is communicating and alive, toggling it on/off takes time, is acknowledged, but the light on the on/off button of the device simply flickers briefly but does not actuate the device being controlled.

VERY frustrating to have an update like this take out most of the lights in your house!

I’ve submitted two tickets…original one and an update with my attempt to add. Hopefully this will get resolved soon.

Aeotec does NOT seem to have a driver for Smart Switch 7 but, as someone else noted, point to another user who developed one to be able to control the advanced features. (I updated mine so it doesn’t barrage the network with power reports every few minutes.) As a test, I went back to the ‘generic’ driver, and same things - still didn’t work.

Bottom line - the SmartThings Hub software doesn’t seem to work with Aeotec Smart Switch 7 plug-in gizmos.

Hoping for a quick fix because 1/2 of my house no longer works!!!

1 Like

Having the same problems. Where does the support ticket need to land? With Smartthings or Aeotec?

Could this be relevant?

Cherry pick/virtual switch aeotec smart 6 by greens · Pull Request #652 · SmartThingsCommunity/SmartThingsEdgeDrivers (

Maybe the 7 needed addressing as well?

1 Like

Just heard back from Aeotec. They can replicate the issue and said it is the SmartThings hub issuing an LED dim command rather than a switch command. They have reached out to SmartThings and suggested we do the same:


Just got this custom edge driver from Chris Cheng at Aeotec and it fixes the problem until SmartThings fixes the standard one:

Thanks for the update JBH_CO.

I think this may have pushed me over the edge to move to Home Assistant now. Nothing like having an angry family that can’t turn devices on and off…

Aeotec provided me with a new driver but the forum detected it as spam and blocked my post.

1 Like

My Home Assistant didn’t work either because the problem is with the hub.

Is it possible to reference your ticket with aeotec so we could to call them and reference it and quickly get the driver?

You just need the driver found at the link I provided. It was an earlier attempt to post it that was blocked (sorry, I wasn’t very clear about that earlier). And I don’t know if they provided a fixed driver for the 6, only the 7 US and EU.

Unfortunately, you will have to go to each Smart Switch 7 device in SmartThings to change the driver.

Let me know if you are having trouble with the link or changing drivers.

Meanwhile, SmartThings is telling me to try rebooting my Hub. :unamused:

Edit: just re-read earlier posts and saw that you are already familiar with changing drivers, so this should get you up and running right away

1 Like

AEOTEC updated the edge drivers and there is an update for Smart Switch 7 US that does a work-around for the issue. Access the AEOTEC channel and select the Smart Switch 7 US, enroll it for your hub, then after that, select each switch and change the driver to be the AEOTEC one using the ‘change driver’ option for each device.

The basic issue still is with the hub, but this will get you operational at least.

Kudos to Aeotec.

1 Like

@jonj, thanks for posting this - it is helpful as a workaround for the Switch 7. The features of those devices is diminished with the partially-functioning Aeotec drivers. I’m hopeful the full-function drivers written by @CommanderQ that Aeotec used to point customers to will be updated in the future.

1 Like

I reached out to Aeotec about the driver changes they introduced so that I can update my drivers. Once I hear back or I see their drivers integrated into the SmartThings driver repository, I’ll get an update out. :smile: