Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Hotfix Notes - 0.45.11

you should remove your email address from your post and send it to her in a DM. :slight_smile:

4 Likes

I am not certain what to do to get the zigbee devices working again. The Zwave devices and cloud based devices are working fine. The local zigbee devices continually go offline about every 10 minutes and then reconnect and then go offline again. Do I need to delete all these devices and then pair them again to get them to use one of the new drivers? This is across multiple types of devices—I have over 100 ST connected devices. Or, should I just wait and be patient? I have deleted and re-added the app, I have unplugged my hub for an hour. Neither of those “fixes” worked. This continual online and offline recycling has be going on for several days now. As a test, I removed a plug and tried to add it back. My ST hub will not pair with the device. It is a Centralite series 4 plug. I have reset the plug and tried several times. Tried a second plug and same thing–It will not pair. What a mess! This only happened after the recent hub upgrade–all was good prior to that.

Question: does the workaround for a similar sounding problem with 0.45.9 work?
As I remember, this involved manually changing the Zigbee channel.
I could be 100% wrong.
Luckily, I have not suffered this problem (V2 hub; ~50 devices; mostly zigbee).

It looks like the channel keeps changing on its own. Sometimes it shows channel 19 and other times it shows 255 (see below here I copied and pasted the info form my hub (using groovey IDE site).

  • State: Not detected

  • Version: 0.0.0

  • EUI: 0000000000000000

  • Channel: 255

  • Node ID: FFFE

  • Pan ID: FFFF

  • OTA: enabled for all devices

  • Unsecure Rejoin: true

  • State: Functional

  • Version: 5.4.4

  • EUI: 286D9700020131A1

  • Channel: 19

  • Node ID: 0000

  • Pan ID: B1AA

  • OTA: enabled for all devices

  • Unsecure Rejoin: true

I am sorry for the problems of all of you with zigbee. I had these problems since August and finally with the latest firmware 45.11, The whole zigbee network is back to working perfectly. I didn’t have any more disconnections. Now I’m really afraid of the next update. I’m afraid of some change :slightly_smiling_face::stuck_out_tongue_winking_eye:

1 Like

I did a lot off testing. Unpair everything and only pair two Z-wave plus devices. Maybe this is helpful.
I use one Z-Wave plus switch dimmer device to control the lights, an Aeotec WallMote Quad to turn on and turn off the lights with dimming. The Aeotec Smart Hub (firmware 0.45.11) control both devices.
I create a routine : Lights on 75%. Only one command is executed. Lights on or 75% dimming. Sometimes the lights turns on with the last light setting. Another time only the dim 75% is set and no light at all. A delay time cannot be set in the routine, because Smartthings doesn’t give that option. It are two settings for one device whitin one routine. This is a bug in the system.
When I read all the issue that are reported, unstable product. For me the end of smartthings I’m gonna look for a better product.

All of my Aqara Zigbee devices are dropping out constantly, totally unusable!

1 Like

Not only Aqara (Xiaomi), all Smartthings devices go offline randomly (outlets, door sensors, water sensors, motion sensors). So this tells me they didn’t even tested the firmware updates with their own branded devices, legacy or current Aeotec. Pure incompetence. It’s been almost a week since the supposed 45.11 fix and still nothing to be heard from them.

1 Like

I have 3 V2 hubs all on 45.11 and have had no issues with zwave or ZigBee at all. Nearly 100 devices, no faults.

It’s not everyone.

1 Like

All my devices are working well on v3 hub 45.11 as well

Hi @Terri_Baker

  1. How many edge drivers have you installed?

  2. Do you run a mix of community and native SmartThings edge drivers?

  3. Do you have a mix of devices (Zigbee, Z-wave LAN, Wi-Fi)?

  4. Do you still run any DTH’s and Smartapps?

  5. Do you experience greater delays in automations after transistion to edge than before?

Hi @rubberduck72

  1. I’m currently at 19 drivers and 129 devices (*see below comment)

  2. I have a mix of community and native SmartThings edge drivers, mostly community

  3. Zigbee, Z-wave, Wi-Fi, LAN (*see below comment)

  4. Mostly edge drivers and a few DTH’s for devices that haven’t automatically migrated

  5. It’s hit and miss but for the most part I think it’s faster. I notice delays mostly after updates.

  • I should add that I’m on the beta and I’ve been having hub cycling and device offline issues since July. It got to a point that it was unusable. I’ve been working with the development team since then.
    I had 22 drivers and 140 devices (mix of device types) but was having a lot of hub cycling, devices offline, and hub memory full. I noticed a difference in speed and stability almost immediately after removing drivers. My hub memory warning finally changed from full to almost full.
    I have since added a 2nd hub which I moved my edgebrdige driver and associated devices, myq driver, some virtual devices and things seem to be stable…finally!
2 Likes

Thankyou for your response @Terri_Baker .
My questions to you, was because I have same issues with HUB disconnect/connect randomly and devices goes offline after update to 0.45.11 . I think they have narrowed the threshold for installed edge drivers in 0.45.11. So I began to uninstall edge drivers (23 before) and are down to 19 as you. My HUB memory before states it was full and after drivers uninstall it changed to almost full and now the warning disapeared, as you experienced. I noticed speed and stability improvements almost instantly. So if I want to add more devices from now, I have to buy another HUB aperently. It is a kind of drawback from my point of view and there are aperently more users in this forum with same issues. I hope Smartthings makes a statement about this. According to status.smartthings.com they are still monitoring latest update as of Oct 31. so something is going on hopefully.

How do you uninstall edge drivers? I may try that.

Find your hub in the ST app, open it, click on More Options (3 dots in upper right) and select Driver.

2 Likes

Thank you!
I tested with my Smartthings water leak sensors (x8), deleted the devices -it won’t let me delete drivers if there are devices using it- then deleted the edge drivers and added again the water leak sensors. Then the edge driver re-appears in the Driver section(!). Am I missing something?

Are you attempting to get Groovy Device Handlers on these devices? If so, with the ST water leak sensor, they are only going to pick up Edge Drivers at this point. The only way you can get groovy device handlers at this point is if you had custom device handlers already installed (they have now removed the ability to add custom code - possible custom code is no longer the first choice when joining devices.) or for devices that have not had their groovy device handlers migrated to Edge Drivers. Time is running out for groovy.

No, these Smartthings water leak sensors don’t have Groovy DHs. Just simple leak detectors (& temperature). I basically only use DHs for my Zooz devices. I guess Edge Drivers are the default/faulty drivers now. Seems to me almost all my devices that use the listed Edge Drivers are going offline randomly (Smartthings plugs, motion sensors, water leak sensors, door sensors, Securifi Peanut plugs). In total ~100 of my devices use the listed Edge Drivers.

Sounds more like the issues from recent firmware updates to the hub and not the Edge Drivers.

1 Like

Any updates for another fix? All of my zigbee devices including hue lights goes randomly offline. I pair them again, restarted the hub, change zigbee channel but still no effect.