Aeotec Indoor Siren 6 - I just got it new from Amazon and it won't configure?

I just bought this device brand new from Amazon. I’m using the iPhone app (v1.6.98.21) and it paired easily (browsing to select the exact Aeotec product by model name) and everything seemed ok.

Now, when I tap the tile it opens and only Tamper Alert and Sound two are “populated” … everything else is grey. I’ve followed the various instructions on configuring, and it keep popping up saying “This device hasn’t updated all of its status information yet. Check again later”.

I’ve gone into settings, changed the “Component name” to different values, set the Volume, and picked the Tone … toggle the “Send sound and volume configuration” (a pretty lame UI feature?) and then gone “back” and nothing happpens. No changes. Everything grey except the two above.

Power cycled. Tried all sorts of configuration changes. Nothing. The device is 15 feet from my hub.

Anyone else seeing this with the current product? Ideas? Suggestions?

I opened a ticket with Aeotec also.

1 Like

see if anything from this thread helps in resolving your issue:


Wow … nice find! I did search but never saw this thread. I’ll give this a try and also post if I hear back from Aeotec.

1 Like

Ok … it worked … AFTER I got one more tip from Aeotec support.

You MUST do this with the Android SmartThings app! It CAN NOT be done with the iOS/iPhone/iPad version of the app!

From Aeotec Support:

Unfortunately there is only one fix that i have come across, if you can utilize and Android device, you should be able to use these steps.

I have been told by SmartThings that this issue should be resolved by the time Edge drivers have made their full migration.

NOTE - This fix will only work with Android phones, on iOS these options do not appear for some reason.

I came across a workaround fix for this issue which is found here: Aeotec Siren 6 Not Updating Status: Work Around - I have tested this and confirmed that this works.

It utilizes Automations to force the device to update its status on the Siren 6 or Doorbell 6 allowing you to use all 8 endpoints of the Siren 6. You’ll need to trigger each of the endpoints 1 by 1 and this will permenantly fix your Siren 6 on SmartThings UI until you unpair and re-pair the Siren 6.

  1. Pair the Siren 6 into SmartThings
  2. Go to Automations tab
  3. Tap + at the top
  4. Select “Create Scene”
  5. Select + Actions → Control a Device → Siren 6
  6. Enable “main”
    Chime = Chime
    Enable ONLY chime.
  7. Tap Done
  8. Name the Scene and Save it. (i named it “Fix Siren 6”)
  9. Play the Scene once (it should ungrey main)

Now Repeat these steps for Sound3 - Sound8

  1. Go to Automations Tab
  2. Tap on the Scene that you created
  3. Edit the Action of the Siren 6
  4. Disable the previous scenes
  5. Now enable Chime ONLY for the next sound. (Sound3, 4, 5, 6, 7, or 8) - We skip Sound2 as this is likely already enabled due to it triggering on its own by physical touch.
  6. Click on Done
  7. Play the Scene once

Note - Once you get to Sound6, Sound7, Sound8, you will need to go to the Siren 6 page and turn Sound 6/7/8 OFF as these sounds will play indefinitely otherwise.

So there were three different things that I learned here:

  1. There is an initialization bug in the current driver that will be fixed in the future.
  2. You MUST use the Android app - not iOS/iPhoneiPad
  3. Sounds 6/7/8 play forever! I noticed this, but did not realize it was a feature!

I hope this helps someone else!

1 Like

Hi my friend, Maybe you want to switch to try in an Android device, I am using Aeotec Siren 6 sharply with Mariano Edge Driver, at the beginning with mi iPhone all settings and automations let all functions, but some weeks ago for the THEN part of automation there are no options to set any sound (only MAIN feature of the siren), when I tried again in an Android, (because Mariano advice) then I found the 8 sounds options again. So this probably could make some problem while you are setting the device, I hope this helps.

1 Like

That sounds like it may be a side effect of disabling the ‘synthetic events’ used to initialise attributes in the stock drivers. ST did that as a temporary change a while back, presumably because they were unhelpful when devices were being migrated.