[Aeotec Hub] Z-Wave switch not working correctly (July 2023)

Just try to get a similar device in the catalogue and find this ones, not sure if this can help
@AlejandroPadilla @nayelyz

https://products.z-wavealliance.org/products/1115?selectedFrequencyId=-1 (but with 2 switch for mine)

Mmm the company is a affiliate member not a Manufacturer member, but I still have a few doubts about your devices,

  • Do you know if your device was using a custom DTH? because in these days have been migrating some DTH devices.
  • or Was your device using an edge driver before the problem?

Hi @AlejandroPadilla Thanks for the clarification

No, I was not using any custom DTH
And when my drivers was working properly before this catastrophic updates, I were able to see in the IDE page, that all my devices and child devices were Locally running and able to see the routes that my devices were working with my Hub. But when I start to have issues with this devices, the routes were properly wrong, and appears the driver used as “Placeholder”. I can see now in the new IDE page, that when adding my devices, the parent devices is setup as Locally, but the Childs are setup as Cloud and “EDGE_CHILD”

My devices were all working perfectly!! This before June, starting June is when I start to see issues controlling my devices in the ST because they start to not response any action I made in there.

I understand your discomfort, I’m trying to figure out what happened with your device, please can you enable the support access

Enable support access to your account:

  1. Please confirm that the email address that you use in the community is the same as that in SmaertThingsm if not, please send us by private message
  2. Go to the SmartThings Web (my.smartthings.com)
  3. Log in to your Samsung Account
  4. Select Menu (⋮) and choose Settings
  5. Toggle on Account Data Access
  6. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

I already reported that problem and the team is working on it, some devices are no display that value correctly

to verify that value on your device you can use the SmartTings CLI

smartthings devices {deviceid} -j

or you can use the SmartThings API


this is the propriety that you can check with both options

"executingLocally": true,

Thank you @AlejandroPadilla

Account Data Access is enable. And for the 3 devices (Parent and its 2 Childs) it appears “executingLocally”: true

I tried to access your account but I can’t, Are you using the same email address here in Community and SmartThings App? or Are you using another different for SmartThings App?

yes, is the same email for both.

Unfortunately, we tried with the email that you have registered in Community but we don’t have access, you can send the email address of your SmartThings to build@smartthings.com to avoid confusion.

Hi @AlejandroPadilla Just answer you with an email that Im using with Smartthings. Thank you!

Hi @AlejandroPadilla @nayelyz Please let me know if something else is needed from my side. Thank you!

Hi @nayelyz @AlejandroPadilla Any update related to my issue? Thank you!

Hi @FiruLAD after checking with the team we noticed that your device was migrated on the 12th which means that before that your device was not using a driver, and it was using a generic fingerprint because its specific one is not on the driver, that means it’s not a certified device and for that, we can’t ensure the correct functionality of the device.
For a device to be certified, its manufacturer needs to contact SmartThings to go through this process which among other things includes: developing a driver or using one already existing but adding the corresponding functionality and sending his device to the test labs.

In this case, you need to find a custom driver or develop one that would comply with the requirements of your device. You can base on the source code from the SmartThings drivers which you can find here: https://github.com/SmartThingsCommunity/SmartThingsEdgeDrivers/tree/main/drivers/SmartThings

Hi @AlejandroPadilla Thanks for the follow up

Well, for me that’s a bad customer care, because I’m using this platform for more that 1 year without issues, and now you are saying practically that Im alone and that I need to find my own solution. Im not a developer, I have not idea on what to do, or how to start. Why do I need to fix the issue if the RC is that ST cause the issue?

You can see a lot of customers saying that its drivers are not working any more. So something is bad with your software and not my hardware.

Please, try to give me a fixed driver or a solution, or I will escalate this situation further.

You’re using a device that ST no longer supports under the Edge framework. They can (and do) change what is supported at any time. You’re not paying for support, they owe you nothing. How long must ST support devices that they supported in the past? Forever? The migration to Edge required them to make tough choices about which devices to continue to support and for the most part those were only devices that manufacturers still made and went thru the WWST certification. Things change, nothing is supported forever.

You have a few options as I see it:

  • Write or have a driver written for your device that you support yourself
  • Replace your device with a currently supported device. There are lots to choose from.
  • Switch to a different smart home hub/ecosystem. There are lots to choose from. Some of them may still support your device.

Some of us write drivers for devices that are no longer officially supported or need enhanced features over the stock drivers. We do this to support our own devices or just for fun.

1 Like

@Mariano_Colmenarejo has a driver called Z-Wave Switch and Child Mc that might be able to support your devices. I suggest posting your device info in the topic for that driver to see if it can be supported or not. It would be helpful to have the device name and model number(s) as well as the manufacturer code (fingerprint) for the device(s) which is available in the ST Advanced Web App or from the community developed ST API Browser+.

Thanks for the advice and help here.

I have try using that driver, and it works properly :D. But the only thing that I can’t make work are my double switch devices. Because it only creates one Device in the ST app, and im not able to control each switch independently :frowning:

Im not paying for support, but Im paying for a HUB. So I AM IN ALL MY RIGHT to ask for support and to have a solution.

Incorrect. You bought a hub that had a manufacturers warranty against defects, but that did not include support for devices.

Sure, you can ASK for support, but they’ve answered you above. You have an unsupported device.

Understand. The author might need to update his driver to support the child devices for your switches. That’s why I said to post in the topic for that driver.