Aeotec Hub Migration

I got my discounted Aeotec Hub to replace my V1 ST hub that sunsets in June.

I deleted all my devices using the Groovy IDE tool and then deleted my V1 hub from the app.

I installed the new Aeotec Hub which is supposedly a v3 ST hub. Seem to go well until it got to firmware updates and then it just stopped and showed no download for like 30 min.

I restarted the app and went to the hub setting where is say “Don’t Allow” under firmware. When I change it to Allow, it immediately changes back to Don’t Allow.

Any thoughts on why the firmware will not update and why the setting say “Don’t Allow”? FYI, my old V1 hub also said Don’t Allow for firmware.

what is the firmware version on the hub? 35.4 is the current version.

also, the section where you set allow and don’t allow is for Device Firmware and not the hub firmware. Currently, there is no way to prevent firmware updates for the hub. It is a feature many users request.

When I click Information on the hub, this is what I see.

ok, looks like we have our first reported difference with the aeotec hub :slight_smile:

go to IDE at https://account.smartthings.com and go to hubs and check if the firmware version appears there

When I go to Hubs, it says no Hubs Have been setup, but I have a hub on my app. My old V1 never showed a hub on the IDE either.

You may want to contact ST support and ask why it does not appear in IDE. most interesting. The v1 hub should have appeared and I would expect the aeotec would as well.

Do you have more than one location? If so, did you check each of them for the hub?

1 Like

Agree with @iridris

You’ve got a mismatch between the IDE and the app.

Are you accessing the IDE via

https://account.smartthings.com/

There’s been another URL passed around which is incorrect and will lead to problems.

The firmware toggle is for devices and only allows it to toggle once you have devices attached. The hub will update on its own. My Aeotec did the same thing as yours and after about 45 min, I power cycled it and rebooted the app. It updated again and froze a second time. When I cycled it again, it worked fine then.

Side note, I got everything attached and working again, however under Smart Home Monitor, it forces me to use all door sensors. Last time I was able to choose which sensors. Any ideas why I can’t choose which sensors this time and any workarounds (I couldn’t find any in IDE)? Is it the hub??

You are going into SmartThings Home Monitor and clicking on the cog in the upper right of the screen?

Cog just lets you toggle what you’re monitoring. In the sensor selection below each type, the only option is all sensors toggled on or off.

click on those fields and you are given the opportunity to individually select devices

When you click on them, it shows the list of sensors. no way to toggle on or off and if you click them it takes you to their individual device page. From there, the only options are edit and information and edit only changes the name/room. I was able to do it on the gen 1 hub, not now. I think its a aeotec hub issue, I don’t think it can distinguish them and its all or nothing now.

That sounds like the ‘View sensors’ page in STHM. You’d think that would be the obvious place to edit the list of sensors, but bizarrely no.

First you must hit the settings cog on the STHM opening page to open ‘Setup SmartThings Home Monitor’.

Then you must realise that ‘Security’ is not just a label for the toggle but also actually an item in a menu and click on it.

Then you must select e.g. ‘Set up Armed (Away) sensors’, which has to be a menu item as it can’t be anything else.

Then you must deselect the toggle next to the ‘Use all open/close sensors’ label, if it is selected.

Then if you are lucky you will see blue text under the label mentioned above and guess it is a link. If you are unlucky you will have to guess that the black ‘None selected’ is also a link. Select that and you’ll finally get to the list of sensors.

I don’t know who designs the UI but it sucks.

1 Like

That worked, thanks! It did not show up as a link and was just black text with the toggle on the right for select all. When I clicked on the black text it allowed me to select which ones. Not very intuitive not being a link. Thanks!

I got help from ST tech support and it was a mismatch between the app and the IDE. All is good and excluding all my ZWave devices was easy with the v3 hub and app. Something I was not able to do with the V1. Got all my legacy GE switches re-added. Even some old GE Link bulbs we use in our bedroom lamps that have been in use for 6 years since we first got ST added back easily.

I will add that that if you are a V1 user, use the IDE tool to delete all your devices and then your hub. The v3 hub will take care of the ZWave exclusion easier than dealing with it on the V1 hub.

All is well again.

2 Likes

How did you get your legacy GE switches added back on to the new network with the AEOTEC hub? Same for the smart things sensors?