Aeon Siren will not Trigger


(Simon) #1

Hi, I wonder if anyone can help me with a problem I am experiencing with an Aeon Siren? I bought the Aeon Siren about 3 months ago and it seemed to work fine once I had figured out how to correctly integrate it within SmartAlarm. However, about a week ago I noticed that the siren was no longer working. I cannot trigger the siren manually from Things>Aeon Siren>Right Now>Test or upon sensing motion from within SmartAlarm. I contacted SmartThings support but although helpful the whole process is dragging on and there doesn’t seem to be any sign of progress.

I was told by SmartThings support that there aren’t any known issues with the Aeon Labs siren and that I should try removing it from my account and then reconnecting. I had already tried that twice before reaching out to SmartThings support but it made no difference. I have tried doing it a couple more times but still no change even though the Aeon Siren is correctly identified within the SmartThings App and IDE. I was then told by support to move the Aeon Siren closer to my hub but again that made no difference even though it was now within 1m.

I have checked Aeon Siren (Device) Events in the SmartThings IDE and it seems the SmartThings App is communicating with the Aeon Siren. From List Events I can see the Value Off and Test are being sent to the Aeon Siren but still it does not sound. Interestingly, from the Aeon Siren Live Log, I can see that although the Off command is being registered when I press the Off Tile in Things>Aeon Siren>Right Now, the Test command is not being registered.

SmartThings support suggested there might be a problem with the Aeon Siren, so I contacted Aeotec support. They told me that there are some known issues with the Siren and SmartThings hub which could be affecting the communication between them. They also suggested I remove and reconnect the Aeon siren but I can’t see the point in trying that again. Finally they told me that the siren is not broken if holding the button for about 8 seconds produces a loud sound, which it does.

To check if there was a problem with the Aeon siren device handler, I created a new one using the code provided by krlaframboise on GitHub. I can see the commands being registered in the SmartThings IDE but still not sound from the siren.

I am at a loss how to resolve this problem and would really appreciate some help.

Thanks in advance,

Simon


(Kevin) #2

You could try another device handler like the one linked to below or try removing the device, doing a factory reset , and then pairing it again just so you can be certain it’s not a connection problem.


(Simon) #3

Thanks for the suggestions but I have already done both and it made no difference. Your device handler seems to work but the siren will still not trigger.


(Simon) #4

I also checked in Live Logging and it shows the following when I manually press the Alarm tile from the Things>Right Now

Executing both() command
Sounding Alarm: [sound: 1, volume: 1]

However, the siren is not making a sound.


(Kevin) #5

Try this:

Open Live Logging and then in the mobile app’s Device Settings, make sure that Debug Logging is enabled and then save the settings. If you see “Checking for Secure Command Support” in Live Logging, that means that the device is not paired securely.


(Simon) #6

Debug logging is enabled and a blue tab with debug appears in live logging when I press the tiles in the mobile app. So, I think the device is paired securely. Any other suggestions are very welcome.


(Kevin) #7

When you press the tiles, it doesn’t check to see if it’s paired securely and the 2 events you previously posted will appear in the log either way. There are 2 additional lines that should be appearing in the logs, but aren’t which means the device is not responding to the commands being sent to it.

You need to save the settings screen because that’s where it checks to see if it’s paired securely. If you haven’t saved the settings screen at all, that could be why my DH isn’t working.

If every time you save the settings screen you see that message about “Checking for Secure Command Support”, that means you’re not paired securely.


(Simon) #8

I checked the live log when saving the settings and it does return “Checking for Secure Command Support”. Any suggestions how to ensure the Aeon Siren does pair securely with the SmartThings hub?


(Kevin) #9

[quote=“Bil90, post:8, topic:43340”]
Any suggestions how to ensure the Aeon Siren does pair securely with the SmartThings hub?
[/quote]Remove the device, hold the action button for 20+ seconds to factory reset the device then when re-pairing the device, press the action button twice instead of just once.

If that doesn’t work, you should move the device close to the hub to ensure that it’s connecting directly to the hub and not going through other devices. After it’s paired, you can move the device, but you should probably run a z-wave repair.


(Simon) #10

Neither option worked. Interestingly, when I ran the z-wave repair it returned a failure for the Aeon Siren.


(Kevin) #11

It might be throwing an exception during the pairing process. When you paired the device, did you have Live Logging open?

If you quickly press and release the action button, does it start blinking?

When you did the factory reset, did you wait the full 20 seconds? I think after a few seconds of holding it, it will start beeping, but it doesn’t actually reset until you’ve held it for 20 seconds and then when you release it it will beep for 3 seconds.

Considering that the device was working and then stopped, it’s possible there’s a problem with it, but if that was the case, the hub probably wouldn’t see it.


(Simon) #12

The siren is now working but I am not sure why and how because I tried several things in the last hour. I appreciate that is not best practice but I put it down to frustration. I did another z-wave repair, rebooted the hub, moved out of live logging and also performed a factory reset of the siren. Interestingly, even though I held the action button for a full 20 seconds, mine didn’t beep for 3 seconds when I released the action button. Anyway, I am not bothered about that now and am just pleased to eventually get the siren integrated within SmartThings. BTW, the multifunction device handler for the Aeon siren works great! Thanks for all the advice.


#13

You may wanna check that the z-wave mesh is such that the siren receives signal. I had trouble with both my z-wave sirens. They were too far away from the hub.

What I and it seems that things were fixed:

I turned off the hub (no mains, no batteries) for s,the like 30 min.

I moved the Aeon siren closer to the hub. It is plugged into mains therefore it retransmits z-wave signal.

I turned on the hub and waited for like 15 mins so that changes in mesh network topology are propagated.

After else three steps it seems that my problem is fixed.