Problem with smartthings hub v2 with Aeon labs siren and minimote


#1

Hi there. I’m new to this community and really excited to join the smartthings family. I have successfully set up my v2 hub with a bunch of samsung and lowe’s iris sensors/outlets. These things are amazing!

Recently, I just added an aeon labs siren to my collection and it worked well with the mobile apps. I can trigger and disarm it easily there. Then I decided to add the aeon labs minimote to help my wife opearting our new home security setup. I carefully followed all the instructions on smartthings support page. But the problems came. (1) Once I pair the minimote to the hub, everything works fine (e.g., turn on/off lights) but the siren somehow became unresponsive at all. I CANNOT trigger it via the minimote or the mobile apps. In the siren log, I can see things like the minimote buttons programmed to it has been pushed. But it just didn’t do anything. (2) I tried to disconnect the minimote and the siren from the hub. Disconnecting the minimote always worked, but for most of the time, I could not disconnect the siren. After selecting disconnection from the app and pushing the action button on the siren, the safety LEDs light up but not the network LED. I tried to reset the siren by holding the action button for 20 seconds and nothing changed. When the action button was held, I can hear some small noisy from the siren. I waited for one day and by some chance this time it successfully disconnected itself from my hub. But after I tried to connect both again, the same problem came. Seemed to get stuck in a bad loop.

Does anyone else has experience with this combo of aeon labs siren + minimote? Your suggestion would be highly appreciated. Thanks!


(Josh Jeffrey) #2

I don’t have the minimote but I do have an Aeon Siren. Mine has gone silent, though connected and active, but never triggers from SHM or other alerts. If I click the test button it works. I’ve been working with SmartThings Support and there is a recent (as of Feb 2016) known issue/bug with the Aeon Sirens connecting but not triggering. They are still working on a fix as of now, so it may be related to that. I would reach out to e-mail support so they can look deeper at your account. Hope that helps a bit…


(Brian Dodd) #3

I have the same problem as you. Siren is connected, can be turned on and off, but is not triggered anymore by SHM. Did you ever find a solution?


(Josh Jeffrey) #4

I did find a solution. It’s a workaround, but hoping some of the new firmware updates coming will fix the SHM issues.

Workaround:
On the Dashboard, click the settings icon. I created a “Custom” security monitor. I chose which sensors, what mode (I chose a night), then which siren to sound (which I used my Aeon). I also set the alarm to Arm (stay).

When I used routines and set to Night, it uses my custom security rule and the alarm sounds. When I change to Morning routine (the custom rule is not active).

This siren issue is a bug in the SHM (Smart Home Monitor) which triggers intrusion, says it triggered siren, but it would never go off. Hope that helps. Let me know if you need any other help.

I also set a custom rule for Goodbye to arm ;
(Away) with motion sensors as we’ll. Another custom rule.


(Kevin) #5

If you have the Aeon Siren, you might have better luck with the Device Handler below.


(Brian Dodd) #6

Thanks for this. It looks great; however, when I try and copy the code into a new smart app, it comes back with the error message: No signature of method: script14613235305191947252087.metadata() is applicable for argument types: (script14613235305191947252087$_run_closure1) values: [script14613235305191947252087$run_closure1@dcb0873] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

I don’t yet know groovy enough to figure and fix this issue. Thanks again for any help.


(Kevin) #7

You should be copying it into a new Device Handler, not smart app.


(Brian Dodd) #8

Yes of course! It’s obvious now you mentioned it! Thanks. Seems to be working fine now. Brian