Aeon MultiSensor Gen 5 - Set Parameters


(Anthony S.) #1

I recently have had an issue with one of my sensors where the motion sensor is stuck on active. All of the other sensors are reporting appropriately. I have tried removing and re-including, resetting the sensor.

I reached out to Aeotec Support and they suggested:

Set parameter 3 [2 byte dec] to 7 and see if the motion sensing ever returns back to normal, also try setting parameter 5 [1 byte dec] to 2 and see if that changes anything.

I’m assuming i would create a modified device type to apply to this specific sensor temporarily correct?

If so what parts do I change?


(Johnathan Fullman) #2

Is this a multisensor 4? You need a custom device type to set the config. I have one you can use
on github

Just plug the sensor into power, re-install the sensor with my device type, and then press the configure button on the device app. Might clear it up for ya. Might need to do it a couple times… I have found these sensors to be odd and unreliable.


(Anthony S.) #3

It’s actually a gen 5… And just 10 minutes ago Aeotec support actually sent me instruction on how to make the changes to the smartthings device type. With examples I was highly impressed

Thanks for responding though…


(Anthony S.) #4

Here is the instructions from Aeotec Support for future reference:

You would still be using SmartThings hub, but it is a little bit more complicated to set these settings. Within the device type code, you would need to change a few lines of code. I will be using Robert Vandervoorts code as an example: https://github.com/robertvandervoort/SmartThings/blob/master/Aeon%20Multisensor%206/device_type-aeon-multisensor6-v1.1

For Parameter 3 [2 byte dec]: to 7:

zwave.configurationV1.configurationSet(parameterNumber: 0x03, size: 2, scaledConfigurationValue: 60) will need to be changed to:
zwave.configurationV1.configurationSet(parameterNumber: 0x03, size: 2, scaledConfigurationValue: 7)


In other gateways provides a simplier method to do this, but SmartThings hub requires these changes by code.


(Johnathan Fullman) #5

Right! @Robert_Vandervoort has a great configurable device type for the Multisensor 6 as well!


#6

“Gen five” refers to the chipset, the 500 or Z wave plus. ( those are all the same thing: “Gen five” equals “500” equals “Z wave plus.”)

Aeon Labs has made two different Gen five multi-sensors so far: the original four attribute device, and the newer six attribute device. But the next one could be a “Gen five multisensor three” if they wanted.

That’s why people are asking which one you have. It would be best if you could give the model number. Just because there are multiple Gen five multi sensors from Aeon.


(Anthony S.) #7

My bad that’s what I get for posting while on a conference call at work that has nothing to do with me. :wink:
It is a 4-attribute Gen 5.
I actually have 2 new multisensor 6’s sitting on my porch to try out when I get home


#8

I have 2 Multisensor 6 devices as well and the default 4 minute motion sense is excessive. Once I’ve used the custom device type to configure the device, can I switch back to the “official” device type and retain my settings? My hope is to have motion based events process locally and any custom app or device type results in cloud processing.


(Michael and Jessica) #9

I have 4 Multiseonsor 6’s in my house and they reset motion very quickly, within one or two minutes. I have many programs that use them as short duration occupancy sensors.


(Anthony S.) #10

Mine behave the same as well. Motion activity reset is very quick.


#11

Default setting according to the manual is 4 minutes and that’s about what I have observed. I’m primarily using it for environmental readings in the nursery but have another I plan on using strictly for motion and wanted it to have a tighter response.


(sapstar) #12

Sorry for posting on an old topic. What parameters do you use with this device? I am running it on batteries. Below is what I have set using @johnathan398 's device handler.

Name Type Value
MotionStopMinutes number 0
MotionStopSeconds number 30
ReportBattery1 bool false
ReportBattery2 bool false
ReportBattery3 bool true
ReportBatteryRT decimal 5
ReportHumidity1 bool false
ReportHumidity2 bool true
ReportHumidity3 bool false
ReportHumidityRT decimal 3
ReportIlluminance1 bool true
ReportIlluminance2 bool false
ReportIlluminance3 bool false
ReportIlluminanceRT decimal 100
ReportInterval1 number 5
ReportInterval2 number 15
ReportInterval3 number 30
ReportLowBattery bool true
ReportRealTime bool true
ReportTemperature1 bool false
ReportTemperature2 bool true
ReportTemperature3 bool false
ReportTemperatureRT decimal 0.5