Aeon Minimote problems

Of all the devices that I have installed, this is the one I can’t get to work. I’ve removed and re-added the device multiple times, and installed and uninstalled the Smart App too. I have the Button controller hooked up to a simple light, just to test it, but pressing (holding, etc) the buttons does nothing.

Any ideas why I can’t get this device right?

Do you see anything in the logs?

Have you updated the firmware on the Minimote? If not, you should.

That is not something I’ve tried - how do I do this?

Go to the Aeon website, Support section.

Well that was easier than I was expecting! Do I have to remove and re-add the device after that, or should it just work?

Remove and start over.

Removed it, re-added it (named it differently just to make sure), re-installed button controller, connected it to the lights again. Pushing the button makes the leds light up now (just momentarily) which it didn’t do before, but doesn’t change the light’s status…

Thanks for your help so far though!

Do you mean it’s status in the mobile app? Don’t expect that to be instantaneous, and for some devices it can be quite slow. That doesn’t have anything to do with the Minimote. The Minimote with Button Controller either fires the action or it doesn’t. You can use Live Logging in the IDE to see the events from button pushes.

Neither the status in the mobile app, nor the actual on/off status of the light change.

I’ll try using the IDE to see what I can see.

Nope… nothing at all in the IDE, for any button press or holds :frowning: I tried turning the light on and off other ways and that I could see, so I know I’m looking at the right thing.

Does the Minimote show up in the IDE?

Sorry greg, I missed your reply somehow - but the conversation with bravenel has caught up - I see nothing in the IDE at all when I press or hold any of the buttons…

Under “My Devices” yes, but not in the logs. Last Activity is when I re-installed it

I don’t know what to tell you. You could have a bad device, or it could be paired incorrectly. I’d exclude it (delete all smartapps that touch it first), and start over. Repeat until success, or give up declare it to be bad.

I’ve been through that cycle many times… I think it’s time to call it :dizzy_face: