Aeon Minimote Buttons Doesn't Show Buttons (January 26, 2018)


#1

I had my Aeon Minimote working, and was able to turn different lights on and off by selecting different buttons. For some unknown reason, the device stopped working. I had to remove the device and did a firmware update.

Now, when I pair the device, Smartthings only sees the device, not the individual buttons. When I try to configure a routine or smartapp, where I would select a button as a trigger, it only has the Minimote as an available option. There is no further option that I can see to actually select which button.

Any ideas?


#2

This is an officially supported device, and they have been making changes to the official device type handler since late December, and it seems like every change fixes one problem and creates a new one. :disappointed_relieved: So there have been multiple trouble reports on the minimotes all month long.

Definitely report it to support, and they may have a fix for you right away.

https://support.smartthings.com/hc/en-us

Otherwise, the workaround is to go get one of the older custom device type handlers which doesn’t have the new problems. See the following thread:


.


#3

Thanks. I’ll pursue those suggestions.


#4

Just chatted with support. They say this IS NOT an officially supported device, and directed me to https://www.smartthings.com/products Searching that also suggests it is NOT supported.

In any case, they are of no help. Can you provide direction on how to install the older device handler? Do I do this through IDE? I experimented with IDE a little bit, but not sure how to go about adding a device handler.


#5

They said the minimote is not an officially supported device?! It has been for the last four years, I wonder if they dropped it?

@slagle @jody.albritton @tpmanley


#6

This will explain:


(Brad) #7

Sorry for the confusion caused by the products page and support agent.

Several months ago the Works with SmartThings products page was trimmed to reflect devices which are certified with SmartThings and Samsung Connect Homes. The Aeon Minimote is certified to work with SmartThings v2 Hubs, like you have.

I have flagged your support ticket for further investigation but in the meantime, I’d be happy to help.

I took a look and I don’t think you need to use a custom device handler, you just need to set up Smart Lights from under the Marketplace --> SmartApps --> SmartThings Recommends --> Smart Lights.

You can then configure Smart Lighting automations which can be controlled via minimote buttons, as shown in the video here:


ViciousPessimisticGoldfish

(Alex) #8

@Brad_ST - Ever since Scenes were introduced and the Smart Lighting app updated I’ve been trying to trigger scenes using the Minimmote without much success. I have several Minimotes that use a smartapp to control up to 8 devices and they work fine (they all use the standard ST DTH). I converted one Minimote to use Smart Lighting since I have 4 devices and 4 scenes I need to trigger for my kids’ bedtime routine. I use both the push and hold for each button. While the devices mostly work fine (not all buttons, more later), the scenes do not. In initial testing I was able to control a scene on button one, but once I finished configuring all the 4 buttons, the devices were controlled perfectly however the scenes seem to have never worked (or maybe just once or twice on button 3).

The Smart Lighting app has a few issues:

  1. If you create an automation that only controls a scene it will most often save with the name of “No devices or scenes selected”. If you toggle “Edit name” on and then back off, it usually gets the proper name. If you happen to save it with the error as the name, it typically seems to correct the name if you press the X to delete the incorrect name and then do the “Edit Name” toggle or you change the button selection. Sometimes just going back in and saving it again gets the proper name set.

  2. When selecting buttons you have the option of selecting the parent device or the child device (one per button). Not sure which one is the correct one to select but there seems to be less trouble when selecting the parent device and specifying the button number. If you select the parent device and then select the button number the automation title is correct (when it works), while if you select the child device, the title will always have an additional “button X” appended to the title and most often (if not always… too many tests things are getting blurry) the automation does not trigger.

EDIT: Support confirmed that selecting the parent device and then selecting the button number IS the correct way to do it.

  1. Whichever button selection method I use (parent device + button # or child for button #) I can’t get a scene or device to work using button 4.

EDIT: Removing a custom DTH, removing the minimote and adding it back seems to have fixed this issue. Devices and scenes now work fine on all 4 buttons of the minimote.

  1. If you hit Android’s back button or the one in the Smartapp < before saving the automation and when on the name page, you have to start all over as it takes you to the general Smart Lighting page rather than where you can select the buttons etc.

  2. “Toggle On & Off” is visible and On by default when the automation only triggers a scene. Since scenes do not support being turned Off, I guess this should be hidden or locked to Off.

I’ve tried to get around all these issues with Smart Lighting with webCore however I noticed that button 4 does not work there either. Also, since webCore does not have access to Scenes at this time, I was forced to create a routine that calls the desired scene. While the scenes I used to do all of the testing above work (mostly controlling a small number of Hue lights), the ultimate scenes I need for my kids’ bedtime routing include LIFX, and a number of other devices (switches/lights). I know there are timeout issues when it comes to cloud-to-cloud scene operations as confirmed with @vlad but all of the above seems to go beyond that issue (although it may explain why I have less success controlling those scenes even on buttons where I am successful controlling the simpler Hue lights based scenes).

EDIT: Removing a custom DTH, removing the minimote and adding it back seems to have fixed this issue. Devices and scenes now work fine on all 4 buttons of the minimote.

All of this makes me wonder how it escaped any type of QA testing. Is my use case a corner case?