I cant get my minimote to work

I just bought a v1 minimote from aeon labs and I am trying to get it to turn on and off two lamp modules using my smartthings (v1) hub. I was thinking pressing one button would turn on the two lamp modules and pressing another button would turn them off. and maybe a press and hold to dim.

so I went in the app to the Things tab and went to "connect new device"
I chose Entertainment > Remotes & buttons > Aeon Labs > Aeon Labs Z-wave minimote > Connect Now.

Then I pressed and held the “Join” button on the minimote.

the app said it found it and asked me to name it, and then let me set up options for the Button Controller smart app.

i went through and for button 1, under lights > Pushed I dded the two lamp modules.

then I hit next to get through the next 3 buttons then hit Done"

but when I press button 1 on my minimote, the blue and red buttons light up and then a second later the red light flashes quickly - but nothing happens with the lights.

so two questions

  1. how do I troubleshoot this?
  2. when I select the two lamp modules under button 1>lights>press what is the intended behavior. Does that make it so that it turns those lights on with a press? or off? how would I get it to dim them?

I am finding myself very confused by this and would appreciate it if someone could shed some light on the subject - seems like there is something I am missing here.

oh and also - I did go and update the firmware on the minimote to 1.8.

Since you have a v1 minimote, I would suggest updating the firmware to v2 first before integrating it to ST land.

More info at (but make sure it is relevant to the model you have and if it’s the correct firmware update link). I just googled and pulled it up. So cannot verify.


thanks for the reply. unfortunately I already tried that. I tried that version first and then when i was searching the forums I saw someone say to use the 1.8 firmware instead. so I have tried both and still had the same problems. :frowning:

Log into IDE and click on live logging. Then push the butten on the minimote to see if is communicating with the hub. You can also see if it is trying to execute the command from the app.

so i ended up chattign with ST support and they got me squared away. They had me remve the minimote from smart things, reboot the ST hum (remove power, wait 30 seconds, plug power back in), and then they had me re-add the minimote. for whatever reason, this time it seemed to work.

I also used the smart Lights app for more control over the way it was controlling lights.

seems to be working well now.