Aeon Labs Minimote - Button Controller App Won't Install

I just added an Aeon Labs Minimote to my ST hub, but I’m having trouble installing the Button Controller App to use with it. I get a red error message saying “Sorry, but there was an unexpcted error.” This happens after entering the Button Controller app, just after choosing my button device and pressing next on this screen:

Is this happening to anyone else?

Yes, I am getting the same error. Looks like you are doing this on an Android phone. I also tried on an Iphone 6s, and it says failed to assign a button. To no avail can I figure out how to do this.

I just bought 2 minimotes, and installed the button app (iOS) but found that creating a basic piston in CoRE gives you more functionality and devices also react faster… so my recommendation: don’t use the button app at all :slight_smile:

You could try this alternate enhanced version of the Button Controller here:

And also check out this much improved DH:

Thank you so much! I tried the updated app and it still gave the error. I updated the device handler successfully, but it still won’t work with the Button Controller App (or the + version)

I installed CoRE this morning and the Minimote is working flawlessly