Aeon Labs Minimote with SmartThings?


(Joe Angell) #1

I got an Aeon Labs Minimote (owner’s manual), a four-button Z-Wave remote control.  I wasn’t entirely sure it would work with SmartThings, but I thought I’d give it a shot.

So far, I’m not having much success.  I figure that I’d want to set it up as "a secondary/inclusion controller to another Z-Wave controller or gateway in an existing Z-Wave network), as the Minimote’s docs say.  Following the steps:

Pres the button labeled “Learn” - The blue LED will blinck slowly
Press the button labeled “Include” on the other Z-Wave controller.  The blue and red LEDs will blink quickly to indicate detection of the other Z-Wave controller.  Consult the operation manual of the other controllers for instructions on how to add the Minimote as a secondary/inclusion controller into an existing network.
The blue LED will stay solid for 2 seconds to indicate success; the red LED will stay solid for 2 seconds to indicate failure.

Step 1 is easy enough.  For step 2, I used the iOS app to add a device through the “+” tile.  The red LED on the Minimote lit, and the blue LED started flashing quickly.

However, the minimote never shows up in the Connect pane of the iOS app.  At one point when I exited the Connect pane to the list of already connected devices, I saw an Outlet that I hadn’t added before.  I assume this was the remote (since it wouldn’t turn on/off and didn’t seem to otherwise respond).

I’m guessing that either SmartThings doesn’t support remotes, doesn’t support this specific remote, or that I’m doing something wrong.

Any thoughts?  Thanks!

– Joe


Arduino Shield Suggestions?
(Andrew Urman) #2

We don’t have support for remotes yet, but its being worked on right now. We have the single panic button version of this, but I’ll get this one ordered as well. There is some confusion around these because they can have things paired to them like their own mini-hub.


(Joe Angell) #3

No problem – I know it’s early still for SmartThings, and that all kinds of devices aren’t supported yet.  I figured that if it didn’t work now, it would probably work at some point in the future.  I’m glad to hear it’s in the works.  Thanks!

– Joe


(Scott Newman) #4

I’d love to have a few remotes around the house, especially if they can be programmed to control Smart Apps. I always hated how the Z-Wave remotes acted like a secondary controller; I’d much rather program a workflow inside of an app. (e.g. “When this button is pressed, make these actions happen…”)


(Cory S) #5

Agree, I want a simple button on my night stand that will power the house down and lock the doors.


(Gray) #6

@corys: I think you can do that with a SmartButton like the $20 Iris one from Lowe’s. I have received one and will try it as soon as the Android app is available, and I’ll let you know how it goes. My goal is to set it up for my wife to use when she’s on the second floor and I’m in the basement. It will flash the lights and turn off the outlet to my stereo. Hopefully she won’t abuse this power…


(Cory S) #7

@Gray So is all iris stuff compatible? I thought I remembered reading they were using a propitiatory zigbee protocol for some of their stuff. Their light switches look to be just rebranded GEs though.


(Gray) #8

@corys: Well, here’s hoping! I remembered that detail as soon as I posted. But again, I can’t easily attempt to use this one now so I’m waiting until I have an android app to use.

The light switches and outlets, like you say, are just rebranded GEs. The prices at lowe’s on those are pretty good, plus I like having the ability to return them easily (like I had to do with the switch that required a neutral where I didn’t have one).


(Cory S) #9

@Gray Yeah, so far I’ve been pretty unhappy with the GE/Lowes dimmers. They buzz like CRAZY. One even has a pretty good high pitched whine while turned off. I hear the bulbs you use can affect it, though I’m not sure how a buzzing coming from the unit is caused by the bulb while it is turned off.

Naturally the only one that whines while off is right next to my bed…


(David G) #10

Anyone have any luck getting the minimote to work? If yes, step by step would be great. Got the panic button and the other 4 button remote from aeon labs to work, but the minimote is giving me problems


(Kirsten27) #11

i see these are now for sale in the store — are they fully working or not???


(Morgan) #12

Bump this, I’m curious to see if the integration w/ the MiniMote is working now. Thanks


(Jason D) #13

I also want to know how to get these to work. That video they posted the other day was useless. The directions talk about it like you are pairing a device TO the remote. I cant seem to figure out what to do here.


(Jason D) #14

Figured it out. The same procedure in the first post worked. Press learn, then press include and put Smartthings app into add a device mode and it will be found.

It works!


(Scott B) #15

Are you using an iPhone/ipad or Android product to activete?


(Jason D) #16

Iphone. All I did was to go into the area for adding buttons and choose the minimote so it was in searching mode. Press learn on remote and then include.


(Skyhopper88) #17

I got it added. But how do you assign the buttons to trigger stuff? I don’t see anything in the events, Graph.api page, or any published smart apps. My lights aren’t zwave, so I may need a smartapp for this.

Edit: Got the Button Controller smartapp and configured it, but it’s nwot working. When I hit or Hold a button I get the blue light flickering once and the red blinks rapidly whether I press or hold.

The only events coming from the minimote are
9 Jun 2014 18:34:05
10 minutes ago DEVICE Aeon Minimote is now inactive false
9 Jun 2014 18:27:55
16 minutes ago COMMAND configure configure command was sent to Aeon Minimote true
9 Jun 2014 18:27:55
16 minutes ago DEVICE updated
9 Jun 2014 18:27:55
16 minutes ago

Any ideas?

Edit, Ah I forgot everything about zwave I knew. I added it again and It got a new ID, which means it didn’t fully add. Removed and readded, got it on the third try. All’s well now. Any idea what the battery life is like.?


(Kirsten27) #18

so how do you program the buttons?


(Jason D) #19

The button programming is in the smart app. When you add it press the additional settings and it will take you through several pages of telling it what each button will control.


(Gilbert Chan) #20

Once you have the remote paired up, you’ll see it under the “Things” section.
Go to the “+” (if on iOS) > “More” section > “Convenience” > look for “Button Controller” (you can also use the search button on top to look for “Button Controller”)
Once you have the Button Controller app pulled up, it’ll ask you to set up the press and hold for each button.

Let us know if you get it to work. It makes a world of a difference - no more needing to open your app to use the non-automatic hello home commands.