Aeon Key fob GEN 5 with smartthings V2 UK

hubv2

(dwr55) #1

Hi,
i have Aeon Key Fob GEN 5 and i a trying to attache it to Smatthings.
the initial pairing works fine… but on first pairing i am unable to load the button Smartapp.
if i click done and add the button smart app later it lets me install.
but unfortunately even if i add the smart app and configure the buttons the key fob still not working.
its seems that it still on initial mode with the learning option on the bottom right key.
the documentation says that there is no need to change mode after pairing.
any idea how to me this works?
P.S i do see the battery status on smart things app.

please help. Thanks.
Danny


(Lawrence Clark) #2

Add me to this one… I have the fob’s and have been able to connect to hub. However, I can’t get the fob to work. I’ve changed modes and reset the fob but still no luck…

Has anybody else experienced this and can provide some advice for resolving?


(Pat Molloy) #3

Same here. I sometimes get the battery, but most often not. Have deleted and re-added numerous times.

If I look at the device online, I see

Raw Description 0 0 0x0101 0 0 0 d 0x5E 0x86 0x72 0x70 0x80 0x84 0x85 0x59 0x73 0x5A 0xEF 0x2B 0x26
Current States No states found

Presumably “No states found” is not good. I would expect to see the 4 buttons and the battery there if it follows the pattern of other devices … eg. the Aeon MutliSensor

Raw Description 0 0 0x2001 0 0 0 8 0x30 0x31 0x80 0x84 0x70 0x85 0x72 0x86
Current States
illuminance: 8 lux
temperature: 24.2 C
humidity: 26 %
battery: 100 %
motion: inactive


#4

I’m sure that’s frustrating. No states found is not a problem in this particular case. You see that from time to time. It just means that the device hasn’t reported during the recent reporting period, Which will be true for a new device.

The key fob is an officially supported device, so the best thing is just to contact support@SmartThings.co.UK and they should be able to help.

If I had to guess, my guess is that you are trying to add it as a Z wave scene controller, but that is not how SmartThings will use it. In order to allow it to also change modes or run routines or control zigbee devices, it will be set up as what smartthings calls a “button controller” so that each button press is sent to the SmartThings hub, and then you use either smartlighting or another smart app to assign meaning to that button press and then the hub will send a message to the end device that you selected.

For this reason, it is very important that you follow the SmartThings set up instructions for it, not the ones that come in the box.

But again, if it doesn’t work, just get in touch with support and they should be able to help.


(Pat Molloy) #5

I had a very extensive to-and-fro with spport, who were incredibly helpful. But not able to solve the problem. The main issue is lack of decent documentation … I eventually made it work … here is the final e-mail with support …

Through (a lot of!) trial and error, I have figured out how to make this work. If it’s any help to you here is what to do … I will post to that forum thread too … the attached (well hidden) engineering manual also gives some help !

  1. Reset the keyfob. Put a paperclip in the “mode” hole on the back, and watch the LED on the front (fob must be open). It flashes red/green at increasing frequency. After about 20 secs it will go solid green. Let go of the mode button (i.e. release paperclip)
  2. This puts the fob in pairing mode for the ST Hub
  3. Add the device as normal via the ST app … when the app says it’s looking, briefly press the “learn” button on the back of the fob (again with paperclip).
  4. Wait a few moments … the device will pair with the hub
  5. The missing step is to then take the fob out of pairing mode, which you do by pressing both the learn and mode buttons at the same time for 3 or 4 seconds (so you need 2 paperclips).
  6. Add the Button Controller SmartApp and program.

You can tell if the fob is in “learn” mode if …

Pushing button 1 gives slow green flash
Pushing button 2 gives slow red flash
Pushing button 3 does nothing
Pushing button 4 gives slow green flash

If that’s the case you need to re-do step (5) above. When the fob is in “use” mode, pressing any of the buttons should give a brief green flash on the LED.

Seems to work for me …

I see

Current States • button: pushed

(But the battery has disappeared … perhaps it will come back) and then in the event log … I can see that all of the buttons are registering for both push and hold.

Date	Source	Type	Name	Value	User	Displayed Text
2016-04-25 6:43:07.250 PM BST
moments ago
DEVICE		button	held		Aeon Key Fob button 4 was held
2016-04-25 6:42:50.908 PM BST
moments ago
DEVICE		button	held		Aeon Key Fob button 4 was held
2016-04-25 6:42:47.298 PM BST
moments ago
DEVICE		button	held		Aeon Key Fob button 3 was held
2016-04-25 6:42:44.300 PM BST
moments ago
DEVICE		button	held		Aeon Key Fob button 2 was held
2016-04-25 6:42:40.559 PM BST
moments ago
DEVICE		button	held		Aeon Key Fob button 1 was held
2016-04-25 6:42:37.012 PM BST
moments ago
DEVICE		button	pushed		Aeon Key Fob button 4 was pushed
2016-04-25 6:42:35.497 PM BST
moments ago
DEVICE		button	pushed		Aeon Key Fob button 3 was pushed
2016-04-25 6:42:33.942 PM BST
moments ago
DEVICE		button	pushed		Aeon Key Fob button 2 was pushed
2016-04-25 6:42:32.448 PM BST
moments ago
DEVICE		button	pushed		Aeon Key Fob button 1 was pushed

Aeotec key fob 5: How to send Configuration CC changes to fob
(Michael) #6

I have also gotten this device to work with 0 issues (I am in the US). One thing that tripped me up is the device handler is written to not log anything so if you are looking at the Live Logging page you will see nothing when the buttons are pushed. You need to look at the device event history to see if it is passing anything as @patmolloy shows above.


#7

Thank you for posting this. My key fob was not in use mode all the time I was trying to get it to work. Thank you again.


#8

Just a note that installing the button controller app mentioned in step six above is no longer required for most people in 2017 as both the official routines feature and the official smartlighting feature will already recognize button controllers. :sunglasses: