Keyfobs - Help Needed Please


(Mark) #1

Hi,
I’m hoping someone can help me out with some issues I’m having with keyfobs?

I’m running a ver 1 hub and using the Smart Home Monitor in conjunction with some motion sensors and a z-wave siren to provide some basic home security. Everything is working just fine with the system. Our phones are seen as presence sensors and will change the Hello Home mode when we leave or arrive, so no issues there.

Where we run into trouble is with our cleaner and pet sitter. If they arrive and we are not home they will trigger the siren and I have to shut it off remotely. Not a problem when I am at work but when we travel it can be a pain.

For that reason I thought it would be a good idea to get some keyfobs that they could use to disable the security system when they come and we are not there.

I started off by getting one of the SecuriFi keyfobs, installing the device handlet that Kevin Tierney put together and the smart app created by chipr. SmartThings sees the device and identifies it correctly. I programmed the buttons to change the Modes (Home/Away) and the Hello Home actions but when I tried actually using it nothing happened (no mode or actions changes). I don’t see anything in the logs that’s telling me there are any errors, so I tried removing and re-pairing the device. Same problems.

At that point I decided to try another keyfob. I got an Aeotec fob (the 4 button one). SmartThings sees it and identifies it correctly. I used the Button Controller app to configure actions for 2 of the 4 buttons. Again, nothing happened, so I decided to just assign some simple actions, such as turning on a light, to the 2 buttons. When I push button 1 (to turn on the light) the green LED on the fob blinks but nothing happens. When I press button 2 (turn off the light) a red LED blinks but, again, nothing happens.

I have a minimote that I have been able to use successfully with the Button Controller app and it does seem to work to change the modes. I just wanted to give them fobs because they are smaller and easier to carry around.

What am I doing wrong here? If I can’t turn on/off a light it seems as though something is not set up properly I just can’t figure out what and why.

If anyone can point me in the right direction to get this working I would be extremely grateful.

Thanks in advance…


#2

I’m sure that’s very frustrating!

The fact that you have the minimote working is a very good sign. :sunglasses: So we should be able to get what you want with the other devices.

Because these are different devices with different protocols and different device handlers, let’s just pick one and work on that first. Which one are you most interested in getting working?


(Mark) #3

@JDRoberts,

Thank you sir! You’ve helped me out before and I really value your expertise.

I think I’d like to try getting the Aeotec fobs working. They don’t need any custom device drivers and perhaps I can apply what I learn along the way to try getting the SecuriFi fob to work :slightly_smiling:

My replies may be somewhat delayed because I’m at work, so not able to test anything. I will try anything you suggest when I get home tonight and update this thread with the results.

I did some comparisons between the minimote, which I know works, and the Aeotec fob by going to the IDE and looking at “My Devices” > Minimote > Events List. Here I can see my button presses being recorded. The only thing I see for the Fob when I look in the same location is that the fob reported the status of it’s battery when it first joined the network. Nothing registered after that (no button presses), The info from “My Devices” looks like this:

Name
Aeon Key Fob

			Label   Aeon Key Fob 1
		

		
			Type   Aeon Key Fob
		

		
			Version  Published
		

        

		           Device Network Id  14
			
	
                                Status  INACTIVE
		

		                Hub   Home Hub
			
		
                                    Group   Living Room
			
		

		
		             Last Activity At   2016-03-08 4:29 AM PST
				
			
		
                                  Date Created   2016-03-07 11:45 AM PST
				
			
		

		       Last Updated   2016-03-07 11:45 AM PST
				
			
		
                             Data
			
				
					
						
			endpointId:    0
								
					
				
			Raw Description  0 0 0x0101 0 0 0 d 0x5E 0x86 0x72 0x70 0x80 0x84 0x85 0x59 0x73 0x5A 0xEF 0x2B 0x26
			
		

		
			Current States
			
				
					
			battery:    63 %
								
							
				
			Events  List Events
			
		      
                            In Use By  	Button Controller

Hope this is helpful.

Best regards


#4

I can’t use the mobile app anymore, so I can’t help much with this. But my first question would be are they using the same smart apps?

I don’t know if this is still true, but it used to be that you could open the mobile app, go to the my home section, choose the things list, and then choose the minimote from that List, then choose the “smart apps” tab on that individual device details page, and that would show you any smart apps associated with that particular device.

So my first question would be does the minimote that works use the same smart app as the key fob that doesn’t?

If it doesn’t, then you’ll have to install a new version of that smart app for the key fob.

For example, if you have two button controller Devices, you have to install the button controller smart app twice if that’s the one you want to use.

Or if it’s an officially supported device and you just want to use the smart lighting automations, you have to make a new lighting automation for each device.

So that’s my first question: what smart apps are associated with the minimote that works and with the key fob that doesn’t?

My second question would then be to see the exact screenshots for the smart app that you were using with the key fob.

But again, I can’t use the mobile app now since they changed it so I think somebody else is going to have to help you.

Good luck, you should be able to find a solution since this is an officially supported device. And hopefully that solution will give you clues to the other key fob.


(Mark) #5

@JDRoberts

Thank you so much. In answer to your questions:

The minimote (that is working) is using the Button Controller app. I installed a second instance of this app for the Aeotec fob (that doesn’t work). I’ve attached some screenshots that show how things look in the remote app and I’ve configured it there to turn the dimmer switch on and off. It doesn’t work.

I reset the fob to make sure I was starting with a clean slate but that made no difference.

I’m also including a link to the instruction manual in case that yields any clues. I followed the instructions to add it to my existing network by pressing the “Learn” button and it is definitely identified correctly by ST.



Remote Manual

The bit I don’t get here is that the manual I have says the remote has 2 modes (Group Mode and Scene Mode). There is a pinhole on the back of the fob marked “Mode” and a small 2 pronged device to poke into the hole to change the mode. It sounds as though the device is in Group Mode by default but needs to be in Scene Mode to talk to devices through the hub. I tried pushing the Mode button, followed by Button 1 to see if it did anything. It didn’t. I don’t see any button presses being recorded in “My Devices” either.

Hope this helps.
Best regards.


#6

OK, I have some thoughts, but the good news is that since this is on the official compatibility list you can write to support@smartthings.com and they should be able to get it working for you. So I would try that first. :sunglasses:

.

BTW, the manual you linked to doesn’t say anything about scenes that I saw. It said

Your Key Fob Remote Control has two modes: setup mode and use mode. These two modes change the way that your remote’s buttons work, and you can see the differences in the ‘Familiarise yourself with your remote control’ part of this guide.

But again, support should be able to help.


(Mark) #7

@JDRoberts

Many thanks! I will shoot the support folks an e-mail.

In looking at the manual I linked to it seems to be missing a LOT of information compared to the manual that came in the box with the device (that’s where it talks about scenes). Not sure why they would publish a deprecated manual on their site but there you go :wink:

Best regards.