Aeon hem v2 stops updating smartthings


(Eric Anderson) #1

As stated my HEMV2 stops updating and appears to have dropped out of SmartThings. Restarting device will make it work for a hour or so.


(Simon) #2

Is it included in secure mode?

Also, try reducing the frequency of the updates I have important things like amps in group 1 every 10 seconds, watts in group 2 every 57 seconds and kWh in group 3 every 123 seconds. The aim is to reduce the chance of 2 groups reporting at the same time.


(Eric Anderson) #3

i pulled the plug and batteries from the hub, that appears to have fixed it.
what device type are you using?


(Simon) #4

Gen 5 with 3 clamps


(Mike) #5

I have a V2 and it occasionally stops reporting as well. What I did was plug it into a smartplug and wrote a smartapp that monitors power usage if it doesn’t report a power change in 30 seconds then it power cycles the HEM. I also have it send me a notification, I get a notification probably every week or so saying it had to be reset.


(Eric Anderson) #6

i tried switch it back to “green living HEMv2+” device handler and it soon stopped reporting. i switched it back to the SmartThings “home energy meter” device handler and it started reporting without resetting anything.

i think SmartThings is blocking highly verbose device handlers that run in the cloud!!!


(Eric Anderson) #7

siwilson, I meant device handler…


(Mike) #8

I use the HEMV2+ and don’t have any issues. I did make a few modifications, however.

The details are in this thread.


(Eric Anderson) #9

i made your change now reset works, but i only get the first two configuration values in settings? so can not change “Power (Watts) L1, L2, Total”, every 6 seconds. it was this way before making the changes… but i manually changed the code to 12 seconds…

but i’m really thinking smartthings stops the code from running if it uses up to much cpu on the sever, that there is a limit…


(Eric Anderson) #10

I’m also getting double units.

i edited out the extra watts, amps and volts; seems the device returns units with the value…


(Eric Anderson) #11

under preferences, there isn’t a entry to change the variable for the timer on Power (watts) L1, L2, Total which is set to 6 seconds by default.

perhaps it needs to be difined like the other variables:
preferences {
input “kWhCost”, “string”, title: “$/kWh (0.16)”, description: “0.16”, defaultValue: “0.16” as String
input “kWhDelay”, “number”, title: “kWh report seconds (60)”, /* description: “120”, / defaultValue: 120
input “detailDelay”, “number”, title: “Detail report seconds (30)”, /
description: “30”, */ defaultValue: 30
}

and the inputs are not connected to the HEM…


(Eric Anderson) #12

Ok i’ve made it so you can change the defaults and created an extra variable. check you variables as they may be blank on first setup in the app or ide. i did make a change to inputs which may have fixed it… includes Terminal’s reset fix and the extra units in the app…


(Mike) #13

I had changed some of the formatting of things as well. That part was really not that important to me as I really just want KWH usage data logged to my thingsspeak account. As of right now I can’t check anything as I am moving to a new house and I just took down everything as of yesterday. I won’t have internet back up at my new place until Monday. So I will be having to set things up again.

It’s going to be a slow process getting everything back up I have about 70 devices to re-install but the energy meter will probably be one of the first.


(Eric Anderson) #14

my device handler stops poling the data for some reason. I can switch device handlers to “home energy monitor” in the ide and back to my device handler and it will start working again. it isn’t stopping because the device crashes or gets kicked out of zwave network.

edit: device handler doesn’t stop running it just stops “polling” the data.


(Eric Anderson) #15

seams like either device stops sending or device handler stops listening…

logs:
2018-08-25 1:47:21.082 PM CDT
23 minutes ago
COMMAND poll poll command was sent to Electric Meter true
2018-08-25 1:36:39.000 PM CDT
33 minutes ago
DEVICE ampsOne 4.93 Amps L1 Current: 4.93 Amps true
2018-08-25 1:36:38.848 PM CDT
33 minutes ago
DEVICE power 1082 Total Power: 1082 Watts true
2018-08-25 1:36:38.860 PM CDT
33 minutes ago
DEVICE powerDisp 1082 Watts Display Power: 1082 Watts true


(Eric Anderson) #16

i commented out the configuration settings at the end and let the device run on the manufactures defaults. this is what i found in the logs when it went down.

b580e793-59f1-4359-9eb9-9112836e079e 11:16:34 PM: debug resetDisplay() - energyL1Disp: 104.78
kWh

b580e793-59f1-4359-9eb9-9112836e079e 11:16:34 PM: debug refresh()

b580e793-59f1-4359-9eb9-9112836e079e 11:16:34 PM: debug poll()

b580e793-59f1-4359-9eb9-9112836e079e 11:15:29 PM: debug resetDisplay() - energyL1Disp: 104.78
kWh

b580e793-59f1-4359-9eb9-9112836e079e 11:15:29 PM: debug refresh()

b580e793-59f1-4359-9eb9-9112836e079e 11:15:29 PM: debug poll()

b580e793-59f1-4359-9eb9-9112836e079e 11:13:34 PM: debug resetDisplay() - energyL1Disp: 104.78
kWh

b580e793-59f1-4359-9eb9-9112836e079e 11:13:34 PM: debug refresh()

b580e793-59f1-4359-9eb9-9112836e079e 11:13:34 PM: debug poll()

b580e793-59f1-4359-9eb9-9112836e079e 11:12:24 PM: debug resetDisplay() - energyL1Disp: 104.78
kWh

b580e793-59f1-4359-9eb9-9112836e079e 11:12:24 PM: debug refresh()

b580e793-59f1-4359-9eb9-9112836e079e 11:12:24 PM: debug poll()

b580e793-59f1-4359-9eb9-9112836e079e 11:06:35 PM: debug Parse returned L2 Power: 348 Watts

b580e793-59f1-4359-9eb9-9112836e079e 11:06:35 PM: debug Parse returned L1 Power: 482 Watts

b580e793-59f1-4359-9eb9-9112836e079e 11:06:35 PM: debug Parse returned Total Power: 830 Watts

b580e793-59f1-4359-9eb9-9112836e079e 11:06:21 PM: debug Parse returned L2 Energy: 113.99 kWh

b580e793-59f1-4359-9eb9-9112836e079e 11:06:21 PM: debug Parse returned L1 Energy: 104.78 kWh


(Mike) #17

FYI, I just got my HEM setup last night at my new house. Now like you are describing my unit stops polling almost constantly. It worked pretty much flawlessly at my previous residence. In my case I believe the problem is signal. My hub is on one end of the house and the HEM is on the other. I tried adding a couple iris smartplugs, which are Z-wave repeaters, between the two but they don’t seem to want to stay connected either. I didn’t have much time to mess with it last night. Also my new house was built in 1997 and there are no neutrals in the junction boxes so before I can start adding my switches back I have to get that fixed. I had hardwired Z-wave switches all through the last house and had a pretty robust z-wave network.

All that being said, perhaps you need to look at your z-wave network.


(Mike) #18

My HEM has been going now for two days and although it is not reporting as it did at the other house it seems to be working. At the other house power levels were reported about every 10 seconds, but now it only seems to report about every two minutes. I am using the same device handler and I can’t figure out why it has changed it’s behavior. I was concerned it might not be calculating total KWh correctly but the daily use for yesterday was exactly what the power company said it was.

The smartapp I wrote would monitor readings and if it did not report something in 90 seconds it would reset the device by powering down the smartplug I have it plugged into for 10 seconds, but since moving I have had to revise that to 5 minutes due to the lower reporting frequency. I am okay with that as it working, but it’s weird that it’s not working the same


(Eric Anderson) #19

I got a mix of hard wired zwave and zigbee switches everywhere. in the garage it is next to a zwave plug and not far from that is the zwave garage door opener.