Aeon Heavy Duty Switch Gen 5 device type

If you have the beta firmware (ask support for it via email) this should work:

0 0 0x1001 0 0 0 12 0x5E 0x25 0x32 0x31 0x27 0x2C 0x2B 0x70 0x85 0x59 0x56 0x72 0x86 0x7A 0x73 0x98 0xEF 0x5A

Here is what I can map to the Z-Wave supported command classes from the fingerprint

Z-Wave Supported Command Classes:

Code		Name
====	=======================================
0x5E	???
0x25	COMMAND_CLASS_SWITCH_BINARY
0x32	COMMAND_CLASS_METER
0x31	COMMAND_CLASS_SENSOR_MULTILEVEL
0x27	COMMAND_CLASS_SWITCH_ALL
0x2C	COMMAND_CLASS_SCENE_ACTUATOR_CONF
0x2B	COMMAND_CLASS_SCENE_ACTIVATION
0x70	COMMAND_CLASS_CONFIGURATION
0x85	COMMAND_CLASS_ASSOCIATION
0x59	???
0x56	???
0x72	COMMAND_CLASS_MANUFACTURER_SPECIFIC
0x86	COMMAND_CLASS_VERSION
0x7A	COMMAND_CLASS_FIRMWARE_UPDATE_MD
0x73	COMMAND_CLASS_POWERLEVEL
0x98	COMMAND_CLASS_SECURITY
0xEF	COMMAND_CLASS_MARK
0x5A	???

5E is supports encrypted communication.

I got the engineering spec from Aeon Labs last week and I wrote a decent and functional device type.

This device supports the switch control as well as reporting on the power (in Watts), energy (in kWh), voltage (in Volts), and current (in Amps). It also supports reporting the temperature (in C or F) but since it is at the circuit board level it is not a great representation of the room where the switch is installed.

This device type also has some preferences you can set if you want to adjust the reporting interval of the values to the hub and if the switch responds to a “Switch All” event.

Enjoy!

2 Likes

Hello, I’m pretty new to Smartthings, but I’ve managed to set up some basic home monitoring (thermostat, fire/CO alarms, door motion, etc). I just bought an Aeon Heavy Duty Smart Switch to turn my water heater off when not in use.

After reading posts on this site, I’m a little concerned that this might not work.

Assuming the device I just bought has the latest firmware, will I need to do anything special to get this work with the Smartthings hub?

I noticed that this device is not specifically listed in Aeon devices when I tried to add via by phone app. Is this device supproted?

Your help is very much appreciated!

1 Like

Me too! Any help would be great!

Hi James,

Thank you for this piece of code. I used it and it works well. However, I tried for a few hours to get continuous power reporting of “0 W” every minute from the Heavy Load Switch, but the power seems to be deplayed only when the device is consumming. I tried to changed all sorts of parameters, but it doesn’t work. I would like to know what needed to be changed to see the power (and voltage - but this is working) every minutes, even when at 0 W. I can also do with Amps and find the power myself, if easier.

Thanks !

David B.

David,

What you want to do is change the code that sends reports on intervals. By default, the configuration only sends reports on the report interval (set in the device configuration) when the wattage changes by 50W or by 10% (which ever is smaller)

The latest code can be found here

If you look at the configure() method starting at line 304 there are some comments

/***************************************************************
Device specific configuration parameters
----------------------------------------------------------------
Param Size Default	Description
<snip>
0x5B  2    50       The value here represents minimum change in wattage in terms of watts for a REPORT to be sent (Valid values 0‐ 60000)
0x5C  1    10       The value here represents minimum change in wattage percent for a REPORT to be sent
<snip>

And later in the method the values are set:

secure(zwave.configurationV1.configurationSet(parameterNumber: 0x5B, size: 2, scaledConfigurationValue: 50)),	//Minimum change in wattage for a REPORT to be sent (Valid values 0‐ 60000)
secure(zwave.configurationV1.configurationSet(parameterNumber: 0x5C, size: 1, scaledConfigurationValue: 10)),	//Minimum change in percentage for a REPORT to be sent (Valid values 0‐ 100)

I believe that if you set those values to zero, it may always report every reporting interval even if the value is zero.

Your mileage may vary!

Good luck,
James

Thank you James,

Unfortunately, I did try that and also other combinations and it doesnt work for me. If the power is 0 (which is usually the case 75% of the time of an electric water heater), it just doesnt report. I am using it for logging power consumption of Electric Water Heaters, if you have another suggestion, feel free to suggest.

Thanks,

David

What about hooking it up to pollster and setting the poll interval to 1 minute?

SmartThings picked up the device but from the phone I toggle it to turn on and it does not turn on the device. If I press the button on the device SmartThings reports correct that it is on but then I cannot turn it off or on via the phone. Does it just take some time to communicate to the device and then it will work properly?

Am I missing something? I see that it sends the command, the Device status is Active but it seems that the relay is not being activated.

I ended up excluding the device and adding it again with the ST hub closer to the device. That time it added properly and commands worked as well as the statuses.

I am having the same issue as dbeauvais99, did you ever get this to work? I am having the same issue with a dryer.

I have done a general exclusion of the device, repaired it with Smartthings, all in the Classic app. I get everything but Watts and Amps. Not sure what to do at this point. What does “report interval” mean under the settings?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.