Adding device handlers: "Access Denied" error in IDE


I’m actually new to ST and IDE. I’ve basically linked the IDE with github and when i try to add a new DH i get the Access Denied - you are not authorized message.

May i know what am i doing wrong here? appreciate the patience and help.


When this “Access” error happens to me, which is way too often, I use Chrome’s Incognito mode, re-log in, and make the change. This works 99.9% of the time to add/edit DTH or devices.



I’ve tried the incongnito mode and it still doesn’t work. I’m really new at this and was wondering if it’s my account issue?

Any other suggessions??

Disconnect your github account and then reconnect it. That option is in settings in my Smartapps or my device handlers in IDE. Also, login to IDE at to make sure you connect to the right shard.

i’ve tried as mentioned by disconnecting github then reconnecting but still the same…

also if i create new DH and then enter a code; i get this error… Help please


Ok i’ve solved the issue with creating a DH. basically i need to change the run locally to false.

I see this often when I use Chrome (Win 10), but when I’ve used MS Edge, I have not had the same issue.