Add smartthings to google assistant

Hello, I install smart things in many homes over the last year and now all of a sudden have run into some issues connecting smartthings to google home.

The steps are pretty simple, so I have no idea whats going on, unless samsung has changed something?

Google home app
-add something thats already setup
-search smartthings and click on it
-transfers you to a site to log in (samsung account) but have tried both options
-then just kicks you back to the screen where you found smartthings in the list of things to add and never gets to the authorize screen? done this a million times, never links or adds devices. Also tried a different phone to see if that was the issue

also checked to make sure it wasn’t linked on the actual google account settings, and rebooted the smartthings…


1 Like

This is new user manual for SmartThings Hub that explains how to add google assistant

Scroll down to Google part

I’m guessing you didn’t read my post? i have followed the manual to the letter, and it doesnt work, please read what i wrote in my post, you will see where it gets hung up.

thanks anyways

Exactly the same issue here.
SmartThings hub v3, trying to add it to the Google Home app, no success.

Looking into Samsung’s announcement, looks like it will be added in January

I think what the OP said is that adding a SmartThings hub to the Google Home app used to work, but not anymore…

I was having the same problems all day, but I just tried it again and it worked for me. I really didn’t do anything different, so maybe just try it again.

I came to bump this thread because I am having the exact same issue…

I open the SmartThings app on my phone and can see that my Google account is already linked under Companion apps.

But, when I load Google Home and try to add new device, just as the oP described it, the Home app will show the list of all possible apps, and I will select SmartThings… From there it acts like it’s linking the two account and just refreshes and SmartThings never shows up as actually linked in my Google Home.

And yes, of course I have reboot my phone, re log into both apps, etc

This is an obvious bug and I sure would like to know how to fix it! Cheers

Can anyone who has an issue linking PM me there Samsung account email and I will take a look! This is not an issue we are aware of. Thanks.

Out of curiosity, are you seeing this issue on Android or iOS or both?


Hi Lars, thank you so much for the reply, I would happily send this to you for review. Pardon me but I don’t see a way to PM here on this forum… :confused:

I am having the same issue. Is there a solution yet?

Continuing the discussion from Add smartthings to google assistant:


You asked for private messages from anyone who was having trouble linking their smartthings account to their Google home/ Google assistant.

My Google e-mail is *** and both my home/ assistant and my SmartThings account use that email as my login.

When I go through the steps in the smartthings app it appears as if my Google assistant is already linked, but it’s grayed out unlike the Alexa assistant which appears blue like it’s actively working.

When I go to link smartthings in my Google home app, I search through the list of compatible applications, and click to add smartthings. It says it successfully added it, but then it reloads the list of compatible apps and SmartThings isn’t in the connected apps section. It’s in the available apps section.

Thank you for your time,
Preston Robertson

Same problem on 3 different android devices and 3 accounts. Any Solution? I can’t PM to send you contact info.

Hi Preston, I checked your account and I do not see any devices on it. When there are no devices Google will hide the action in the Google home app even if it linked successfully.