About to give up


(kyle) #1

Have a GE 12727 light switch (about 10ft away from hub directly) and everspring an163 outlet (about 5ft away from hub directly upstairs) and I cant turn both on or off reliably. The first day I got the hub and the first day I included both of these two up, it worked flawlessly. Now onto the 2nd day+ and its a hit or miss. Some days are better than others.

Out of the 2 the GE one gives me the most problems. Probably works 15% of the time i click on/off. The an163 probably 70% success rate. In fact right now the app says my GE is on but Im looking at the light and its dark. I can manually go flick the switch on the light but it will shut off right away and I have to flick it again (telling me something is telling it to turn off). Once the light is manually flicked on, turning it off via the app is pretty much a good 90% success rate.

Any ideas? Almost starting to think its the app itself. Using smarttiles.click doesnt work either.


(Ben Lebson) #2

If it is automatically turning off when you hit the manual ‘on’ button on the GE switch then it’s not a SmartThings issue probably… Those are not instant reporting so the hub would not be able to issue a command immediately after you hit the physical button. Sounds like something else funky is going on. Have you emailed support?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #3

Unless you’ve installed various SmartApp(s) or Routine(s) that have been configured to use that GE Switch, then nothing will be “telling it to turn off”.

This sounds most likely to be a hardware problem with the one particular switch. It happens … intermittent device hardware problems are the most frustrating, but the easiest to solve – i.e., buy a replacement unit and return the old one for refund or warranty.

I don’t recommend someone starting up to use a lot of devices in the system, but it helps to have more than 2; otherwise you won’t know if it is a software (App, Cloud), RF (ZigBee / Z-Wave) network, or single hardware device problem.


(kyle) #4

Yup emailed. Just thought someone may have additional experience here.

Right now smarttiles.click is reporting the GE to be on. I click it off and refresh smarttiles and its still shows its on. Something is up with that GE(?)


(kyle) #5

oh forgot to mention that the GE worked FLAWLESSLY when paired with my Piper cam/hub. Perhaps not a hardware issue?

Only reason why i switched over to ST is because Piper’s latest app update made my particular setup useless as I can no longer access my “things” in horizontal tablet mode (my “wall controller”). It was also slow to respond, needed like 5 seconds for it to actually execute the command for lights to come on. ST is instant…when it works.


(Brian) #6

Have faith, it should work more than 99% of the time you try, my setup does. It’s a device or configuration.


(Nick) #7

Is the Piper hub turned off and totally out of the picture? It almost sounds as it it’s interfering. As others said, the GE should not turn itself off without a smartApp.
The GE switch shouldn’t be paired with the Piper hub anymore, but who knows…
If the Piper hub is still on, turn it off and see if results are any better.


(Ben W) #8

If the switch is turning on for no reason, unplug ST (remove batteries) and test the switch out.

Now if its not reflecting right in ST that is a different issue. I noticed last night my time to update for manual presses was long and out of sync. In order to tell what the stat is ST listens for commands from the switch, “Switch 1 is off”. I think for some the queue was backing up and not refreshing ST. I was also working on a custom Device Handler and I may have mucked it up.

You can also try to pull the airgap on the switch to give it a reboot.

Look at live logging ide.smartthings.com It may help identify whats going on and if you have errors.


(kyle) #9

Took piper completely out of the picture. The GE was excluded from it before otherwise i couldnt add it to the ST anyways.GE still not reliable. Dont think theres an airgap on this model.

The GE works perfectly maybe 1 of 10 tries this morning to turn it on. BUT I just pressed it on off multiple times right now (3 minute break in between cycles) and at first nothing for the 3x i did this but then 5 minutes later the GE would turn off and on in rapid succession 3x as if it did receive all my commands but waayyy late.

I turned it off and just turned it on and waited to see if it would come on 5 min now and it didnt. So its not always it receives the command. When my phone sleeps and i wake it back up into the app (or if i turn it off right after pressing the on button and turn it back on), I can see the green on button go to off automatically.

The An163 seems to function sort of ok right now. Sometimes theres a 5 second delay from when i press it on in the app.
]


(Brian) #10

Hub away from router? Devices away from router?


(Ben W) #11

Something might have gone sideways with the unpair and the switch has a command stuck in its queue.

What I would do:

  • Do a zwave repair.
  • Reboot ST (take batteries out too).
  • If there is no airgap try killing the breaker for a few minutes

Look at live logging from the IDE if you are sending commands to the switch from ST. This will tell you if there are errors and when commands are being sent.


(kyle) #12

Ill dig more indepth later but just quickly seeing IDE right now and sending commands to the switch does nothing. IDE shows that its still “Waiting on events…” and doesnt change even if i refresh the page.

Funny just before I typed the the GE switch worked flawlessly. Now both smarttiles.click and the ST app show the switch to be on but obviously the lights arent on.


(kyle) #13

and then of course i just try it again after sending my previous post and the switch works both on and off…whaaattt.

lots of “debugs” in the IDE if this gibberish means anything to anyone =D


(kyle) #14

in fact the feed is constantly updating right now almost every minute with a new line of “debug” code and Im not even doing anything with the setup.


(Ben W) #15

smarttiles.click is just showing what ST reports so it should always match, even if its wrong.

As for the log that is weird, it looks like something is up. best guess a smartApp delete is not completing and its in a loop, probably sucking up all resources. You should hit up support.

edit:
What smartApps have you installed? The name of the app that is tossing it should be showing up at the top of live logging.


(kyle) #16

Looks like everything cleared itself up by itself without me even touching a single thing. I’m glad but this is rather anticlimactic. Was actually hoping that there would be some definitive problem thats solvable in case it comes back up again.

IDE logs look clear. GE switch working flawlessly for the past week.

A self fixing system? Maybe the investment into ST was a good one? Is ST known to fix itself? If so thats awesome, I wish all electronics are like that =)


(Brian) #17

Yes. And break itself too. :slight_smile:


(Bobby) #18

Wish that was true in all cases, but let’s not forget that not all breakings heal themselves. Some require TLC and a giggle or an update to push, a done to click AND several beers to chill.