2016 Honda Pilot app

Can anyone create a smart things app to go into the Honda Pilot radio? The Honda Pilot radio is full Android base radio. I would love to make that a presence, so when I get close to the house my garage door can open without using the little fob presence device. Or if I can do automations from in the car.

IS it a phone as well? Or Wifi? How would it communicate it’s presence?

I use Life360 on my phone, and a few pistons in CoRE with a contact sensor (optional) to achieve this. Works well, when Life360 is working correctly at least.

The car is just a radio, but I do have it connected to my wifi in my house.

A good example would probably be the BMW radio. It has Smart Things built into their radios.

Here is a link to a youtube video.

HOW DID I NOT KNOW ABOUT THIS??? Going to try this right now! :scream:

1 Like

Seems like the iOS version isn’t supported yet? I could only find information about the Android one. My main phone is Android, but I have an older iPhone that I keep connected to the car for music streaming.

I have an Android phone, and the phone works well, I just want someone to try to create an apk install file that I can install in my Pilot’s radio for it to use my smart things routines. I think I might be able to get by using the tiles from the web browser in the car… but an app would be super cool.

Maybe try something like this?

Thanks I found the apk file for Smartthings hub, I’m going to try to install it. I’ll let you know if that works or not.


Other options would include something like using Automatic (which has been integrated by @yvesracine and can be integrated for a cost: [DEPRECATED ] Automatic Connected Car- Integration with SmartThings), Dash (which has an IFTTT channel and the device options are cheaper than automatic, but it does have a delay with IFTTT), or using your router to determine that a specific device connected (if you have a router you can do that with) since you mentioned that the Pilot is connected to your home WiFi.

Here are a few links regarding the router method.

It didn’t work… bummer!!