1 of 3 Zigbee dimmers not reporting states

Hey all, long time reader, first time poster. Please let me know what etiquette I might not be aware of or am missing in this post.

I’ve paired 3 Ikea Tradfri transformers with my ST v2 hub to drive some lights in the kitchen and I set their DTH to Zigbee Dimmer. Two of these devices work perfectly - I can set up automation to dim and brighten them on command. When I look at these two devices on the web, it shows that they have 3 states - “switch” (on/off) “level” (0-100) and “checkInterval” (currently set to 720).

I have a third instance of this device, configured identically, but it only reports the “switch” (on/off) state and not a “level”. I’ve rebooted the device, my hub, removed and re-added it several times, and nothing has fixed it. What is weird is that I can still manually brighten and dim the device from the ST app when I manually control that single device, but my automation routines don’t control the brightness (works on the other two).

I also paired the device with the Tradfri hub for giggles just to see if there were any new device updates it wanted to push out - no luck.

Sorry for the weird one - let me know what info would be helpful for further troubleshooting.

Are they all using the same device handler? You can change that in the IDE (web) under edit device.

Yep, same device handler on all 3.

Where are you seeing this?

Hey Tony, screenshots below.

Working Fine


Not sure if this is significant, but it’s the last difference I see between the 2 working devices and the 1 weird device - the weird one has a status of “Active” and the working 2 devices say “Online”. Not sure if that’s pertinent.

My understanding is that when the device handler supports the Health Check capability you see ONLINE rather than ACTIVE. That is consistent with two of your devices having the checkInterval status, also a sign of the Health Check capability. It really is like one of your devices, the one misbehaving, is using a different device handler, as previously queried.

I’m toggling the DTH to other items and then switching it back to Zigbee Dimmer. Is there a certain length of time that I need to leave it on each setting? Or a way to force a refresh?

Hey all, this is finally behaving. I tried writing a custom DTH to expose the “level” state - no joy. Changed it to “ZLL Dimmer Bulb” and it finally worked. Changed it to “Zigbee Dimmer” - still works. Tried my multi-light automation in ST, still works.

Not sure what the actual fix was, but thanks for the assistance and ideas!

Sounds like an error with the original pairing process.
It’s the raw description and firmware the same with both devices?

Same firmware on all, yes. I didn’t capture the “before” raw description, but from what I put in the screenshots above they do match.