1/3 of my GE Link bulbs is not recognized


#1

I couldn’t resist the draw of a $15 light bulb, so I purchased 3 of the GE Link bulbs to try with my ST hub.

2/3 of the bulbs were discovered correctly as “GE Link” devices by the ST hub and they are working 100% (yay!) but 1 of the bulbs was not properly detected (it just showed as “Unknown” device type).

I went to the IDE and manually categorized the device as a “GE Link” bulb, but it still doesn’t seem to be working properly as I can’t accurately see the bulb status or turn it on/off. Very strange…has anyone seen this or could it be a faulty bulb?

I’ve also tried moving the bulb closer to the ST hub and renaming it + uninstalling it and manually turning on/off. I have zigbeeFirmware: 1.5.4 and Hub firmware 000.012.00074


#3

Ok, this seems to be resolved - I read a blog article where someone talked about resetting the Link bulbs by turning them on/off 5 times with 3 seconds between each on/off operation. I tried that and then let the ST app try to search for the bulb again. This time the bulb flashed 3 times and the app was able to recognize it as a GE Link device.

I guess that something went wrong the first time this bulb was trying to pair with the ST Hub. My advice…don’t try to add multiple bulbs at once. When you get a new GE Link bulb, turn it on by itself and make sure it pairs successfully before turning on the next bulb and so on…


#4

use the code in this thread for the GE Link devices, it is much more fully featured

http://community.smartthings.com/t/updated-ge-link-bulbs-finally-getting-on-status-after-manually-turning-on/8000/63


#5

@Daveuk100, just read your post. As k3vo stated, please try using that updated device type as well. I also recommend the Pollster app.