zwNwkRepair failure

You may want to start looking at which pistons can be moved over to Routines and prepare for the day when webCoRE will end. When ST migrates over to Edge and LUA, the legacy side of the platform will cease and that will include webCoRE and Smart Lighting.

1 Like

Thanks for the note. I’d gladly spend $150 on a tool like this. Unfortunately, it appears out of stoxk everywhere ive looked.

Wonder if there is a newer version of this, or a similar product available. Thanks

Try getting in touch with Zwave Products and see if they are expecting it to come back into stock, I believe they are the primary distributor. These days with supply chain issues, everybody’s having challenges, unfortunately. :disappointed_relieved:

Thanks for the reminder. I might as well start on this conversion at this point. I have a couple questions:

  1. Is there any documentation / primer for Routines & Scenes? Mostly interested in complex statements - similar to webCoRE capabilities. Like: If my Life360 presence is PRESENT and the outside temp is above 72F and it’s between the hours of 3:00p - 11:00p, THEN turn on the veranda ceiling fan (but turn OFF when any are not true. Or, complex nested AND and OR statements…
  2. Is there a web interface available, or can Routines & Scenes only be set up in the ST app? (I have a LOT of automation, as you can imagine, and it’s simply easier to complete that amount of work on laptop / web interface.)
  3. In my brief perusal of Routines, I didn’t see any way to do the equivalents of a “WAIT ()” or a “plus or minus OFFSET of minutes” (like, to sunset, etc) in webCoRE.

My ST network & automations (via CoRE and then webCoRE) worked pretty flawlessly for the last 6 years. Huge disappointment is this current OFFLINE issue. Gonna try placing some of my unused zwave outlets in various places in the house, to see if their repeater function has any effect on the mesh…

Thanks for your thoughts!

no

not similar so you will lose a lot of features of webcore.

only ST app but there is CLI that can be set up to use the Rules API.

they are there… sorta but there are major limits. right now, there is a limit of 60 minutes +/- but there is the virtual calendar using Edge you can install which adds that functionality to use a higher number. You will be disappointed when switching.

1 Like

Dave,

Routines are very easy to use.

In some cases you will need to use 2 routines to replace 1 piston. For example if you turn a light on at sunset, you would need to a 2nd routine to turn it off at midnight.

You can use virtual switches like variables. For my wash is done routine, I have a virtual switch called Washer running that is control by a 2nd routine and is used in the wash is done routine.



Just remember there is a limit on the total number of routines you can have now. Since the OP has over 140 devices, the limit may be an issue. :thinking:

Automation 200 limit?
.
Automation/Scene limit (2022)

Wow… OK. I’m a classically trained programmer (C, VB, PowerShell, etc) so my pistons are complex, complete with error detection (did the front door really lock? if not text me. Oh, it wasn’t closed, so notify me of that…)

If there are major limitations, causing me disappointment, maybe I should hold off on converting away from webCoRE. Is there a credible timeframe for when webCoRE will not be accessible?

From the platform’s point of view, Webcore is like any other custom groovy smartapp, so would be discontinued September 30th according to recent public statements.

Groovy deprecation - end of September 2022?

I will just point back to my original post earlier :slight_smile:

You might want to look into SharpTools. Paid license third party app, a lot of people find it well worth the fee of $30/year. There’s a free tier you can test out. And a free trial of the premium tier. Dashboard and rules engine. They have been working on getting ready for the new architecture and that version is in Beta now. You can find lots of discussion here in the forum.

Web-based, visual UI. :sunglasses:

(It doesn’t run locally, but neither does Webcore.)

1 Like

Not having any luck with Zwave Products / ToolSet availability.

Are there any other tools I can look for?

I’ve noticed that if I power reset the zwave devices, or power reset the ST hub, then all my devices come back ONLINE, but then slowly many of them go OFFLINE again. And it’s not always all the same devices that go OFFLINE. (Most of the same ones go OFFLINE but not all of the same ones…) This behavior makes me suspect I have a rogue zwave device causing the issue. Too much traffic? How can I see mesh traffic?

I can’t really turn the devices off one-by-one, since most are electrical switches and outlets (not battery powered). Whew… any suggestions to debug?

Also, I’ve noticed now when I do a zwave repair via the IDE, I don’t see any log entries. Not even “repair started” or “repair completed.”

Nothing as comprehensive. :thinking:

You can just get an Aeotec Z wave USB stick, use it with a laptop, and at least get a better topography map.

Did you get a response from Z wave products?

FAQ: Is there a way to see the Zwave mesh network map?

I called ZWave Products and they just said it is out of stock. Not sure when, maybe 2? maybe 3 weeks? Maybe longer…? LOL

Looks like there’s a Stick 7 now… any reason not to get the 7 instead of the Gen5? (I presume 7 is better than Gen5, but since i’m not familiar with the product, I’ll just ask…

Aeotec Z-Stick 7 – Aeotec Store

If you have series 7 zwave devices, it will be better to have the series 7 stick, but if you have older zwave devices, the older model stick is fine.

UPDATE:
On 23-AUG, ST Support (3) ghost devices (after my request for them to look and remove any from my network.) As of 27-AUG, devices continued to be OFFLINE.

Also on 23-AUG, I found an “UNKNOWN DEVICE” in a path and used the instructions to use the IDE to create a new device using the same zwave device ID. That worked, but the instructions to then delete that device in ST app failed. So it remained - visible in both the ST app and IDE. I asked ST support to delete it (but as of today 28-AUG they have not.)

On 26-AUG, I found another UNKNOWN DEVICE, which I was able to use IDE to create a new device with the same ID, but again, unable to delete via the ST app. Sent an email to ST support to delete it (well, both ghost devices I had found, and conveniently named “Ghost Device X” for ST support.

** Note: I ran zwave network repairs after each time I followed the UNKNOWN DEVICE / ghost device process.

Today, 28-AUG: I realized that my automations started working last night, and I look this morning and ALL my devices are now ONLINE. …and, there appear to be no delays when turning a device ON or OFF via the ST app now. (It’s like the last 3-4 weeks never happened!) I have absolutely no logical explanation for this. Frankly, I’m a little scared that ST support will now get around to deleting my Ghost Device X’s, and things break again. Oy veh!

MANY THANKS to you who reached out and responded with ideas! Wish I had something conclusive as to why things are now working. Nonetheless, thankful!

Looks like it’s back in stock as of this writing.

Hey - Thanks for the note! :wink:

I actually ordered one late last week and should arrive today or tomorrow.

All my network issues have been resolved for a couple weeks now but figure it’s probably good to have on hand anyway.

THANK YOU!

1 Like

No problem. Saw they were in stock and thought of this thread. Glad to hear things are working well for you now.

Now if the wheelchair repair place could just get my tires in stock…:roll_eyes:

1 Like

Hope your tires are available now.

Hey - So I’m having issues with my Toolbox. And their customer service phone is not willing to help me, and their tech support email is not responding…

I have connected to the Toolbox Wifi and changed its IP to something on my network, and rebooted.

My laptop on that 192.168.1.x network cannot access (browse to) the Toolbox; and the Toolbox cannot download updates. However, if I connect my laptop to the Toolbox Wifi, it can connect to the Toolbox (bother are on the 192.168.1.x network.)

oh, obviously, I also physically connected the Toolbox to my router with the cable they supplied. I see good Link status on the router, but not on the Toolbox itself.

Oh, and curiously, while my laptop can’t access (browse to) the Toolbox, an IP scanning tool on my laptop does find a device at 192.168.1.248.
:thinking:

Any ideas why the Toolbox doesn’t appear to be on my local network?