Zwave wall switch suddenly offline

Every so often one of my switches will do this. In the mobile app, pull up the device, click the gear, and click the replace button. It will check health and then require you to include it again by clicking on and off a few times. This way all your automations remain in place.


And make sure you have Device Health turned off in the mobile app. Finally figured out that was the cause of my losing all GE switches.


Turned off Device health and the device no longer says offline but still doesn’t respond to SmartThings commands. Still shows offline in ide however so don’t think this fixed it.

When I clink on the replace button the SmartThings app crashes. Tried it 3 times. Is there any other way to do this?

Then I opened the device in ide, selected edit, saved (no changes) and then it started displaying as “online”. But still doesn’t work.

Alexa used to say device not responding. Now it says “OK” but still nothing happens.

Did you cut power to the switch at your circuit breaker?


J[quote=“Shoot31, post:6, topic:109737, full:true”]
Did you cut power to the switch at your circuit breaker?


  1. Changed app to not check device health. Switch shows active but doesn’t work
  2. Cut power (still inactive)
  3. Opened device, selected settings, selected “replace”…app crashed. Light still not active
  4. opened device in ide (shows offline) selected “edit” selected save. Device shows online. Still not working.

NOTE: changes made using switch don’t reflect in app either.

UPDATE: while community was offline I finally got things working. Zwave repair broke everything and then a reboot fixed it all. Thanks for the help guys!

1 Like

Very interesting!

At present, I have a Zooz wall switch that got dropped from my ZWave mesh. It happened with the same switch last March and the “fix” was the same: use “ZWave Replace” and replace it with itself.

The discussion about this problem being unacceptable and having it happen when 1500 miles away from home is best kept for another time, so I won’t go there now.

But, I wonder if 1) it is a SmartThings problem rather than the switch itself, and 2) how many others have experienced this and blindly “fix” their missing ZWave device by “replacing” it with itself???

Obviously, it shouldn’t happen in a robust home automation system…

I have the same issues, I have Zwave wall switch that went unavailable 24 hours ago. And not the first time it has done so. I followed every recommendation, Replace device, power to switch cycled.
Smarthings is crashing for me when I select Replace in the Device config (Gears).
I did also un-install the Smartthings app, Apple iPhone 7 and iOS 11.2.
I have send Support an email requesting assistance.

The only other things I did was

  • try replace from Old android phone. Didn’t crash but just search continuously and never fixed
  • ran zwave repair ( caused all devices to start failing )
  • after repair unplugged hub and plugged back in (reboot) then everything started working again

I actually had a GE z-wave switch completely drop off my network. One day it was there and the next “poof”, nothing. I had to exclude it and then add it back as an all new switch. Fortunately, I only had a few automations running on it.

As of last night, I now have seven Z-Wave switches that are non-responsive… I haven’t had time to dig into it yet, though I’ll work on it later tonight.

So at this point there appears to be only one other report of the Smartthings App Crashing on iOS when selecting Replace in the Things configuration screen.

Negative. Mine did that last night from my iPad mini… I didn’t think anything of it since I never use ST on it, the tablet was just more convenient to reach than my phone. I ended up grabbing my phone and poking at the replace function, but it did not work for the switch I tested on.

Just a thought. Is Device Health turned On? Turn it off it is, and see if the devices become responsive.

It was on, though I had turned it off at a previous point in time. I disabled it last night, and my non-responsive devices were still non-responsive this morning. I’m at work so can’t get into the troubleshooting yet, but I will when I get a moment.

I had this happen once with an older GE switch in my garage.
I solved the problem by replacing the switch with a Zwave Plus switch (longer range).
I believe my problem was signal strength.
Note: the original switch had operated for several months. I suspect Mesh changes with new devices had some effect on the issue. The “Replace Device with Itself” method was not successful.
I have recently reused the original switch in another location.

For those experiencing Disappearance of Z-Wave Switch Syndrome, it would be interesting if you would log in to the SmartThings API, click ‘My Devices,’ click on the device(s) in question, and look at:

  1. Status (OFFLINE/ONLINE) and
  2. Last Activity At (date/time) fields.

It would be interesting to see if the switches all fell off around the same time (hub update?) or are simply asynchronous events.

Mine info is in screen shot above :slight_smile:

I suspect this is caused by the device health check as many have described. Once I turned that off my device said it was online again but still didn’t work. I suspect the reboot of the hub fixed that but it could have been some of the other steps I mentioned in this thread also, for example my zwave repair.

1 Like

Since my switch disappeared completely, I had to re-add it so my “Last Activity At” is with the “new” switch which I added back 12/9

Last Activity At 2017-12-11 12:51 PM PST
Date Created 2017-12-09 10:54 PM PST
Last Updated 2017-12-09 11:02 PM PST

1 Like

A reboot of my hub tonight resolved all of my offline switches.


So, hub update on 12/09 10:00 PM MST

Last Activity At 2017-12-09 9:57 PM MST
Date Created 2015-11-08 8:28 AM MST
Last Updated 2017-12-10 5:24 PM MST