Zwave Crashing and Rebooting

I had that issue. The 20.x beta cleared it up for me it also fixed the hub disconnects too.

Made it worse for me. The beta didn’t address the cloud-hub communication error. Bug-87.

John Cox

On the upside, I did create my own fix to it.

I’m also seeing “Z-Wave power cycle started” in my hub’s log.
I suspect it started after I tried to add a few Fibaro Wll Plugs to my setup. (I also added 2 Aeon Garage Door controllers yesterday, but they paired without issue and are working fine). The Fibaro Wall Plugs really don’t play well with Smartthings. I originally purchased 8 and over months only managed to add 3 successfully. I wanted to add 2 more yesterday, but in the end, gave up. (I have explained the issues in another threat, but it comes down to the Wall Plugs often not pairing in Secure Mode and even if you manage to include them in secure mode, they often still do not work.)
Anyway, in the end, I excluded the newly added Wall Plugs (I tried with 4 different device so I had to remove all 4) because I realised my other z-wave devices started acting funny. Even excluding the Wall Plugs was an issue and I had to remove them from the IDE. At that stage, I started seeing the Z-wave power cycle messages in the log. I noticed that there was a ghost device in the log, so I added a virtual switch with the same network ID as the ghost device. I subsequently deleted the virtual switch, but that did not get rid of the ghost device.
My hub continues to power cycle the Z-wave module every 90 min or so. Between the log entries “power cycle started” and “z-wave is ready”, there is usually an entry about a device which timed out (Err 120). (Never the same device).
Bottom line is, there seem to be issues with the z-wave module and for now, stay away from the Fibaro Wall Plugs (there are many members on the forum who have experienced similar issues with these plugs)
My z-wave module details (Not beta):

I had that problem before and created a ticket. This is the response I got:
“As far as the constant Z-wave power cycles, will you please power cycle the Hub by removing the batteries and power cable for 10 minutes? The removing of the ghost node should also allow you to have a more stable Z-Wave network as well.”
Needless to say, I did that and got no improvements. Then a few weeks later everything was back to normal with no changes in my network configuration.
Create a support ticket and let them look at it.
Also, don’t forget that backbone had various problems almost daily this year.

Thanks Daniel. I created a ticket for the removal of the ghost device when I did not manage to get rid of it.

Ok, so those are who experiencing this issue. I am sorry, we are working on it.

Background to the issue:

Well, we do not develop the firmware for the Z-Wave radio, this means, that we have to abide by their chip interface rules, and when the chip gets in modes where it is not responding, we have to power cycle the chip.

Updating the firmware on the radio seems to help, but there are still corner cases that we need to figure out.

If you have the update, the Protocol Version should show: 4.54 instead of 3.83. If you do not have the update and have received 20.16 firmware, you can message me your hub ID and I can remotely trigger the update to take place.

We should try to address more of this in 21.x release, and the Z-Wave radio firmware will be automatically applied if not already on 4.54.


@Kianoosh_Karami Thank you, Thank you for responding. I have to tell you I am a little disappointed in the response I have received on my support ticket. The person working my ticket is trying to get me to redownload the last firmware by performing certain steps with the button on the back of the hub. He then proceeded to tell me if that does not fix it to do a factory hard reset. I have over 1000 hours invested in the setup of my hub and would never do the nuclear option and start over.

I now feel 100% confident that you know exactly what you are talking about and how to fix this. So thank you for posting on my thread and reaching out to us.

I am still on 19.20 so I will wait for the next firmware update which I think is tomorrow and contact you if I am not on the z-wave radio 4.54.

Again, thank you for helping us.

Trust me, the 4.54 Z-Wave firmware fixes about 90% of the Z-Wave issues including the troublesome Z-Wave power cycle and eeprom write failure events. There are still a few remaining issues (my current favorite is devices which work but are reporting as not responding despite resetting & reconnecting several times). There remains work to be done on Z-Wave repair. Random, perfectly working line-powered devices, even those in the same room as the hub will fail for variety of reasons.

However, for the bulk of the issues, this update is well worth the wait.

1 Like

I am just glad I ignored my support email telling me to nuke my hub, absolutely insane that they sent that to me.

To be fair to the customer support, they get lots of issues reported to them and they can only have so much in depth knowledge of the issue, and unfortunately some solutions are not ideal but have proven to be successful. And like SteveWhite mentioned there are lots of work to be done :slight_smile:


I am not trying to bash support in any way. My frustration came from me asking numerous times to send my ticket to the next level support, which he did not do, at least as of yet. Regardless, thank you.

To me, the Z-wave business is super frustrating. I have for the past 10 days had nothing but issues when I want to include more devices to my network.
I spent more than an hour trying to add a Fibaro relay today. The symptoms are almost always the same - first, the hub refuses to go into inclusion mode. Only solution is to power it off for a while. Once up and running, it only goes into inclusion mode after the second, third of fourth attempt, but the device is not included. By the fourth attempt. the Z-wave network goes down and all Z-wave device stop responding. Once this has happened, you can give up and try another day. Following this, it requires a few reboots of the hub to get all Z-wave devices up and running again.
After a few days, one has usually gathered enough courage to try again. In my case, I have been struggling to add 3 devices for almost 3 days now.
My impression is that the Z-wave frustration has increased over the past year.
A friend of mine helped me to modify a blind-controller tonight and to test it, I had to frequently turn a Z-wave relay (located less than a meter from the hub on a test bench) on/off. Sometimes the relay responds almost immediately, other times it took up to 15 seconds to respond, which caused the friend to remark that the system appears to be a beta-level at best. I could only agree. And that was before I again made an attempt to add a new relay to to the system. Hopefully the Z-wave devices will start responding through the night. Tomorrow evening I’ll go through the same frustration…
Oh, and tomorrow, there will probably be one of two ghost devices resulting on hourly reboots of the Z-wave module.

@949BFN PM Me Hub ID and I can take a look to see what i can help you with

I am all updated to 4.54 Fingers crossed this fixes the crashes!!!

How did you get updated?
My hub received today’s firmware update
but radio is still on 3.83

Also tagging @Kianoosh_Karami

Send him a PM with your hub id and ask him to update you to 4.54.

Thank you.
Just did that.

I took care of it and DM’d you both.

Thank you.
Two things to mention

  1. It eliminated my ghost nodes (good)
  2. Z-Wave repair is much faster (also good)
1 Like