Zooz Zen20 S1 gives only 1 device in the new app

Need help with Zooz ZEN20.

While migrating to new Smartthings app, I’ve noticed there is an official device hander for Zooz Power strip Zen 20, so I’ve set-up my power strip with new official device handler, but it gives me only 1 button which switches all 5 outlets at the same time. what should I do to be able to control each outlet on a power strip independently? Anyone able to control each outlet on power strip separately in the new app?

Tagging @TheSmartestHouse

If you have the ZEN20 VER. 2.0, you actually need to install the child handler as well, so 2 handlers in total, as described in the article here.

Remember to exclude the power strip before installing the second handler and re-include it once the new handler is added so 5 child devices can be created.

1 Like

Thank you for sharpening the link. But I am confused, I am not looking for advanced settings, I just want to be able to control each outlet separately.

So is there is a way to do it with standard handlers or I have to use custom?

Are there any benefits of using standard handler vs custom?

If you don’t need advanced settings, you can exclude the ZEN20, delete the custom handlers, and re-include them to your hub, you don’t need a custom handler to control each outlet separately. With the custom handler, it will create a master device (to control all outlets at the same time) and display the USB ports for on/off monitoring while the built-in device type will only create 5 individual devices for each outlet (no master device or on/off USB monitoring), nor will you have access to any advanced settings.

Hope that helps!

1 Like

I have the same problem. I have a Zooz Zen20, version 1. In the Classic app I could see the individual outlets in the Zooz tile and could turn them on/off.

In the new app, I cannot turn the individual outlets on/off, just the entire strip (all outlets) at once.

I am using the built-in device typw

Have you tried excluding the strip and re-including it to SmartThings? We’ve been seeing issues with multi-channel device migrations, probably because they changed the way these commands are being handled between the classic and the new app. Re-adding the device usually solved it.

Yes, I did it twice with the same result.

Version 1 was officially integrated by SmartThings and they have a dedicated device type for it in their device list so if it’s still not being discovered correctly, we’d recommend getting in touch with SmartThings to see if they’re able to identify the issue.

Any updates to this thread? I have the same problem and same (non successful) results.