Zigbee devices quit working and then went offline

Yesterday I noticed all my Sengeled Zigbee bulbs quit working and displayed a message that said couldn’t connect with the server try again later. Hours later they started working again except for one that changed status to offline. I tried the normal reset but nothing worked and ended up deleting it last night and will try to reinstall it today. I have been having random connection issues with these bulbs and reset normally takes care of it. I do have a Sengeled Zigbee hub but no longer use it when I moved everything to ST. Would putting it back into my network allow for more stable performance of the Sengled devices?

More alarming is that late yesterday my new Kwikset Zigbee 914 lock suddenly went offline as well and remains offline now. I tried simple solutions like resetting my hub but that does not help. Later I guess I will need to remove it and try reinstalling it again (a pain in that I have to take off the lock cover to get to the switches). Hopefully it will reinstall but what could be causing these issues that are only affecting my zigbee devices? Are there any other methods to get these devices back online without a full removal and reinstall? Would switching the lock to Z-wave be better stability (I can buy just the chipset off e-bay and change out on the lock)?
Thanks.

if you have a v2 hub, ST has been pushing out an update that enables zigbee 3.0. is there a direct relation to your issue -I do not know. Contact ST support and open a ticket to let them investigate.

You might try powering down your hub for 20 minutes, remove the batteries if a v2 and force your zigbee network to rebuild.

1 Like

I have the latest V3 ST hub. Strange behavior.

I spoke to ST Support and they saw nothing unusual as to my Zigbee configuration or any other hub/app problems. Told me to just reinstall the 2 offline devices. I did so and both are now working BUT now I have 3 more devices (two Zigbee bulbs and one Kasa wifi switch) that have gone offline. I checked the logs and history and nothing there except they are offline. Since this is now affecting both Zigbee and wifi devices I have to think it is an issue that is not be resolved by rebooting the ST hub. I have not had this problem since I installed my hub about 6 weeks ago. Support has no answers so I guess it will require deleting and reinstalling each offline device but I certainly do no want to this multiple times a day. :thinking: :thinking:

for the tp-link kasa device, you can try going to menu > settings > linked services > open the tp-link casa integration and click Done (do not click delete) That may, or may not, reconnect the off-line kasa device.

Just as mysteriously as it went offline 4 hours ago it came back online. I’ll try your suggestion next time. Thanks.

Sengled devices are unusual in that they are mains power devices but they do not work as Zigbee repeaters. And they count against your total of non-repeating devices that can be supported by any one parent, including the hub. And if you use the physical switch to turn them off you cut power to them, which takes them off the network for a time.

You put all of that together, and it is not uncommon to see a situation where you end up having a few too many non-repeating Zigbee devices for what your Zigbee backbone will actually support, And as they get turned off at the switch others jump in and take the parent they had previously and you end up with a sort of musical chairs around the network Where they are all trying to connect to the same parents and different ones keep getting left out at different times.

I’m not saying that that is what’s happening on your network, just that it’s one of the things that might be happening that would produce the symptoms you are seeing.

(There is also the general off-line bug because of device health which can just randomly affect different devices at different times and the smartthings set up. :disappointed_relieved:)

Anyway, let’s just start with some basics and see if we can at least eliminate the Sengled-is-not-a-repeater orphan problem as the likely cause.

  1. how many total Sengled bulbs do you have? And how many of those have their power cut at the switch?

  2. how many total Sengled plug-in pocketsockets do you have?

  3. how many other nonrepeating Zigbee devices do you have? These are usually battery powered sensors and remotes.

  4. how many repeating Zigbee devices do you have On your smartthings network other than the hub? These are usually plug-in pocketsockets, in-line relays, light switches, etc. Do not include lightbulbs in this count.

  5. separate from 4), do you have any Zigbee lightbulbs connected directly to the smartthings hub of brands other than Sengled, like IKEA, Cree, Sylvania, etc? Do not count hue bulbs which are connected via a hue bridge. If so, what brand are the lightbulbs?

Once we have those counts, we should have a better idea of whether the orphan issue is a potential problem, and we can dig a little deeper. Or whether that’s not likely to be the problem, so you’re back at looking at smartthings-specific issues. :thinking:

Yes, but then they would no longer be available for use through SmartThings except via an Ifttt integration or use of another intermediary. Both the Sengled gateway and the smartthings hub expect to be the only zigbee hub on a network, you can’t use both of them on the same network.

This is quite different from the way the hue bridge works. Hue forms its own mini network for the Zigbee bulbs connected to it, and then uses the LAN or cloud to cloud to communicate with smartthings. So a Hue bulb connected to a hue bridge can show up in both the Hue app and the smartthings app without an intermediary. But with Sengled it’s one or the other.

Thanks JD. I have answered your questions below. You have been great help and assistance in helping me through this sometimes frustrating experience.

I did get everything back online by removing from the device from the app and then reinstalling but very strange why this is happening. The Kasa wifi switch cam back online on it’s own. I have found that my 10 Kasa switches have been very reliable so far. I am having major issues with the Zooz sensor (Z-wave) going haywire (battery drain and continual motion detection even when in an empty room) but Zooz support is sending me a new tested one. I am planning to install a couple of Sengled Zigbee door sensors over the weekend.

Regarding the disconnection of the kasa wifi switch or plugs. I used several kasa wifi plugs and this is my experience:

  • Is it shown offline in smartthings and in the kasa app or only in smartthings? In this case, it could be a problem with the services linked to kasa smart app and it could be solved by refreshing the link in settings.
    It ever happens that one or more devices show offline only in Smartthings.
    Something similar also happened, time ago, with meross linked services, they do not show offline, but it does not update states of some devices.

  • Does the switch lose the Wi-Fi connection with the router? In this case, as it has coincided with disconnections of zigbee devices, it could be that your router manages the 2.4 ghz wifi channels automatically and has changed to a channel that may interfere with the hub 2.4ghz zigbee channel and has caused these problems.

About this there is a post by @nathancu , which explains it very well, I really liked it.