Zigbee bulb preserving state after power outage: is this a change?

i have some cree bulbs in a fixture, plain old toggle wall switch.

there was a time, and i remember it vividly, because i complained about it, that, whether the bulbs were on via smartthings or off via smartthings, if i flipped the wall switch off and on, the lights would always come back on. at first i found it annoying that the bulbs didn’t remember their ‘state’ across a flipping of the wall switch. but it turned out to be convenient in certain situations, like when my housekeeper who knows nothing about the smart home comes in, she can just flip the switch off and on and get the lights to come back on.

but at some point this behavior changed, and the bulbs/smartthings “on/off state” now does persist across the wall switch being flipped on and off. so when the housekeeper comes in and flips the wall switch a couple of times, the lights stay off.

when did this behavior change, and more importantly is there a way to change it back in the IDE?

First off, those are zigbee bulbs, not zwave. Cree doesn’t make zwave. (I fixed your topic title.)


I’m not aware of any changes in this regard, @BroderickCarlin might know.

I do not believe that this change of behavior is going to be because of any changes of ours. A quick test to verify if it is the bulb or the hub is to unplug the hub and power cycle the bulb and see if it comes on as you previously expected

1 Like

maybe it came with the last bulb firmware update?

The OP may have to contact Cree technical support to find out about that one.

Was there any Cree firmware update through ST?

The last one I see mentions about was around 24.11 or 24.20 about a year ago. Or I have missed sime FW release notes.

@curtmcgirt, when your issue started?

@BroderickCarlin, was there any new OTA firmware added to the Hub FW release recently?
I can see something OTA related at the 27.x, but it doesn’t say Cree.

Firmware updates for various Zigbee devices including SmartThings Smart Plug (UK) and Aurora lights

I just noticed it because I installed one in a stairwell fixture controlled by switches at both the top and bottom of the stairs. Then I went to check the bulbs that were previously installed.
But it does only seem to be my Cree bulbs. I thought I had a ge bulb in the same fixture as a Cree bulb, but it turns out the ge bulb is elsewhere. I also have a Sengled bulb in my kitchen, and the ge and Sengled bulbs both turn back on when I flip the wall switch, even if they were previously off via smartthings.

The original Cree bulbs are in a room where I hardly ever flip the switch (my housekeeper does) so I did not notice their new behavior until this week.

Is it new Cree bulb what you are talking about?

Can you compare firmware versions of your Cree bulbs?

I would definitely reach out to Cree support to confirm the behavior. I think @JDRoberts posted somewhere that Hue bulbs have received the option from Hue by a firmware update, that you can change the power on behavior in the Hue environment.
I have Hue bulbs at home some are older, some are newer models. The newer ones has default if you flip the switch, it keeps the last state. It is perfect for a short power outage. The old ones just turn on for the flip. But if you turn it off for a longer period and turn it on again, they turn on, and disregard the last state (color, brightness). They basically reset to default color and brightness.

You can try the same with your Cree bulbs.

1 Like