“Alexa, turn on/off lights” only works with dimmable lights

Dimmable Switches (working): Leviton DZ6HD-1BZ Decora Smart 600W Dimmer with Z-Wave Technology

Dimmable Bulbs (working): Phillips Hue

Non-dimmable switches (not working): Leviton DZ15S-1BZ Decora Smart Switch with Z-Wave Technology

Also using several Leviton DD0SR-1Z 120VAC Decora Digital/Decora Smart Coordinating Switch Remotes for 3+ way switches

SmartThings Hub: V2

Issue: I’ve grouped devices into 5 rooms with various echo devices designate as the “Alexa” for that room. The expected behavior is that when I say “turn on/off” lights, that all smart light bulbs (Phillips hues) and smart light switches (Leviton, various) turn on/off. However, currently, on dimmable light bulbs (all Phillips Hues) and dimmable light switches (Leviton DZ6HD-1BZ) turn on/off with that command if there are dimmable and non-dimmable light devices. If that room contains only non-dimmable devices, then the command works as expected. If the room only Contains dimmable devices, then it works as expected.

Anyone have any idea what could be causing the non-dimmable switches (connected to Alexa through smarthings) not to work properly?

This room works as expected since all lights are dimmable

This room does not work as expected. On the Phillips hues (L3) and dimmable switch (Dinning Room) work with the command. ( one pecfation for the smart plug to work, I’ll set an IFTTT once everything else is working)

In order for any device to be turned off by saying turn off the lights it needs to be set as a light. You need to select each device listed under switches and then on the next screen select the edit at the top and change it from a switch to a light.



I do have echo control groups that include both “switches” and “Lights” that work fine with the “echo, turn on the lights” command. But I went back and checked, and all of the ones that are identified as “switches” are just binary on/off devices. All of my dimmer switches are identified in the echo app as “lights.”

It appears that Lutron already identifies their dimmers as “Lights” To echo, because we didn’t have to make any changes on our side.

But smartthings and wink Both identify dimmer switches as “switches” to Echo, and then they don’t work in the control groups until, as you pointed out, you go into the echo app and change them to “lights.“

1 Like

Here’s the screens in the Alexa app the OP needs to update the device


Switching them from switches to lights did the tricks I was even able to label a plug as a light as well.

All is working as expected now. Thanks so much for the help!