Z-Wave Secure Thermostat SEC_SRT322 from Vesternet. Anybody added this?

thermostat

(Terry M) #1

I have installed a Z-Wave Secure Thermostat & Receiver Set to control my combi-boiler but do not know how to get it added as a device in my SmartThings Hub.

Any help greatly appreciated!

Terry


(Jimmy) #2

were you able to get it into pairing mode? How you do this varies by model, but once you get it in pairing mode and then start pairing in smartthings app it should find it.


(Terry M) #3

I can get it into pairing mode, but the smartthings hub doesn’t ‘see’ it.


(Jimmy) #4

hmm, the generic z-wave handler should find it. Have you tried excluding it and then pairing it?


(www.rboyapps.com - Make your home your butler!) #5

Power cycle the hub and then try pairing it and ensure that it’s within 3ft of the hub.

If you have access to RBoy Apps, try using this Enhanced DTH for thermostats that use secure Z-Wave plus communication:


(Terry M) #6

Thank you I will check it out.


(Terry M) #7

I cannot get the Hub to ‘see’ it.


(Jimmy) #8

Have you tried a general device exclusion and then pairing it?


(Terry M) #9

I have been able to exclude the device.

I can add the SRT322 thermostat to the SmartThings Hub, but on the app if I select it I get a msg that it cannot connect. On the website connection it shows as ACTIVE rather than ONLINE. I also cannot now get the SSR303 receiver to go into network mode.

The thermostat and receiver are paired and work fine.

Terry


(Jimmy) #10

A couple things to check:

  1. login to https://account.smartthings.com and check which Type got assigned to it
  2. which SmartThings app are you using? New one or Classic?

(www.rboyapps.com - Make your home your butler!) #11

It sounds like you’re using the new ST app. If so, try switching over to the Classic app


(Terry M) #12

I have removed it from the network so not sure about Type - can look at this on Monday.

I have the new app.

Thanks


(www.rboyapps.com - Make your home your butler!) #13

Switch to the Classic app and try it. I suspect it’s paired but you can’t see it because you may be using a custom handler and the new app doesn’t support custom handlers.


(Terry M) #14

Getting closer :slight_smile:

I have switched to the classic app and used your device handler code. I have successfully added both the SRT322 thermostat and the SSR303 receiver switch to SmartThings Hub and also linked them together.

Using the thermostat manually it works fine, switching the heating on and off.

In the classic app the thermostat shows the room temperature and the heat setting temperature. It also shows fan control and cooling, neither of these are functions of the thermostat. The receiver switch shows OFF (which is correct).

However, if I change the heat temperature setting in the app it doesn’t do anything and if I click on the receiver to turn it on from the app nothing happens.

Any suggestions would be appreciated.

Thanks

Terry


(Terry M) #15

I have now switched to the classic app and been able to add both units, but I cannot control them from the app.

Terry


(www.rboyapps.com - Make your home your butler!) #16

I checked the specifications of your thermostat

Basic V1
Binary Switch V1
Manufacturer Specific V1
Thermostat Mode V1
Version V1

It only supports turning on and off either via a switch device handler or setting the mode to heat / off using the thermostat DTH. It doesn’t seem provide an option to remotely configure your setpoints over z wave which is why you’re probably seeing no response.


(Terry M) #17

Hi,

I have now removed and reinstalled the thermostat and receiver. Both show as ONLINE.

If I change thermostat setting manually the receiver switches on and boiler runs AND the receiver changes from OFF to ON in SmartThings app.

But the thermostat only updates set temperature after several hours and changing the setting temperature in the app has not effect on the thermostat.

This is the info:

/**

  • Copyright 2015 SmartThings

(www.rboyapps.com - Make your home your butler!) #18

That sounds about right, your thermostats specifications doesn’t support remote configuration of the temperature settings.


(Terry M) #19

OK, but what I do not understand is there are people that use with Vera hub and it works.

I am totally new to this and wonder if you could help in terms of a Device Handler that would work. I am attaching the current device handler and a PDF of the instructions for Vera.

Thanks

Terry


(www.rboyapps.com - Make your home your butler!) #20

Okay I checked it out. This is a rather complicated thermostat (unlike most z-wave thermostats).

This is a sleepy device and not a beaming/listening device by default. It switches to Listening mode in between when it wakes up for a while and then goes back to sleepy mode.
The difference being that when in listening mode it can send/receive messages, in sleep mode the radio shuts down to preserve battery and it can’t receive any commands.

This is important because all the DTH’s for thermostats in ST assume that the device is either in listening mode or beaming mode and hence it sends the command immediately and doesn’t queue them. That’s the key reason why you don’t see your thermostat responding to commands, it’s gone to sleep and cannot receive commands. Vera works around this issue by queuing all the commands until the device wakes up and then sends them.

The problem with this approach is that commands won’t be reflected in real time. The default wake up period for the thermostat is 23 hours which is why it claims a 2 year battery life (like most sleepy devices). However that impractical for communication purposes.
There are ways to reduce this down to a few minutes but that still won’t solve the problem since ST’s DTH’s are not designed to queue commands. So to resolve this issue:

  1. You need to build a custom DTH that queue’s commands
  2. Reduce the wake time internal to few minutes

This still won’t be a real time solution and the downside is that your battery will last no more than a few weeks/months depending on how often it wakes up.

I would recommend using just the standard or the enhanced thermostat DTH and use it to “view” your thermostat’s state (current settings/temp) rather than actively trying to control it. If you want active control I would recommend using a CT-110/CT-100/CT-101 or a GoControl z-wave thermostat. With those you can expect about a 3-6 month battery life depending on use.