Z-Wave Repair Causing Issues

I have around 65 Z-Wave plus devices that are connected to SmartThings. Over the past week or so I added about 15-20 more z-wave plus devices and thought it would be a smart idea to run a “Repair Z-Wave Network” since I had added so many new devices.

This appears to have been a huge mistake. While everything seemed to be working perfectly before for the past 2+ years, I am now having tons of problems with device control. IDE shows all devices connected and last activity keeps updating, however when attempting to control devices from the app or from buttons, nothing happens.

A lot of the errors I’m seeing in the Event List show “Network repair for DEVICENAMEHERE [52]: Could not update neighbors.” I see about 8-10 of these in the Event List after running a repair.

Have I screwed it up horribly or is there an easy fix? I don’t want to have to go around and exclude and include all my devices again.

Thanks in advance!

How many repairs have you run so far?

2 over 2 days. None back to back

I’d keep going. Run them back to back until you get no errors.

1 Like

Seems like this is just making the problem worse. Each time I run the repair, different devices show up as unable to update neighbors.

I use to have well over 150 zwave and zwave+ devices, and it seemed like the more I added the worse things got. Out of all those, about 100 were repeaters. Eventually I gave up on getting clean repairs because it’s impossible in my opinion with that many devices.

I became so frustrated with ST’s implementation of zwave and all their changes, and/or zwave in general, that I moved almost everything to Zigbee. As I was doing that move, the fewer zwave devices I had left, the better things got with my zwave mesh. In fact, once I got to around 30 devices remaining, I had the first perfect zwave repair in several months, if not well over a year(s) and device performance was the best ever.

Personally I think you’re going to have to expect what you’re seeing as normal with as many devices as you have now, and hope that ST’s implementation of zwave improves over time.

I wouldn’t care about the failures in the logs if I was able to actually control my devices. The problem is that I can’t control some devices all of a sudden and the only correlation I can think of is the addition of about 15 devices to the network

Try disabling device health in the Classic app and also reboot the hub in IDE

Device health is already disabled and has been for a while.

I rebooted the hub from IDE yesterday.

All devices in IDE are showing either ONLINE or ACTIVE. I have no devices that show DISCONNECTED or OFFLINE. This is what makes this problem weird.

But you should care because those failures are a result of a mesh not performing at its best, hence device control/response/performance issues. With that many devices, you’re going to have to go through several back to back to back repairs. I once started on a Friday when the family was gone (minimize usage of devices during a repair), and I stopped on Sunday. Also, if you have chatty devices that like to report things like watts usage very often, scale that back or turn that off during repair sessions. You should also validate that you don’t have any bad devices in your existing mesh.

Yeah I’m working on the back to back repairs now…while running the 2nd one, I ran across this in the logs:

zw device: 45, command: 600D, payload: 01 00 32 02 21 32 00 00 00 1E 00 00

There’s a couple more with different zw device IDs but I don’t see those IDs associated with any of my currently paired devices.

Also, thanks to everyone who’s chimed in and tried to help. I really appreciate it!

Those are are ghost devices, which are typically the result of force deleting zwave devices without an exclusion process being done first. ST support can sometimes remove those for you, or you can spoof the process too. Search the community on "ghost devices ".

Good luck and keep us posted!

1 Like

So just as an update…

All of my devices are back to working normally now even though I still have about 5-6 that fail on the z-wave repair each time. I was able to remove about 3 ghost devices that were showing up in the logs using directions from a previous forum post as suggested.

Also, my non-responsive devices turned out to be all of my Monoprice Z-Wave Plus Smart Plugs (4 of them). I just ended up excluding them and then re-including them back since they would not repair. I was not able to do a replace on them either. It was a little bit of a pain getting all the automations set up on them again through webcore, smart lighting, etc but it wasn’t as bad as re-doing all 88 devices on my mesh network.

Again, thanks to all that helped!


This looks like the appropriate place for my post…
I have just stood up a new zwave network in my new home using existing hub and zwave devices from my previous home. All of the devices are simple appliance and dimmer plug-in modules. The hub is a version 2 SmartThings hub. All of this worked perfectly in the previous residence. I had been using the classic version of the SmartThings phone app previously and didn’t get it migrated to the new Smasung SmartThings before shutting everything down to move, and by the time I got around to installing the network in the new home the classic version no longer worked so I had to move to the newer app. I went through extensive attempts to get the new app to log into my existing account unsuccessfully (long story, no need to discuss here) so ended up initiating a new account, generically excluding all of my modules, adding them to the new account one at a time, and moving them to their desired locations. All went well with that, and after placing all of the modules I needed (8, with three of them left not installed, 11 total) I though it best to do a network repair since all of them were initially added right next to the hub. Now only the one in the same room as the hub is working and the rest are completely offline except one which show online but doesn’t work. This is only 8 modules… seems like the ‘repair’ should have been able to handle this quickly and effectively. The modules are separated by as little as 12 feet and as much as 40 feet, through walls. No worse than where they were working before in the previous residence.
By the way, I mostly use these during Christmas to switch lighting with maybe one or two remaining in place during the rest of the year.
Anyone here recently have problems with the zwave network repair utility? Any ideas of what might be causing this?