ST Issues after 40+ z-wave device

I’m seeing all sorts of issues after growing my z-wave network beyond 40 devices. I have a bunch of Inovelli Red Series dimmers and a lot of window shades (Graber Virtual Cords). I was able to grow and add my devices slowly … and repaired the network every day or so after adding to make sure things were optimized, but now I’m having a hard time even adding devices within line of sight to ST Hub (v3).

We have a large house and I was being methodical about adding devices in … starting close to my hub and moving out … giving time for the mesh to optimize … but nothing I do helps anymore. I’ve read other threads where once people get above 40 z-wave devices … they run into issues and repair network commands spit out errors (I’m seeing that too)

I’ve tried excluding and re-adding some devices to make sure they’re enabled with S2 … Some get added but without S2 security enabled (even though I entered the PIN code).

Can someone at SmartThings look at my logs and see what’s going on? This is all very frustrating … I’ve spent thousands on these switches and shades … @Kianoosh_Karami can you help? I’ve seen you’ve been able to help others.

1 Like

I can do that I’m seeing errors for device IDs I don’t see in my app or IDE. Is there a way to remove these as I feel like this might be what’s causing a lot of my issues.

Hi @SamR, I’m probably one of those people you’ve read about. I ran into EXACTLY the same issue as you. I’m very skeptical of ST’s zwave implementation because of what I’ve ran into over the last few years and the changes they make that you can’t control or don’t know about until something breaks, so I’ve abandoned all but a handful of Zwave devices on ST and have moved everything to Zigbee. That move had the most dramatic and positive impact on our usage and gigantic improvement in ST reliability and speed. I should have done that move years ago.

In saying that, I can’t be 100% sure that getting below a certain zwave count did the trick for me because I also had old GE devices take could have been causing some issues. It may also be good devices causing issues too, and they might not be failing but instead may have an internal “bug” in their routing table logic. For example, I had 2 Mimolites and 1 water flow meter device (still have) from FortrezZ that would crap out after every single Zwave repair I did, which required a power cycle to get them to work again. Once I got below 30 devices and ran a repair, the Mimolites did not crap out, and neither has my water flow meter. Could that be related to FortrezZ’s firmware having an issue with a large route table bug, or being in a large zwave mesh? I have no idea, but all I know is that after my Zigbee migration my water meter zwave device has never failed again. All those devices were not zwave plus BTW.

I wish you luck trying to figure this one out because you’re not the only one in my opinion, plus you’re using new zwave plus devices (I assume w/the latest firmware from Inovelli)

Tagging @Eric_Inovelli for an insight from them.

3 Likes

Very likely at least part of the problem.

The way I’ve cleaned those up in the past is:

  1. Open the IDE
  2. Create a virtual device and assign it the ID of the “ghost” device. I usually name these “trashxxx”
  3. After saving the virtual device, use the IDE to delete it.

Wait a while before trying another Z-wave repair.

I started having issues with my Z-wave mesh at about 25 devices. Possibly exacerbating the problem was that 90% of my devices were in our great room. That room includes kitchen, dining, wet bar, and living room. In addition to indoor lighting, the switches for all the outdoor lighting for the front porch, front walkway, and patio are there. I was getting repair errors on around 20 Z-wave dimmers and switches, all around this one room. All my devices are two years old or less and all are Z-wave Plus.

I have since replaced a few of the devices with some of the new GE/Jasco Zigbee 3.0 devices. FWIW, I like those devices and they’re not too expensive. I did one 3-gang multi-circuit box where their smaller bodies were very helpful.

I’ve currently got 24 Z-wave devices and getting clean repair runs. But I’ve also got 7 more Z-wave devices in the cupboard waiting to be installed.

1 Like

Thanks for the tag!

@SamR – I think @Kianoosh_Karami is your best bet here. He’s amazing at helping in these situations as there’s not much we can do from our end since we can’t see under the hood of your hub.

One thing that you can check that I’ve seen cause issues is to see if your devices all paired correctly. https://support.inovelli.com/portal/en/kb/articles/troubleshooting-device-not-sending-commands-to-hub-smartthings

I don’t think this is your problem, but it’s worth checking just in case as I’ve seen this cause a lot of issues with people writing into support.

I also think @HalD’s advice is solid – I’d give that a whirl until you hear from Kianoosh.

1 Like

I’ve tried removing the ghost devices using virtual devices in the IDE and I still get a ton log references to these devices after they were “removed” and I ran a repair.

@Eric_Inovelli - I’m using exclusively Red Series dimmers (about 50 total) and when I first started adding … I had no issues and was able to add with the DSK code to get S2 security enabled. Now I never get that … and adding new dimmer locations doesn’t work. I’ve excluded, reset … and nothing. The exclusions work right away too …

re-publish the custom DTH. They go “stale” and cause devices to not show-up when added. You may also want to turn back the energy reporting on the Red series dimmer. Lots of frequent energy reports can clog the network.

1 Like

I will try the republish … and I actually started disabled energy reports on the dimmers as well as I read that somewhere else.

I’d really like to understand why these dimmers are not joining with S2 anymore. Maybe the DTU repub will help with that.

@Eric_Inovelli - I can’t seem to add any of the Red Dimmer switches anymore. I have one that I excluded and reset … and it’s line of sight within 15 ft of the hub and it won’t add.

did you re-publish the DTH?

I did … So frustrating. I decided to scratch and start over with a hub reset. And the damn hub won’t even add a dimmer switch 10 ft away (that was connected before)… and I’ve excluded and reset the dimmer too.

After resetting and slowly adding the 50* devices again and having it run smoothly for half a day … everything sucks again.

I called support earlier in the week … got it escalated … and nothing.

I just ordered a Hubitat. Done with ST.

Hey SamR

I apologize for the delay in getting involved earlier, unfortunately I am super busy with many things.

I’d be more than happy to take a look at your network, and the sluggishness that you may experiencing. Please PM me anytime and I can take a look at stuff.

1 Like