Z-Wave problems

Hi people!
I have been building my security and automation system for some weeks now.

Issue 1

  • On the Smartthings IDE, in the device detail page, why some devices show “route” and “metrics” and others (most) don’t? Even between equal devices! Thought, if it was direct connected to hub it wouldn’t show, but some directly connected devices do show “route” and “metrics”.

Issue 2

  • I’ve got this z-wave door lock device that shows in “route”:
    This Device (0B) ↔ Unknown Device (81) ↔ Unknown Device (98) ↔ Porta Arrumos (1) (1E) ↔ Sensor Hall1 (3) (16) ↔ SmartThings Hub
  • Facts:
    • I’ve got no (81) nor (98) devices on the network or lurking outside the network
    • Devices (1E) and (16) are not repeaters (they are battery operated)
    • The device (0B) works correctly though
    • Repairing Z-Wave network doesn’t change anything.

Issue 3

  • Repairing Z-Wave shows randomly devices that “failed to update route”. Every time it runs different fail, but always at least one fail.

Thanks for any help

For issues 2 and 3, you have ghost devices that need to be removed. @RBoy has a very nice write-up on how to remove them:


Item 1 is also likely related to 2/3. Devices dont show route information if they havent reported.

1 Like

Thanks for your replies. I should have searched for “route unknown device” before asking this. My bad.
But unfortunately like many I’ve now read about, nothing worked nor changed a bit.

What I’ve done:

  • Manually added device (81). Forced removal.
  • Manually added device (98). Forced removal.
  • Z-Wave network repair (x2). Still reports random devices failing updating route.
  • Restarted Smartthings Hub V3.
  • Z-Wave network repair
  • Powered down Device (0B) for 5min.
  • Manually added devices (81) and (98). Didn’t remove.
  • Z-Wave network repair.
  • Powered down Device (0B) for 4 hours.
  • Z-Wave network repair.
  • Removed both ghost devices.
  • Z-Wave network repair.

Checked on the IDE device detail page in between most steps above and always (and still) shows:

Route: This Device (0B) ↔ Unknown Device (81) ↔ Unknown Device (98) ↔ Porta Arrumos (1) (1E) ↔ Sensor Hall1 (3) (16) ↔ SmartThings Hub
Metrics: Received Messages From Device: 15
         Received Messages From Device (Duplicates): 0
         Messages Transmitted to Device: 43
         Messages Transmitted to Device (Failures): 29
         Updated Time: 2020-12-27 1:16 PM WET
Data: networkSecurityLevel: ZWAVE_S2_ACCESS_CONTROL

After all this, I find strange that:

  • Device (0B) still works normally.
  • Device (0B) still reports no update since two days ago.
  • Device (0B) shows the same “metrics” numbers since I’ve started this troubleshooting (and most probablyt since 2020-12-27!).
  • Mentioned device (1E) doesn’t show “route” nor “metrics”. But mentioned device (16) shows “route” and “metrics” (where it shows the same: “updated Time: 2020-12-27 1:16 PM WET”)

Also, in all my smartthings hub existence, I only removed one device (to add it back). So I would dare to say that those ghost devices (81 and 98) never existed on the network. Also, I don’t have neighbors at my location.

Should I contact support?

Whether you contact support or not will be up to you. Unfortunately I suspect, at this point the only thing they can help with is removing ghosts, and you’re already doing that the likely answer you will get is ‘rejoin device X’ or ‘reset your hub’ …Nobody wants that.

So first, a little expectations setting. This will not be an easy, fun -or FAST process. You will be fighting this for DAYS.

(pause for effect)

BEST case, with the amount of weirdness you’re describing, expect you will be fighting this through the end of the week.

When removing ghosts and resetting routes, each repair will unblock something - but there may be other blockages and busted routes. You will do this again and again - clearing the next ghost you discover and removing it, then running a repair, until suddenly the backlog will clear and everything will suddenly work better. I was recently fighting with an issue post .34 firmware and it took me a record 22 repairs to get through it. (Yes, I counted. It took 14 days, and the entire time I was LESS than happy about it. I also have 80 something Zwave devices and it takes ~30 minutes for each run…)

It doesn’t matter if you have neighbors, doesn’t matter if you never added or removed anything, the unfortunate fact of the matter is your routes are busted and you have to fix them. Don’t go by whether the IDE reports a route or not - It’s only reporting the last reported route. With Zwave a given device can and should route automatically through all reachable neighbors - there will be be other routes in use by a device that don’t get reported.

Your bellweathers are ‘does my device work’ and does my repair come back clean. Of those two - all devices working ALWAYS trumps did the repair come back clean.

The best hints I can offer in fighting through my own:

  1. ALWAYS clear all visible ghosts before running any repair (I saw you have a few you didn’t delete - they’re not helping anything staying around - kill them)
  2. Resist every urge you have to spam the repair function. Repeated repairs don’t help much and usually needlessly complicate things. It takes time for the system to stabilize after running a repair. Best case is to let the system rest a day or so between repairs. Understandable sometimes you cant - but if you can find a stopping point, do it and let it ‘cook’ to see if things get better. ZWave devices will work behind the scenes on normal network timings and things and fix themselves - if given enough time to do so. I had better results running repairs if I waited between runs.
  3. If all of your devices save 1-2 are working - then kill and rejoin those few devices it will save a lot of headache.
  4. Locks are a pain in the BEST of circumstances because of the security requirements to joining. They’ll probably be the last ones to lock in and work. (My fiasco started with my back door lock)
  5. have a designated test plan to run after each repair (I had a spreadsheet with all the devices I cared about and tested every one in the list after each run.) If your list comes back good - stop, no matter what the IDE says. If it comes back good minus 1-2 devices rejoin those and then stop and let the network cook. (see #3)

Thanks! I need to read your message early in the morning and slowly! :slight_smile:
But one thing I can say for now: I tried to remove the two ghost devices twice, it doesn’t change anything at all: they are still reported on that device 0B route.

This just solved by it self… :roll_eyes:

Thank you for your time!

What’s interesting is that I all of a sudden also have 2x ghost devices with ID 81 and 98 like yours. I tried deleting both of them using RBoy’s method and after a z wave repair they were both back again. Support is currently looking into it but no word back yet.