Z-wave lock edge driver - no option to add/edit codes

I have a Schlage Connect (BE469ZP) Z-Wave lock. I was able to install the Smarththings Edge driver with the lock and the lock displays, locks/unlocks fine.

But I’m not able to add any codes to the lock.

I also installed the “Smart Lock Guest Access” app from the “Life” section, and all that does is allow me to lock/unlock the lock or all locks. It does not have the option to add/remove codes either.

I also tried this with the Z-Wave Lock driver from @philh30 but got the same results.

Any idea what I need to do to get access to setting codes?

Any info would be appreciated.

Did you try clicking on the tiny very gray arrow next to “Locks” in the upper left corner? They seem pretty intent on hiding that.

2 Likes

@bthrock

Thanks, that was it. I could not even see that drop down arrow!

1 Like

@allanp , I believe that @troy_owens is incorrect when he stated that the Beta drivers “are” the production drivers.

All of the Samsung-written Edge drivers are in GitHub. The Beta drivers are here:
https://github.com/SmartThingsCommunity/SmartThingsEdgeDrivers/tree/beta

And the production drivers are here:
https://github.com/SmartThingsCommunity/SmartThingsEdgeDrivers/tree/production

If you look at the production Z-Wave lock fingerprints.yml file, you’ll see the vast majority of lock models are commented out, while the same file on the Beta channel shows those locks as uncommented (and therefore currently active):

https://github.com/SmartThingsCommunity/SmartThingsEdgeDrivers/blob/production/drivers/SmartThings/zwave-lock/fingerprints.yml

https://github.com/SmartThingsCommunity/SmartThingsEdgeDrivers/blob/beta/drivers/SmartThings/zwave-lock/fingerprints.yml

As you would expect, the production channel only has a few locks currently supported, as clearly they are still testing out some of the more complex functionality on the Beta channel.

If you subscribe to the Beta channel, you can use a pre-release version of the drivers and give your feedback to Samsung on what works and what doesn’t; if you don’t subscribe to the Beta channel, Samsung will eventually send you the Production driver once they finish their development and QA and your specific device is supported (no longer commented in the fingerprints.yml file).

I’m choosing to not use the Beta drivers, I have Kwikset and Yale Z-Wave locks that are not yet supported on the production branch. I’ll wait until they push out the production drivers, and I’ll keep my fingers crossed that the developers will be responsive if any bugs crop up in those drivers.

1 Like

Thank you for that detailed explanation with the links. That is what I thought as well regarding the beta. That’s why I was wondering if eventually my system would get switched over from beta to production once the code was approved.

I did use the link provided by @TonyD to the Beta channel, which I assume is somehow the same as the one you gave. Yours is the beta files on Github, whereas his was to a Samsung site that starts with “callaway.smartthings.com”. Not sure if they are the same or not.

So far the beta driver seems to work properly. Or at least any hiccups I’ve seen are no different than before. Things like the history being delayed before it appears,

Has anyone determined if there is a 3 code limit to the smart Lock Guest Access? I’ve sucessfully installed 2 locks, one FE469 AND ONNE Kwikset. However, i can’t get the Life app to accept more than 3 codes. I get a “Something went wrong while creating the code. Try again” error.

I have 8 codes currently in SLGA with my Schlage BE469/BE469ZP locks.

1 Like

How many max on each lock. I’m stuck with 3 on each. However, i think i have some legacy codes in the lock that may be duplicates of what I’m trying to add, but these legacy codes are not showing up in SLGA. Also, the lock routine maker does offer the option to unlock if certain conditions are met. So frustrating!

You might want to try factory resetting the lock so you can start from scratch with the codes. I did that on my Schalge Connects when migrating and currently have 6 codes on each.

1 Like

My Schlage locks can accept 30 codes. I’ve never pushed any of them past 10-12 and don’t know the limit in SLGA.