SmartThings Community

Z wave devices slow response

For years, I’ve had a few GE Z wave switches whose sole purpose was to trigger something else (i.e., one switch that told the under cabinet LED strips to turn on and another that served as a virtual 3-way switch for my living room).

I used the lighting automations to simply say when switch X turns on, turn on switch Y. This has worked perfectly until about a month ago. Suddenly, you’ll flip the switch and it will take close to 30 seconds for the other switch to trigger. I’ve tried restarting the hub (2nd generation) to no avail.

When I try to do the z wave repair tool it just tells me that the repair has started and the spinning icon never goes away (I’ve actually never gotten the z wave repair tool to work in the 5ish years I’ve had Smartthings.)

Any guidance on how to resolve this lag is greatly appreciated.

Read the Known Issues in the first post of this thread…

2 Likes

Thank you. I guess that means I just wait and hope they fix it soon.

If I remember correctly, I believe I saw somewhere a fix is expected at the end of April.

1 Like

Great. It’s definitely not a huge issue, just a minor frustration. I’m always happy to learn something like this is a known issue and not something that I have no idea how to troubleshoot.

I rarely have seen a zwave repair complete when I run it on the phone app. I find it best to launch zwave repair from the IDE and then click the link that allows you to monitor the progress so you can see any failures, etc.

1 Like