Z-Wave Devices... advanced utilities?


(Matt Martz) #1

I’ve been having a lot of Z-wave reliability problems ever since I switched from VeraLite (never had any problems) to SmartThings. The hubs are in pretty much the same spot. Right now the developer section says that every single one of the z-wave devices is inactive… which I know isn’t necessarily true… because if I unlock my z-wave lock it notifies me that it’s unlocked. When I first un-enrolled them from vera and enrolled them with ST (which I think I actually did twice) everything worked great for about a week.

When I repair the z-wave network using the hub utilities, it fails every time. Is there a way to do manual routing of devices? I know which ones are close to the hub and not and could build a path connecting the outer ones.

I have 1 door sensor, 2 door locks (kwikset, they usually work and are on extreme ends of the house), 8 light switches and an aeon multi sensor.

The house is a long rowhouse in DC… it goes back pretty deep.

Help/suggestions?

Thanks,

Matt


(Andrew Urman) #2

uhhhh ya, those inactive things aren’t always correct…We really need to fix that :ramen:

Is anything else broken other than that misleading active/inactive bug?


(Matt Martz) #3

@urman Half the light switches aren’t controllable by the hub. Other than that everything works ok


(Andrew Urman) #4

@mattmartz I would suggest contacting support. That is very unusual behavior.


(Beckwith) #5

@mattmartz

If you haven’t found a solution, turn on the logs when you do a repair. The logs can clarify routing issues. I’ve also found rebooting the hub can clear things up especially if you are including and excluding rapidly.


(Bobfrankston) #6

I have lots of such problems including the inability to connect new devices for periods of time and false reports of the status of my door lock! Are there diagnostic tools? Also, since the devices do not have a UID printed on them how do I figure out what is what if the label rubs off or if I make a mistake?


#7

There are diagnostic tools available at http://ide.smartthings.com.

That said, your best bet is to email us at support@smartthings.com with a list of which devices aren’t working. The most likely fix will be:

  1. Making sure you’re on the latest firmware. We have a beta version we can issue to your hub that includes some Z-Wave performance fixes - especially with GE/Jasco devices. This update will be sent out soon to our larger customer base.
  2. Issuing a Z-Wave Network Repair. Steps here.
  3. If you still can’t connect a particular device, make sure you’re excluding it prior to connecting it. This is like a reset.

(Bobfrankston) #8

OK – it seems the device is connected but is still flashing it’s red light. Very confusing. Of course without serial numbers I was lucky that the device seems to click when turned on and off. It also doesn’t help the signaling is open loop so the app shows a state change even if the device isn’t there. This is a serious problem with door locks. Well, at least I’m making progress … and being very careful to label the devices with the ID number as soon as I connect them.

Still need to figure out exclude and all that and might as well try the beta software.

BTW, I have done a network repair but it failed the first time without explanation. Worked the next.