Z-Wave Device in Metal Enclosure?


(Mike Coscia) #1

So I bought one of these intermatic z-wave modules for my pool. I used it to replace an existing mechanical time clock.

I used an old power cord to power the module and plug it in near the hub. The hub found it right away and it worked great. I installed in outside in the pool circuit panel, repaired the network, and it turned right back on. However, it does not respond when turning off sometimes. The module is about 60-70 feet from the hub, so range issue?

Second problem, the pool circuit panel is metal. So, as soon as I close and latch the door, I lose control of the module. The circuit panel is up against my shed, do you think plugging in a repeater might help? Or is this just not going to work?


#2

it’s likely a combination of range and the metal enclosure.

You could try just plugging a zwave plus pocket socket inside the shed (assuming the shed itself is not metal), then running a Z wave repair utility, waiting about an hour, and then seeing if you get signal to the pool switch.

If that doesn’t work, Many electrical boxes do have some kind of ventilation, although not all. If you can position a repeater in direct line of sight to the ventilation holes, you may be able to get signal through.

Another alternative if it meets code in your jurisdiction is to put the timer itself into a separate plastic electrical project box. Many are rated for outdoor use. And signal can usually get through the plastic even if you can’t get through the metal. And signal can usually get through the plastic even if it can’t get through the metal. Or you might even be able to replace the metal door on the existing box with a plastic door.

@Navat604 or one of the other electrical experts might have more ideas. :sunglasses:


(Mike Coscia) #3

Thanks JD. The shed is all wood and it has power running to it. I already ordered the Aeon repeater. Going to try that. I can also replace the light switch in the shed with a GE Toggle z-wave switch. Can also use one for my pool light as well, which is right next to the circuit panel.

I already looked online for a plastic door, but no luck. Guess I can always cut out the area in front of the module and glue in some plexi. Although, that might be a bit extreme, not to mention unsightly…lol. Only knock outs are for pvc conduit and they underneath the panel box.

I also did a bit a search and apparently the antenna is not mounted in the best location. One person mentioned drilling a small hole in the front of the module and pushing the antenna through. Wonder if that might work.

Either way, going to try the repeater first, then the shed light switch, then modifying the module.

I guess worst case scenario, I can get one of the Aeon heavy duty appliance switches, mount it outside the panel and run the wires through one of the knockouts. Not as clean looking, but should work if I can’t get the intermatic to work.


#4

The shed being wood is good, that may help a lot. If you can, I would return the Aeon extender and use a Zwave plus pocket socket instead. If that works, then you can consider getting a zwave plus switch for the shed and use the pocket socket somewhere else. :sunglasses:

Up to the third generation of Z wave, dedicated repeaters were useful. But we’re now at Zwave Plus, the fifth generation, and there’s no reason to use up a hop just for a single purpose repeater. Pretty much all current devices operate at full signal strength. And almost all mains- powered devices except smoke alarms now also act as repeaters. That includes light switches, bulbs, plug-in motion detectors, relays, In wall receptacles and pocket Sockets. And really the most important characteristic for situation like yours is range, and a Zwave plus device will have significantly longer range than the old extenders.

http://thingsthataresmart.wiki/index.php?title=Repeaters

Good luck, let us know how it goes!


(Mike Coscia) #5

Thanks again JD, I always appreciate your help :smile:. I was able to cancel my amazon order for the repeater and ordered an Aeon Gen5 Smart Switch.. Crossing my fingers that does the trick.


(Ray) #6

You can replace your pool circuit timer box with this plastic box. Not sure how many walls between your hub and your pool circuit timer box but if possible also try the repeater between the hub and your pool z-wave device.


(Mike Coscia) #7

Unfortunately, that box is too small. The panel contains two timers and 8 circuit breakers. It’s just a sub-panel coming from the house.


#8

That’s why I thought you might want to put just the new zwave device in a plastic box. :sunglasses:


(Mike Coscia) #9

I could do that, but everything fits so nice and neatly inside the circuit panel :grin:. My pocket plug is coming tomorrow in the mail, I’ll post how I make out with it.


(Ray) #10

If it didn’t work. Add another Z-wave Plus. It’s probably be easier than rewiring the panel :slightly_smiling:


(Mike Coscia) #11

No luck with Aeon Smart Plug. I also wired a GE toggle switch to the pool light, which is right next to the circuit panel, didn’t work either.

My shed happens to have an ethernet connection, so I brought the hub into it and plug everything up. Both the intermatic module and GE switch paired right up and turned worked without any issues. The intermatic module even worked with the panel’s metal door latched closed!

However, as soon as I brought the hub back in the house and repaired the network, nothing worked again. So it is definitely a range issue. Question is how do I fix it?


(Mike Coscia) #12

Here is a thought, what about a second hub? Can I install a second one on the same network and still have all devices show up in one area without switch back and forth between hubs?


#13

Short answer: No. Smartthings only allows one hub per “location.” Vera allows this kind of set up, but smartthings does not.

Longer answer: You could get a second hub and set it up as a second location on your same account. People sometimes do this for outbuildings. But they can’t share devices. Or smartapps.


#14

The GE toggle switch is Z wave, not zwave plus, right? That has a range about one third of a Z wave plus device.

When you used the Aeon gen 5 device, did you run zwave repair after putting it in the shed? And then how long did you wait until testing the connection to the pool switch? It takes time for the address tables to update after the repair utility completes , i used to wait untill the next day to be safe.

So for whatever test you want to run, a). Pair Everything to the hub. B) put everything in its final location. C) run the Z wave repair utility. We used to run these three times, but I think with zwave plus that’s no longer important. D) give the network time to update all the address tables, at least a couple of hours. E) now test.

A lot of people skip D) but you won’t get a valid test if you do.


(Mike Coscia) #15

Bummer on the second hub. Having two locations would be a pain…lol.

Yes, the GE toggle is just standard zwave. I can’t even get the Aeon to work more than 15ft from the hub. Works fine in the room adjacent to the hub. As soon as I move it to an oulet on my deck, which is maybe 15ft, the connection becomes intermittent. Sometimes it works, sometimes it doesn’t and when it does…its very slow to respond. I get no response from it when its in the shed. Maybe I got a defective unit?

I did remove and re-add the unit several times from the hub. Maybe the address tables got screwed up?


#16

The Aeon switch is a pain to pair, but once it’s paired it should work. So maybe it is just a defective device, it happens.

I think most people just go with the Dragontech, it’s simple and inexpensive.

http://www.zwaveproducts.com/shop/brands/dragon-tech/z-wave-plus-plug-in-on-off-switch

If you move it to a new location after you pair it, you do have to run a Z wave repair again.


(Mike Coscia) #17

It’s definitely paired, works fine in my bathroom, which is only a few feed from the hub. I move it outside, which is literally the outside wall of the bathroom and no response. I repaired the network, but it repairs instantaneously when I start it. So, not sure if it worked or not. I’ll leave it till morning and see what happens. In it’s current location its a clear line of sight to the shed and circuit panel, only 50ft or so. If it doesn’t work I will try the dragontech module.


#18

At least you got everything to work when the hub was in the shed even with the metal door closed, so that was progress. Now it’s just a matter of getting signal into the shed. Which is why zwave plus can make a big difference. :sunglasses:

The zwave repair utility is kind of confusing. The “finished” message that you get just means that the hub is finished telling the devices that they need to rebuild their address tables. It doesn’t mean the address tables have finished rebuilding. That requires every device to rebuild its own little piece of the tables, and it can just take time.


(Mike Coscia) #19

Ah, okay that makes sense. Maybe all the moving and repairing I did slowed the process down and it needs to work itself out…lol. I only have three powered z-wave devices too. A GE toggle switch in my basement controlling my heated gutters, the intermatic module by the pool and the GE Toggle switch next it. The rest are all just passive sensors, so I assume my weak network isn’t helping either. I ended up ordering a leviton VF+ toggle that I will install for the shed’s light (plan on using them for my whole house eventually) and one of the dragontech power plugs. They should be here Thursday.


(Mike Coscia) #20

Good news! I received the dragontech smart plug and leviton switch today. I added the plug to smartthings in the house and then moved it out into the shed. Bingo! Worked no problem with minimal delay. Just about instant on and off. I repaired the network and the intermatic module fired right up. There was about a 1 second delay, but I’ll take it! The GE toggle switch wired to the pool light also worked, although it had about a 2-3 second delay. I’m hoping it will be a little quicker tomorrow. This is all without replacing the switch in the shed with the leviton. I will probably do that tomorrow to help strengthen the mesh network in that area. I might buy a few more of those dragontech smart plugs and connect them more of my outside outlets. Sooo glad I got it to work. I guess that aeon plug was defective.