Z-Wave controlled bulb suddenly flickering randomly

I’ve had Z-Wave Dimmers connected to SmartThings since 2015. These past few weeks, I noticed the ceiling lights flickering. To settle it down a bit I have to hit the dimmer paddle button and decrease the brightness.

I looked and it looks like some firmware recently got update. Here is what my z-wave driver is using.


That date lines up around when the issue started occurring. Any ideas on remedying it? Is there a different driver I can install? I monkeyed around with the automations to see if I needed to redo some config but nothing seemed to work.

Brand/model of lights?
Name of the Edge driver… all I see is the date?
Which hub do you have?
Firmware version of hub?

1 Like

I see this in my recessed cans using LED flood bulbs. About a year ago I tried some “cheap” LED bulbs from a local store. Several of them started flickering about a week later. What I see is when a bulb starts to flicker it usually dies within a few months. I also have seen this when I have different brands of LED’s in the same ceiling circuit. (perhaps something to do with the electronics of the bulbs) I don’t know if this is related to the OP, but I’m interested and will follow along.

oof. Thanks for asking @jkp - I tried getting clever and posting this via mWeb before bed and…fail.

here you go

Lights: Philips Indoor BR30 Flood Light Bulb: 2710-Kelvin, 65-Watt (i think it’s this based no purchase history)

Hub: SmartThings v2 Hub
Firmware: 000.052.00021

@JKB121 you might be right. perhaps i’ve been lucky with these incandescent bulbs (i think they are. it’s been so long since i’ve changed them)

So the bulbs I had were actually from Sylvania

I just replaced them with Sunco LED flood bulbs that I’ve used in other places (dimmable bulbs) and it’s still the same problem

For kicks, I re-installed the Sylvania lightbulb because it actually worked for some [long] time.

When I log into SmartThings advanced web app, setting the dimmer level to 100% causes the bulb to flicker. Putting it at say 95% resolves it.

Update: 95% does not resolve it. Just makes it flicker way less

Did something change where the dimmer function/driver is setting 100% different than it used to?

For what it’s worth. I use the Sunco bulbs as well.

I found if I only replaced 1 or 2 they would flicker. If I replaced all 6 in the circuit at the same time they did not. I’m using a GE dimmer with a SmartThings Driver. Not thrilled about replacing bulbs that are still “good” though…