You are not authorized to perform

I had to removed all of my bulbs and re-install to clear up some issues. In doing so, I have 2 SmartApp’s that are giving me " You are not authorized to perform the requested operation.’ when I click on them to Edit and Remove them. Not really sure what caused the problem.

My Android app crashes so often I don’t even keep track of it any longer. That might be what caused the problem. I believe these were both created from the ‘Smart Lights’ app. I coincided with the problems ST had a few days ago.

Does anyone know why I would get this error and how to correct it?


I believe if you look in the logging tab as you try to uninstall you might see some debug that somewhat points to the issue. I’d also place a ticket at the same time. See which method finishes first.

Have you tried removing them from the web? If not, log into IDE and try to remove them from there.

Thanks :grinning: . I was just getting ready to create a ticket. Sometimes, the worse errors are fixed by simple things.

You’re welcome. Been there, done that. Glad it worked.

Trying to remove an open close sensor. I’ve removed all the smartapps except for smarting lighting which is saying I’m not authorized to preform request operation. Tried to remove it from things list, tried from Smart Lighting, tried from IDE. All give same red error message "You are not authorized to preform requested action"
Any ideas on how to fix this?