Yes, another Sonos discovery question

Good morning folks… So The last piece of the puzzle im trying to solve is getting my sonos added to ST, so I can use it with action tiles.
I have tried more or less everything from all the content I can find… Letting is discover for an hour, resetting this, redoing that.
I can see sonos in the app, but ST cant see it. Its on the same network. I added a static ip in my router (ubquiti amplifi HD).
It just wont get discovered.
Any ideas?
thank you

Is your Sonos connected by Ethernet or wireless? You tried rebooting everything…st hub, router? You said on same network but is it on same subnet? Only ask because some users like to isolate certain parts of their network that could cause issues.

I have rebooted all devices yes… and yes its on the same subnet as well. the sonos is wireless… I could discover it on wired if that might help, but it obviously needs to be wireless in its final spot.

I just hooked it up wired to the same subnet and nothing there either… Its a fairly old (very old) series 3… so If I Need a newer play 3 or whatever thats an acceptable answer, but I wasnt aware the older sonos speakers dont work…

Just FYI for after you get them connected and showing… ActionTiles CAN control the Sonos, but I’ve not been able to create an AT button for Sonos GROUPS (just individual speakers). This is a big deal for me because I don’t want to have multiple AT buttons. I’ve been asking around, but no one seems to have solved this issue. The AT button will have a pause and play icon on it. To control volume, you’ll need to tap the button, then a volume slider will pop up.

Im not sure I will ever get it connected… Ive read every article, ive done every tip/trick… still nothing… Kind of at a stand still. At this point if I do get it connected, I wont need a Groups button, as ill only have one speaker out there for now.

@Ryan_LaBarre, I’m not sure I understand your problem…

post:1, topic:163974”] I can see sonos in the app, but ST cant see it. [/quote]
What do you mean here? You can see Sonos in what app- Sonos app?

Are you using ST Classic app, or the new one? I use Classic… In Classic app, under ‘Marketplace’ -> ‘Things’ -> ‘SmartThings Labs’ -> Go into ‘Sonos (Labs). If you can’t add your Sonos from there, than you’re probably correct that the old Series 3 cannot be used with SmartThings. I have 9 of the old Play 1’s, which is the predecessor to the new Sonos One. I have had zero problems connecting them.