Yale Keyless Connected showing Checking Status

So I’ve had my Yale Keyless connected lock for a few year, got myself a ST hub and decided to get the Z-Wave module for the lock. It’s taken me many hours, with various resets of the Hub and the lock, but I eventually managed to connect the 2 devices. However, the resuilt of all those hours and frustration, is now an icon in my Smartthings App for the lock saying “Checking Status”.

Which if I open only shows this:

I was hoping for a little more. Anyone have this issue or have any suggestions?


I’ve not worked with locks, but often when you see a ‘Checking status’ message on the dashboard tile and a cloud icon on the details view it means the attribute hasn’t got a known value. In this case I guess it means it doesn’t know if the lock is ‘locked’, ‘unlocked’ or even ‘unknown’.

Thanks for the reply - it took a while but it eventually sprang to life so now works.


Yes, that can happen if the server is having trouble with the event systems and the cloud means it’s not able to retrieve the status of that attribute. It will usually fix itself after a while.

You may also want to look at this device handler for your lock which can bring our additional features and controls your lock might support (like Autolock, Privacy mode, Volume etc) into SmartThings

That does look interesting. My lock (Yale Keyless Connected Smart lock - UK) doesn’t appear in the list, do you know if it is compatible and what features would work with it? Is there an option for a trial login to see if it works and what features are available?


Yes it works but the features vary by what your zwave module offers. Typically it’s auto lock, privacy mode, audio and a few more for Yale Connected. Check your lock manual for what feature they module support (the DTH queries the lock module and automatically enabled discovered features, it not fixed). Unfortunately Smartthings doesn’t have a trial option at this time.

As it happens, I have this exact same lock type (Yale Keyless Connected Smart lock - UK) here in London, with the Yale SD-M1100 Z-Wave Module 2 installed. After some fooling around with relays I was able to get it to work. I have it set to RBOY’s Universal Handler which is installed to my Smartthings app (now new version only allowed). It shows up, but sadly with only the following status items in the app:
Lock State (Crossed out Cloud)
Audio - Unsupported
Auto Lock - Unsupported
One touch Lock - Unsupported
Alarm Mode Unknown + gear symbol
Alarm Sensitivity - Unknown + gear symbol
Battery 0% (I have just fed it 4 brand new Duracell Ultras, so not likely correct)
Tamper Alert - Not Tampered

IDE shows a bit more:
onetouchlock: unknown
audio: unknown
tamper: clear
lockStatus: Battery null%
alarm: unknown
keypad: unknown
checkInterval: 21600 s
codeLength: 0
scanCodes: Scanning
lockCodes: {}
sensitive: unknown
autolock: unknown

I haven’t tried installing LUM yet, but the above is not promising.
Am I doing something wrong?
Bit of a ST Newbie here…

I don’t think you’re doing anything wrong. I see a lot of blanks in the IDE (it’s pretty much empty) which means your lock is having trouble communicating with the mesh/hub. Try bringing the lock closer to the hub and do a refresh (pull “down” on the device page in the ST mobile app which will should trigger a refresh) and then once the lock starts responding you’ll see things populating.

Ooof. I’m gonna have to walk that sucker out to the lock in the garage, anna plug it in… Probably need to add another relay out there someplace, too.

Sadly, this didn’t change anything.

I took the hub down to the lock, wired it to an ethernet cable and powered it up right next to the lock, and the ST Hub light went green (OK). I sat there with it nearby for about 10 minutes and refreshed the phone app. Nothing seemed to change. Is there anything else I might doing wrong?