SmartThings Community

Xiaomi vs Aqara door/window sensors

So after seeing these sensors go on sale pretty often for about $7-$8, I decided to order one of each and give them a try. I heard a lot of complaints about pairing issues and could barely find any info on the Aqara sensors.
http://www.gearbest.com/smart-light-bulb/pp_257677.html
http://www.gearbest.com/access-control/pp_626703.html

I finally got them in the mail, and here’s what I found: They’re the same…

Aside from some aesthetic differences, they both work exactly the same. They paired almost exactly the same, they use the same device handler, and they report open and closed the same with the same distance between the sensor and magnet.
I personally prefer the look of the Aqara flavor, it was only at $6.99 at the time, and it was slightly easier to work with just because it has a button on the bottom instead of a pinhole for pairing purposes… but either way, they both seem to work just fine.

EDIT: The Aqara sensor did recognize as a “Thing” when pairing! Sorry I skimmed right over that. Another bonus for the Aqara sensor.

Here are some side-by-side comparison pictures, Original Xiaomi on the left, Aqara on the right:

Sensors & magnets:

Sensors:

Magnets:

Pinhole vs button:

I just paired them today and got them working with no issues whatsoever thanks to the device handler from @a4refillpad & a simple post from @Pbrain that describes the pairing process almost stupid easy!

Bottom line, these are totally worth every penny and I’ll be buying more!

FYI: These do not report battery status right away. I will update here with what mine do. The Aqara sensor is currently reporting 0%, the original is still showing –

Update1: The original sensor is displaying battery, and the Aqara sensor dropped offline. I popped the front off of the sensor to take it to the hub and pair it again, after going into pairing mode on hub and sensor, it came back online.
Update 2: The Aqara sensor hasn’t dropped offline again, but still reporting 0% battery. The original xiaomi seems to be working fine and reporting 92% battery.

11 Likes

Yep i myself bought like alot of them, they are pretty cool for the price. Again same issue on my side, Battery is stuck at 0%, i modified my DTH to make it show 100% by default (thanks to someone else in the st community) .

Heck i have so many extras, that im sticking them everywhere i can, even on a “lip” of my ac haha

If ever someone happen to find a fix for the battery display %, please let us know :slight_smile:

5 Likes

How did it go? Is the aqara still showing – for battery? or have somehow “woken” up :stuck_out_tongue:

so far no news, i changed my dth so its always showing as 100% kinda regret now, should hve went for the origional door sensor instead

u mean the xiaomi ones instead of aqara? these button batteries last a long time. so not tat “end of the world” rite. lets see if some genius can help us out :slight_smile:

Right, true i haven’t got one that went dead yet due to battery. But my OCD needs this

1 Like

My original xiaomi sensor is showing 91% and the Aqara is showing 0%. Both are functioning great!

hi i dont know where i went wrong but my device doesnt seem to change status from open and closed

Hi so this does happen to time to time, seems like their status got stuck.
I believe there was an incident yesterday regarding ST.
You can try again later or delete it and re pair it

ive tried removing and re adding still the same not showing any status change wonder if ive missed something when connecting it

I have not seen this thread until now so I am not sure if you have created new device handlers for the Aqara. I have the Temp and Window/Door sensor. I have been modifying the Original Xiaomi DH to get the Aqara support.

If you do not have a different DH please try mine and let me know if it works.

2 Likes

@ArstenA i have tried your device handler it is showing on my smartthings but doesnt seem to change from open status.

That seems strange. The original device handler should have given open/close status but had issues reporting battery status.

The new aqara DH should fix the battery reporting.

Are you getting the battery reported now?

Try a bigger magnet to trigger the open/close?

I just recently started using your DH and my Aqara sensor is now showing 100% battery. Idk if that’s correct or not, since my other sensor is showing 90%, but at least my ST app isn’t complaining about it anymore!

Yeah I am not sure if I am looking at the correct bytes or not. We will see once more sensors are deployed!

Thanks!
I updated my DH for the Aqara door sensors.
Now the battery shows 100%. will wait to see if it ever drops from 100%
Thanks again.

1 Like

I added 6 aqara sensors last night all dropped off within a few hours, purchased these as I saw that people were having less drop outs compared to the original and it being added as a thing, I have 10+ of the originals and just wanted a easier time adding

Has anyone mastered the pairing process? I found a great video https://www.youtube.com/watch?v=sciUre0HVl0 that shows how to add the DH and then the pairing process… the problem on mine is no matter how many times I tap the buttons to pair, it’s never showing up as a ‘thing’ on my SmartThings app. This is for the new Aqara door sensors, Aqara button, and the motion sensor. All of them same thing… paperclip or button pressing multiple times, holding it down, etc… not sure how to put into Pairing mode so that SmartThings hub will see it. :confused:

make sure you are using the bspranger handlers and not the a4refillpad

oooh, okay I’ll give that a try then. I was using the a4refillpad - do you think that will help with the pairing, or just general statement that the Device Handler for bspranger is better?