WT00Z-1 - Smartthings cannot find it


#1

I need some help/advice troubleshooting a WT00Z that won’t include into Smartthings.

I’ve installed a Linear WD500Z-1 dimmer switch and successfully included it into Smartthings. I’ve also installed a Linear WT00Z-1 accessory switch, and want to use it to control the WD500Z-1.

I have the AEON MiniMote and have successfully used that to associate the two devices, allowing the accessory switch to control the dimmer switch without Smartthings being involved.

But I cannot get Smartthings to find the accessory switch. I removed it from the MiniMote (successfully, as evidenced by the fact that once I removed it, it was no longer able to control the dimmer switch).

I also have plenty of other devices close to this one (the nearest only inches away), so SmartThings should be able to find it. For good measure I also executed a general exclusion on the accessory switch. Still no joy.

Any suggestions for how to proceed?

Ultimately my objective is to use the different groups in this switch for different purposes. For example:

  • single-click to turn on/off or dim the hall light
  • double-click to turn off all upstairs lights

etc…

If there was a way to achieve this with just the MiniMote, I would like to learn about that as well (it would eliminate the need to include the accessory switch to Smartthings).

Thanks!


#2

Was the minimote paired to the smart things hub before you try to use it to associate the two switches? That is, does the minimote show up on the things listed in your SmartThings account?

If not, the minimote was acting as a primary controller and established its own separate zwave network.

You need to have individually paired each of the three devices (the minimote, the master switch, and accessory switch) to smartthings.

Once all three show up on the things list in your smartthings account, then you can do the association.


#3

Yes, the minimote was/is paired to the smartthings hub. But even if that had not been the case, I excluded the accessory switch from the minimote before attempting to include it (the accessory switch) to smartthings.

That’s what I’m still unable to do: include the accessory switch to the smartthings network.


#4

You probably already did this, but just to be sure…

There’s a difference between excluding the device from the Z wave network and removing it from the association. The fact that it wasn’t able to control the master anymore might just mean that the association had been removed.

https://aeotec.freshdesk.com/support/solutions/articles/6000035629-in-depth-minimote-guide

I would issue a “general exclusion” from the smartthings hub and then try pairing it to the hub. Leave the minimote out for now. See the second part of this article:

Then make sure all three devices are in the things list of your smartthings account before doing the association again.


#5

Thanks JDR - yes I did exclude the device from the minimote. In fact I am not aware of any other way to remove an association (if you know of a way to remove an association using the minimote without excluding the device, I would love to know how to do it).

Then I also issued a general exclusion from smartthings “just to be sure”.

Edit: I just received a reply from Aeotec regarding how to remove an association. You simply follow the sames steps that originally created the association. The LED will blink red to indicate a removal of the association.


#6

I’m sure that’s frustrating.

Since you already did the general exclude, let’s consider the backbone of your Z wave network.

Because this is not a Z wave plus device, it has to actually be within one hop of the hub in order to join to it. It can’t use the other nearby devices until after it has been paired.

So how far is the switch from the hub?


#7

That’s interesting… I wasn’t familiar with that distinction.

It’s not far physically from the hub - about 36 feet. However, it is within a few inches of the nearest device, and there are a total of four devices between it and the hub. So it seems likely there would be more than one hop from it to the hub.

Should I move it next to the hub to pair, then move to its final location and rebuild the network? Obviously this wouldn’t be a trivial exercise since it is an in-wall switch. But I’ll do it if that’s what it takes.

Now that I’ve poked around some of the differences between gen 5 devices and prior devices, it seems worth mentioning that my smartthings hub is V1.

Cheers,

Rick


#8

That’s not quite how hops work. A hop is just the maximum distance the signal can go. A device won’t use every other device it can reach. It’s going to try to reach the hub first. No matter how many other devices are in the room. The following isn’t quite technically accurate but it’s close enough conceptually if you imagine that the device tries to reach the farthest away next device that’s within one hop. ( also remember that only mains powered devices can repeat, battery powered devices can’t. )

All of that is actually important for Z wave because you’re limited to a maximum of four hops to deliver a message. So you would run out of hops really fast if it hit every device.

Anyway 36 feet is probably far enough that it may have trouble making the initial pairing connection.

Fortunately, a minimote can act as a secondary controller and add a new device to the network. (Well, not all devices, you can’t add secure connections. But your auxiliary switch should be fine.) this is particularly useful for mains powered devices which are already wired in place.

So do the following.

  1. add the minimote to the smart things hub if it isn’t already paired. Make sure it shows up on the things list for your smart things account or none of the other steps will work.

  2. walk over to the auxiliary switch and use the minimote to exclude it. I know you’ve excluded a bunch of times before, but let’s do it one more time just to make sure we’re starting from a clean slate.

  3. after the exclude completes, wait three minutes.

Four) now use the minimote to include the auxiliary switch. As long as step one was done successfully, the minimote will now tell the hub about the auxiliary and it will then show up in the things list for your smartthings account.

Minimotes are really useful for including mains powered devices so you don’t have to walk them back to the hub and wire them up there.

Of course the other option to all of this is just to get a really long ethernet cord and walk the hub over to the auxiliary and you can do that instead if you prefer. :sunglasses:


#9

That did it! Whoo hoo! (I think).

Smartthings recognized a new device: “Z-Wave Switch Generic” (which I renamed “Hall Switch”).

I then used the minimote to associate the Hall Switch with the switch that controls the Hall Lights. So far so good - when I click “Hall Switch” manually, it operates the Hall Lights properly.

But… when I turn “Hall Switch” on and off in the app, it does not operate the Hall Lights. Nothing happens except the LED on “Hall Switch” toggles on and off.

I don’t have the ability to add SmartApps to this device - when I go to the SmartApps tab, it just says, “No Installed SmartApps” and there is no way to click to add one.

Am I doing something wrong, or is this where I have to install a custom app to handle the various inputs from this device?

Cheers,

Rick


#10

I think what you’re describing is the correct result. The auxiliary is really just treated as a on wall remote to the master. Toggling it on and off via network commands doesn’t actually do anything. A lot of people just kind of hide that device at the end of their things list by putting a z in front of it.

Anything that you want to do through SmartThings you should do using the master switch. The auxiliary is just a physical convenience on the wall.

You might Look in smart lights and see if it shows up in the list of switches. If it does, you would be able to have turning that switch on then trigger some other event to happen in smartthings. But it won’t use the association to trigger the master that way, you’d have to build the rule to trigger the master as well.


#11

Sounds good - thanks for your help in getting this far!
Now to roll up the sleeves to get it to the next level.