Will the Samsung Connect Hub get a firmware upgrade?


(Warren Strange) #1

I have some xiaomi aqara sensors which are useless with the Samsung Connect hub. They keep falling off the network. This has been reported by others. The smartthings firmware on the connect lags the V2 hub firmware - and I am suspecting this is the source of the problem.

I am wondering if I should just get rid of the hub and/or the sensors, or hang on them in the hope that the connect will get a firmware upgrade that will support these sensors.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

All non-WWST-certified devices are always going to have some associated uncertainty, regardless of which version of the Hub and App you use.

Since these are non-WWST certified, compatibility depends entirely upon whether or not the specific firmware tweak that makes them work with V2 is something that SmartThings has a reason to port to V3. … i.e., they may port it just to keep the firmware’s as “identical as possible”, or port it to “support a WWST device”. They won’t port it just to support a non-WWST device.


(George Hahn) #3

Did you try the process outlined here?

Make sure you’re joining the Xiaomi sensors close to the hub and leaving them there until they start reporting battery. Once it starts joining reporting battery you should be able to move it to where you want it.

This should work for Samsung Connect Home.


(Warren Strange) #4

The leak sensors reported battery status, but they dropped off the network a couple of hours after pairing. They are a couple of inches away from the hub.

The motion sensor is still online, but has not reported battery status since I paired it 4 hours ago. Fingers crossed.


(Warren Strange) #5

All the Xiaomi sensors are offline now, despite being located right next to the hub.


(Neal (www.zebrablinds.com / www.zebrablinds.ca)) #6

It takes a lot of pairing/repairing to get them to work, even on the v2 (I should know). But, once they stay on, I’ve never had one drop.


(Warren Strange) #7

I’m trying to find confirmation that someone with a Samsung connect hub (which has older firmware vs. the V2 hub) has had any luck getting them to stay paired.

I have paired / repaired these now about 10 times.