WiFi/Zigbee network setup and issues with Aqara Motion Sensor going offline

Ok, this is getting frustrating. This is an issue I suppose many are struggling with when setting up their smart home. I guess it has to do with router/SmartThings hub separation, channel interference and/or Zigbee mesh network issues.

Setup

  1. Old D-Link DIR-860L router, with 2.4 GHz wireless settings like this.
    D-Link 2.4 wireless
  2. Aeotec Smart Home Hub, connected via Ethernet to the D-Link router and placed just next to it.
  3. IKEA Trådfri bulbs, currently 9 in total. Some using @Mariano_Colmenarejo’s Zigbee Light Multufunction Mc and others using the stock IKEA driver.
  4. Aqara Motion Sensor (RTCGQ11LM), using @ygerlovin’s Zigbee Sensors Edge Driver [YG] 1.7.1.

Network
Neighbours have stronger network than I, with two extra access points, all using channel 10. Depending on how close I am to my router, this is how the WiFi channels look. Another neighbout seemingly using a 4G gateway on channel 6, haven’t yet identified who that is. Neighbours on both channel 6 and channel 10 sometimes going up to -70 dBm.

.

Zigbee on my Aeotec Smart Home Hub currently set to channel 24.

Issues

  1. The Aqara Motion Sensor pairs fine and works alright, until it doesn’t. It goes offline after awhile. Pressing the button once seems to temporarily take it back online and then it’s gone again. This happens also when I put it on the Smart Home Hub, that I have read in other threads may help for it to connect directly to the hub, rather than via Zigbee repeaters like the IKEA bulbs. I have never come to the point where the battery status changes from 0%, despite changing to a new battery.
  2. The IKEA bulbs work fine to swith on and off, but sometimes it takes awhile to connect to them in the app and the Circadian Lighting feature is unreliable.

Questions

  1. What could/should I do in terms of placement of router/hub and WiFi/Zigbee channels? If I move the Smart Home Hub I may have to connect it to the router via WiFi rather than Ethernet.
  2. Could the IKEA bulbs interfere with the Aqara sensors? I suspect they act as repeaters when online.
  3. As the motion sensors aren’t yet working, we are using the traditional switch to turn light on and off in the bathroom, which makes that IKEA bulb go offline/online. But even before we did this, the motion sensor wasn’t acting normal. But I suspect making the IKEA bulbs go online/offline may cause the Zigbee mesh network having to be rebuilt every time.
  4. I’m considering either upgrading to a Nest Wifi mesh network or getting an access point for the D-Link router (feels like Ubuquiti Unifi is too expensive). What would be better and could this help improve the Aqara motion sensor issue?

Grateful for advice on what to do! I got the Aeotec Smart Home Hub just some days ago, so the entire setup is new.

Changing Your router will have no affect on your Zigbee devices signal issue.
Try changing channel on hub to 14

Hi @westis ,

Aqara devices, especially sensors might be working in sticky parent mode. This means, they are not using automatic zigbee rerouting. I would suggest to re-pair Aqara sensors after all routers are in place and connected and to do it in the exact sensor location.

Would it be possible to collect the logs from the driver? Aqara should report battery status once in 1 or 2 hours, so log collection should be running for this period

Ok. And by routers you also mean IKEA Trådfri bulbs, acting as Zigbee repeaters? I’ve tried that now and put some cellular tape on the switches for other family members not to turn the bulbs off. However, I think this is similar to what I did the first time and then I never got to the point of the sensor reporting battery status.

I’ve never had the Aqara motion sensors report other than 0% battery. This time around it says RSSI = -69-71 dBm and LQI = 116-124 so far. By logs I guess you mean the History tab in the SmartThings app?

Thanks. Will try that, although Zigbee channel 15 would be even better? It’s closer to my Wifi channel 1, but further from the neigbour’s Wifi channel 10.

Hi @westis

Actually, if you have repeaters that could be switched off (like bulbs) it is better to switch them off during pairing of Aqara devices.
This is because if Aqara choices it as a parent and later you switch the bulb off, Aqara will have a hard time to find another parent

I mean the logs from the driver, that are collected with smarthings cli

I’ve installed SmartThings CLI and ran smartthings edge:drivers:logcat for the Zigbee Sensors Edge Driver [YG] driver. But getting Error: timed out. Haven’t used the ST CLI before and I suppose I must learn more.

@westis

I have seen similar reports and I suspect there is an issue with the latest CLI.
Could you please try an earlier version, perhaps

Ah, beta10 worked! Although I’m not quite what to read from this:

The motion sensor has now been online for 6 hours (no other Zigbee devices connected to the hub), but I still get battery 0%. I guess I’ll just wait and see and perhaps tomorrow I’ll connect a bulb and add a routine with the motion sensor switching the light on.

@westis ,

The log shows 2 events from the device, one with illuminance measurement and another that says the motion was detected.
Further, the motion goes off 30 seconds after this.
There is no battery update from the device.
I would suggest to try to collect the logs for more than 2 hours and see whether battery update is recieved

1 Like

After having disconnected all Zigbee devices and adding three Aqara Motion Sensors, they all reported 100% battery when I got up in the morning. That’s great news. Now I have connected the IKEA bulbs again and added some routines to switch them on when motion is detected. Let’s hope it will work fine.

But what if I want to add another Aqara Motion Sensor? I can’t remove all Zigbee devices and lose their routines and scenes, just to add another one to stick to the Smart Home Hub as its parent?

@westis

There is no need to remove all devices.
It is advised only to power disconnect any device that might be normally powered off and serve as repeater.
For example, smart bulbs that serve as repeaters and connected through a regular (dumb) switch.
Another example would be smart plugs that expected to move from one place to another.

There is absolutely no need to turn off (disconnect) repeaters, that have constant location and are always powered. For example, modules/relays, smart wall switches and smart plugs that are always in the same place and are always powered (even if they are in off state).

2 Likes

Sounds like you’re getting everything under control. If you’re interested, as a former field tech I can put up a post on best practices for laying out a smartthings network that will give you the best performance long-term, and that would address some of the questions you asked in your first post, but it will be pretty technical and I don’t know if you’re still interested. So just let me know. :sunglasses:

You might also find the following community FAQ of interest. First read post 11, which I will link directly to, then go up to the top of that thread and read the whole thing.

A Guide to Wireless Range & Repeaters - #11 by JDRoberts

Ugh, this. I have 5 Aqara sensors in a drawer somewhere because I occasionally move things around and they are by far the most unforgiving devices when in comes to finding a new route back to the hub. I keep thinking about giving them another go but the thought of finding and powering off every zigbee outlet for a couple of hours to get them to connect puts me off, not least because I just know something that’s currently stable won’t come back up right and it’ll be a day of fault finding

1 Like

I can give you my address if you want to find use for the Aqara sensors :wink:

But yeah, there’s always something to think about or tinker with in a smart home.

2 Likes