Why always RED!?!?

Okay I think I’m getting to the bottom of this now. Something is wrong with my fob or it often loses connection then gains connection again even if I’m just sitting at my house and when it does it text me with an “I am Hoping” and when it does that and even if I’m home it turns my lights to red automatically even though I do not have it set to change to red but I did at one time. At any rate I have removed the fob from any of my activities coming or going from the house or to the house also I noticed that in the fob setting itself it was set to turn on my lights when I came home so right there was an issue which I had removed from another parts of the SmartThings app but I had to remove it from there as well perhaps this was in the smart home monitor section which I was told recently was not the same as a SmartThings app. Anyway I have now removed that when the fob gets home that it turns on the lights however I have the lights to turn on when I do a get home back to geofence in the security settings. But the fob will not run and get home anymore because I’ve disabled it and the settings specifically disabling when the fob is seen as an “I am home” to turn on the lights I have disabled that functionality. The only way I have the lights to turn on is when my cell phone or device name enters the geofence now so we will see now how it works but that’s what I was talking about where there is multiple instances throughout the app or in the home monitor section versus other parts of the SmartThings app where it has settings for the same device but you need to go through and make sure they’re changed in both locations I think that might have been my issue we’ll see when I leave and come back tomorrow from work.

You can see a list of all apps controlling your device/light. Just open the device from your “Things” list and select the tab named “SmartApps”. This will show you a list of all SmartApps that control that specific device, so you can make sure you have removed anything you no longer want.

Don’t even start to get into that until you’ve learned more of the basics. LOL Don’t try to climb mount everest before you know how to crawl. To run those I have 3 smart apps, a nodejs applet running on my home network and bunch of pistons in WebCore. If that doesn’t make any sense, then you’re not ready yet. :slight_smile:

You’re still getting the f&%$(ing red light??? OMG…dude, I can’t help you anymore. We’ve gone over what it could be. Do you have the scene set correctly to turn them white? If so, then I don’t know. Sorry.

Thank you. I went into “Things” then went to the lights which turn red and they clearly do not have anything associated or telling them to turn red. Here are screen shots so you can see the color is grayed out thus supposed to not change color.

Hey Ryan,

I did a lot of hose cleaning in the app and have not left my home yet to test so it may work finally now. I think they key was to remove my fob as it was acting up anyway.

I have already set up the lights to turn red and dogs barking play to my Sonos speakers when the alarm is triggered so I am no pro at this but I am no beginner either. Just as I was able to choose “dogs barking” when alarm goes off could I not just select some other file for when I come back home? Thank you for telling me what you are using I will download those three smart apps and try that but FIRST will fix this red light issues which I may already have. Lots of people are talking about Webcore so that is defiantly something I will be installing and trying after I get things stable first as I want them now. I am familiar with applets and smart apps but not pistons or webcore yet so I will be researching those before even trying the audio alerts. Thank you

Ok, so I am sitting here at my home have not opened any doors or anything and I get a text message and alert on my phone that says “I Am Home”… Well I know I am home, why did it just do that? Well I looked at the log and it says about 45 mins my fob “has left” which it didnt, and then “arrived” which invoked that message.

*** The good news it my lights did not turn red or turn on like they usually do! That is probably because I fixed that in settings last night.

Sounds like my fob is losing connection randomly. Is that normal?

The fob works by basically pinging the smartthings cloud via your zigbee network every X seconds. Successful ping = home. Failed = away. There are 4 (or more) possible reasons for false reports:

  1. your zigbee mesh is weak
  2. your internet is out
  3. a cloud problem
  4. the fob is busted

FWIW, mine has been doing the same the past 2 days and it had previously been reliable. Email support and see what they say (i did this morning and haven’t heard back yet). Do you have mobile presence setup on your phone?

1 Like

My zigbee network is strong for sure and my internet is up and solid the fob should be fine.

So this effeminately sounds like a cloud issues because exactly like you are saying my fob worked flawless for over a year now and just in the last two days has been having this issues which seems to coincide with Samsung releasing the “Smart Connect” push. hmmmmmm

make sure to email support. the more problems they hear about one thing the more traction it gains. In the man time i’ve removed the fob from automations and am solely using mobile presence.

1 Like

would be happy to. Do you have a specific email address or link to do so?

https://support.smartthings.com/hc/en-us
support@smartthings.com

2 Likes

So my fob was definitely an issue. This is the first time I have come home into my geofence and both the alarm turned off and my lights were white not red! But I dont think it performs an “away” properly setting my alarm to “I’m Away” I have three options to trigger those which are my fob, my cellphone, and a picture of me(which I think just means “device”) I now have just put it on “cellphone” and it worked coming back into geofence will see what it does tomorrow when I leave it.