Why always RED!?!?

Just throwing this out there, but have you by any chance had the opportunity to try this with a different brand bulb? I finally had to pack up all the Hue stuff I had because of the frustrations with exactly what you are going through, changing color when you want or don’t want a default color or just plain disconnecting all the time. The SAF was at an all-time low, lol.

1 Like

Did you have a hue bridge or did you connect the hue bulbs directly to ST? I have had hue bridge/bulbs for over two years and never experienced any issues. :slight_smile:

1 Like

I started with the round bridge, upgraded to the square bridge for Homekit, I’ve moved it into different rooms thinking it was interference, it didn’t matter. I mean we’re talking line of sight with maybe a single closet wall in between, 20 feet max.
I actually still have 2 Hue lights running, one is a Bloom that is supposed to turn on at sunset and then off at 11pm, no color change, all through Smartthings. It doesn’t ever turn off, but it will via the Hue app, which says it is already off. The other is some newer strip lighting under counter in my garage, I have it turn on and off via a button push from a Lutron Caseta switch, I’d say that 6 out of 10 times it either doesn’t turn on or off. I do this same thing in other rooms (not Hue) and it works every time. I even have the Hue wall switch plate and even it won’t turn them on or off sometimes and its like 5 feet away.

Did you set the I Am Home to turn the color back to white?

1 Like

Thanks for all the help everyone! I will try and answer all the questions here in this one post:

I do have a Hue Bridge connected are you saying there is a way to connect the Phillips Hue bulbs directly to the Smartthings hub/ I think I had heard that is possible but I think I will be losing some functionality or no? If I can eliminate the Phillips Hue bridge and connect my Phillips hue bulbs diectly to my Smartthings hubs without losing ANY functionality that would be great! However I am skeptical for instance anytime I add devices to Alexa it says “discovering devices… If you have a Phillips Hue Bridge press the button on it now.”

When I go to the official “Hue” app on my phone it sees the bridge but is asking me to “Set Up” I think I originally connected the Hue bulbs with the official Hue app but it was lacking features so instead I am using the “Hue Essentials” app which is AMAZING!

On that note the “Hue Essentials” app just came out with an advanced “entertainment” pay for premium feature which I did which has a “Police lights” feature which makes the lights flash red and blue like actual police lights which is EXACTLY what I want to have go off when my alarm is triggered! Anyone know how to integrate that Hue Essentials app feature into Smartthings when my alarm is triggered that would be perfect!!! https://play.google.com/store/apps/details?id=com.superthomaslab.hueessentials&hl=en

I have set up a rule for when I arrive to set those lights to just white instead of red but I have not integrated it yet and not sure if it would even work since it is already turning red when I arrive. I made a “Scene” to set those lights to WHITE instead of red so how do I have that scene run when I get home and how to I make sure it runs AFTER the red lights are triggered or it would be useless?

I definitely added color red ONLY to the when “alarm is triggered” never to my “I’m Home” mode which is when it is turning red when I dont want it. I made sure to go back in all the settings in all scenes and even have removed red in all instances yet it still turns red when I come back still!

I do have Osram Lightify bulbs I could try instead but they are far more unstable than the Phillips Hue bulbs. My Phillips Hue bulbs work perfect this is the only issue I am having and I am almost positive it is on the ST app or hub that is causing the issue.

I just did a test. I told Alexa “Alexa, turn off office light” and she did. Then I unplugged my Hue Bridge and said “Alexa turn ON office light” and she said “im sorry I cannot find office light” then I plugged back in my Hue Bridge and asked Alexa again “Turn on office light” and this time she did. So I know for sure, at least for the Alexa AI voice activation it is going through my Hue Bridge.

I have what I think is the latest Hue Bridge which is square in shape.

I have gone in and made sure I have set the “I’m Back” to turn the lights on. There is NO COLOR option there just on or off. Now if you are referring to the place that has the color options that is in … actually I cannot even find now where I can add the color as I did before in the ST app. Also I done see a way you can modify “Home” MODE I think that is just a status and you cant customize it if so can someone please show me how to in which part of the menu system in ST app?

If you have the bridge, use the bridge.

I’ll leave the other responses to other people since at this point I really have no idea what’s going on with the app, it’s been almost a year since I’ve been able to use it. :disappointed_relieved:

1 Like

That’s a lot to read through, but it’s this easy:

  1. create your scene with turning the LIGHTS on AND setting them to your desired shade of white

  2. add that scene to your I’m Back routine. Do not add the bulbs to the turn on section.

image

2 Likes

HI Jeff,

One other thought…is your Smart Home Monitor being triggered when your are gone or when you arrive home causing the lights to turn red? I have the same setup and when I dismiss a false alarm the lights turn back to the previous color.

Jason

1 Like

Good point. I was wondering the same thing. I am not a pro at the Smartthings app but learning more as I go. So on my dashboard screen I have three icons showing with the icon of the person wither their hands up in the air. I assume that means I am in the “I’m Back” mode as that is what the green icon shows on the routine screen?

I am indeed home and the alarm is set to “Armed (HOME)” so why I am seeing the icons of the “I’m Back” with the person with the hands in the air? Ah forgot to mention exactly what my three icons are. One is a picture of my face I must of put on there which is my name, another one is my cellphone name, and the third is a fob(a Samsung presence sensor on my key-chain).

Jimmy thank you! That was a big help and it seems to work while manually doing a “goodbye” and “im back” the true test will be when I leave the geofence and come back which I will see tomorrow. The big difference because making a scene to control the lights vs just adding them in “'i’m back” is that you get to change the color temperature, actual color, and brightness. Otherwise doing it in the security or other mode it simply just lets your lights turn on or off and must default to what they were prior in the smartthings app.

No, that is not what that means on the routine screen. There is no “I’m back” mode. I’m back is a routine that runs to set a bunch of other settings. This of it as a program. Your routine makes things happen, such as turning on light, activating scenes, unlocking doors, opening doors, arming your alarm system. The location modes are something completely different. The defaults there are home, away and night. The only reason that routine shows up with the green guy with his hands up is because that’s the icon that ST decided to use. If you run the goodbye routine the green guy will still be there with his hands up.

And we told you that with your lights two days ago!!! I’m just glad you finally got them working.

thank you that helps me better understand the app. Wait, is there any video or tutorial even to use the Smartthings app? Like a good one that goes over all the full features?

Here is a picture of the screen I was referring to. Notice my favorites I put on there there are three that I think may affect my geofence.

I know the “Cellphone” is my cellphone
I know the “Fob” is the fob on my keychain
But what is the one with the picture of myself? I put that picture on there I know that but that is a person. How does a person differ than a fob or a cellphone as far as running routines and modes?

Yes you guys told me that two days ago and I created the scene but no one said turn off the light settings also in that mode so I think by having the old light settings turned on that was not allowing it to change like it would run the scene first to put my lights on the scene but then divert to the default lights on settings.

Anyway I am going to test the geo fence right now leaving my house then coming back brb with results…

Now things are getting more frustrating. I was testing out the geofence since things work fine as they should when I perform a “Goodbye!” and an “I’m Back!” that all works perfect as you guys have described in helping me here thank you!

The problem is geofencing. When I leave now my Smart Home Monitor section of the Smartthings app does not go to “ARMED (AWAY)” as I have instructed it to. Nor does its go to “DISARMED” as I have instructed it to in the Smartthings app. I have tried double checking, saving, then closing app and starting again.

I am also seeing that my keyfob, which has a brand new battery and “100% battery” is not showing that I arrived home as I did about 30 mins ago. It showed I had arrived right when I got home but now it is grayed out.

In the modes and security sections it has places to “set alarm to Home if everyone leaves” and I can clearly see where I can check 1 or all of 3 different things I just dont know what my device name means?

In other words I want my alarm to arm/set to home, when any of the three leave (my keyfob, my cellphone, or “me” my device name in the app) *all three are listed and can be checked or unchecked.

Then when I come home, either (my keyfob, my cellphone, or my “me” device name in the app) enters my geofence after that.

I think there are several places to put these settings in the Smartthings app and if you have any conflicted or different you get unexpected results like I am seeing.

I would be happy to delete all my settings and start new but that is a ton of work for all my “things” I would need to repair and rename and set up all new rules again including my cameras, speakers, light bulbs, door locks, sensors, siren, a bit of a nightmare.

Is there a way to back up your device settings or devices configurations and reinstall the app new? Maybe tat is what I need to do?

Testing geofence is the worst as even with it set to the smallest radius I have to get in my car and drive out of it then back in it each time and that becomes very time consuming.

I am very appreciative of everyone’s help on this so far by the way!

And yes I have made that scene to just turn the lights to white when I get home and applied it however this now seems to be a geofencing issue specifically

In the modes and security sections it has places to “set alarm to Home if everyone leaves” and I can clearly see where I can check 1 or all of 3 different things I just dont know what my device name means?

Do you mean, within the routine? Can you provide a screenshot from your phone of what you are referring to because your descriptions don’t match what’s actually in the ST app. And I’m sorry to be a dick but the terms you’re using mean different things in the ST architecture. Modes have nothing to do with SHM. They are independant.
And when you say “my alarm” do you mean SHM?

Also, Geofencing will update quicker if you open the ST app on our phone, then hit home, then open your map app. That way it will update your location faster.

1 Like

awesome tip thank you!

I am not sure but you are explaining this well to me. Now I know what SHM means now (Smart Home Monitor) and that is NOT part of Smartthings routines but separate? Is there a Smarthings app for dummies video or something like that?

If you post a screenshot from your phone, that would be very helpful. For example, here’s the routine I run for “I’m Back”.


As you can see, I disarm my alarm, turn on some switches and open my garage door. Within the “Automatically perform I’m Back when…” is where I have my presence sensor (my phone) arriving home.

There are literally thousands of articles up on this forum. And rather than post, why don’t you try searching for what you’re trying to do. I guarantee, someone else has had the question before.
You don’t want to make your geofence too small because then it’s going to have you leaving in the middle of the night and your alarm will arm and then you’ll wake up your neighbors and you don’t want that. I only use my geofence to arrive home and as a backup when i leave. My goodbye routine i run with a button by my door. That way I know everything is set when I drive away.

here is my screenshot. As far as I know!

back|243x500 everything looks proper.