What is the Apple Watch app supposed to DO?


(Different Computers. So happy with Indigo.) #1

I have, as far as I can, “managed” my ST on Apple Watch from my iPhone.

That is, the app shows. But aside from that, it doesn’t DO anything. It just brings up a screen saying “Manage Apple Watch from My Account in SmartThings.” And when I do that, I get settings for the widget, but not the watch.


(Jimmy) #2

They are one in the same. The routines you choose to show in the widget show up in the watch app.


(Different Computers. So happy with Indigo.) #3

Mine don’t. :disappointed:


(Jimmy) #4

what version of the iOS app are you on? Mine actually says “Manage Widget and Watch” under My Account in the app. Sounds like maybe your app is an old version?


(Different Computers. So happy with Indigo.) #5

took most of the day, but my watch finally updated and now the routines show up.

Thanks guys.


(Karl Laun) #6

This thread looks to be several months old, but I’m encountering the same type of issue. I’ve recently installed several software updates, so it’s unclear which of them might have broken the watch app. I’m running iOS10 on an iPhone 6+ ahd have an original Apple watch running WatchOS3. I just recently updated to the latest SmartThings mobile app. (Sept 2016)

When I went to the SmartThings app in the dock on the watch it initially displayed the message “Manage Apple Watch from My Account in SmartThings”. Doing that, I found the four sliders to activate the scenes were all selected OFF (I had them all ON in the previous version). I turned them back ON and hit Done, Returning to the selection screen showed them all OFF again. I tried again about a day later and found that the watch app had mysteriously started “working” in that the manage message was gone. Now it displayed 2/4 scenes, ironically the 2 that I would probably never use. Still the same behavior from the mobile app in that any changes weren’t retained after hitting Done.

Is this a known issue, and is there a solution?

Thanks.


(Marc) #7

There is a known issue where the Manage Widgets/Apple Watch routines get turned off every single time the ST Mobile app is logged out/upgraded. It’s quite annoying, especially when you have 20 routines that you have to toggle back on. It’s been this way since they released widgets/apple watch and they have never acknowledged that they would resolve it. Tagging @slagle and @jody.albritton.


(Geko) #8

I had the same issue. You have to do this dance several times for all the sliders to turn on. It appears to be a new bug introduced the latest app version (2.2).


(Karl Laun) #9

Well, I followed the advice given here and kept trying to activate the sliders over and over. I’d say it took 50-60 attempts, but eventually all the scenes “took” and remained in place after returning to the settings. They all showed up on the watch app. HOWEVER, they do absolutely nothing. Hitting any of the choices on my watch causes a slight dimming of the button (confirming the press), but nothing happens. Giving up for now, it seems this app isn’t ready for watchOS 3.


#10

It used to work fine, in that tapping a widget on the watch would cause that routine in the mobile app to run.

They broke it with the most recent SmartThings mobile app update and now it just doesn’t work all the time . So there’s no point in trying it right now.

They said it will be fixed in the next release of the mobile app.


(Redfred Garett) #11

How about an app that informs you when you lose the iPhone connection?