What Edge driver for Inovelli dual channel outlet

Note that the official Edge driver from Inovelli now supports the NZW37 and NZW97. I’ve tested on the '97 and it works great.


Up until a few days ago I had child devices for my NZW37, and each channel could be named and controlled independently from each other. All of a sudden the child devices stopped working independently from each other. When I would turn on either child devices, both outlets were controlled together. I had beenh using the old DH from Inovelli and it worked great.

I installed the Inovelli Edge drivers. When I try to change the driver to use one of the Inovelli drivers I get a message showing there are no drivers available. The switch has been assigned “SmartThings driver for Z-wave switch devices.”. Using this automatically assigned Edge driver both plugs can be controlled independently from within the ST app.

When I discovered the device in Alexa the plug is found, but I can only control both channels together.

What do I have to do so I can use the Alexa voice commands to control each outlet independently from each other?

From Alexa:

You must have one of the versions of the NZW37 that the Inovelli driver does not yet support by fingerprint. Go to https://my.smartthings.com/advanced and in the Devices section, capture the Manufacturer Code from your device. We can get that to @erocm1231 to add it to the official driver.

The dual channel device drivers have the ability to create child drivers for your 2 relays, so you can control them with Alexa. See this link with more details:



Thank you for reaching out to me and trying to help me get this working. The Manufacturer code is 0312-B221-251C.

I can’t look at the specific list of devices that the Inovelli driver has fingerprinted, but this one was on the list of the old driver and Eric mentioned that he used that list to create the new Edge driver.

Are you sure the correct Inovelli driver is installed?

Check on my.smarthings.com/advanced again, look at your hub, in the Drivers section. Do you have the correct driver deployed to your hub?

I am using the “Inovelli First Gen” driver. All of the drivers in the library refer to Red, Blue, or Black switches or dimmers, or 2-in-1, or 4-in-1, or a light.

After selecting the 1st gen, I tried toggling the switch 1 and switch 2 values between 0 and 1 to create a child device for each channel. No child devices is generated.

Are you sure? The child device is created in the room with your hub, not in the room with the device.

Yes, I am sure. Just to double check, I checked every room. It was kind of a painstaking process since I have 74 devices right now. I also refreshed the https://my.smartthings.com/advanced/devices page and there were no child devices there either.

Not sure then. I just tested it with the same driver and it created a child device no problem. I just enabled the toggle and the device was created.

Just checked the devices page and the child device shows:

As a last resort, I deleted the plug from SmartThings and performed a factory reset on it. When I re-added the plug to SmartThings it immediately picked up the correct Inovelli Edge driver, and I was able to successfully add the Child devices. I appreciate your time and effort you spent trying to help me figure this out. I hope this thread helps anyone else who might be facing this issue.


Can someone explain what is a child device?

A simple example is when you have a switch with 2 or 3 gangs (buttoms) they are the device tiles created to control the 2nd & 3rd gangs.

1 Like